Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.


Error when compiled with qt 4.8

  • spieb

    i just saw that you throw an error if compiled with qt4.8. Couldn't you make
    this a warning, I'm compiling on 4.8 with all my systems (win, unix, osx) and
    didn't experience any problems yet. Now I can't compile anymore without
    changing the source or downgrading my qt :(.

  • spieb

    On OSX it is 4.8.2, to look up the other systems I have to wait until tomorrow

  • spieb

    Ok, i just saw that I use 4.8.1 on Win and Ubuntu, don't know the mingw
    version right now though

  • Tim Hoffmann
    Tim Hoffmann

    So, you're using Qt 4.8.x and mingw, and the viewer works? Then I'd be really
    interested in the mingw version.

    Benito, are you sure, that it doesn't work on OSX? Anyway is it relatedt to
    the same bug report I linked above? I still suspect, that this one a mingw
    issue concerning insufficient memory alignment. However, that has to be
    checked further.

    BTW: Did anyone compile using Qt 4.8.x and MSVC?


  • Anonymous

    Because I don't know how (and where) to define "NO_POPPLER_PREVIEW" I've
    commented the part that throws that error:

    /*#if (QT_VERSION >= 0x040800) && (defined(Q_WS_WIN) || defined(Q_WS_MACX))
    #error Warning: The internal pdf viewer does not work (i.e. crashes) when compiled with qt4.8.x on Windows/Mac
    #error You should either downgrade to qt4.7.x or disable the internal pdf viewer by defining NO_POPPLER_PREVIEW

    I have used Sumatra since I switched to the SVN versions of Texstudio.

  • So you are not using the internal pdf viewer at all?

    Well, then it won't bother you if it crashes...

    On 08/29/2012 01:04 AM, wrote:

  • Robert

    Like spieb mentioned, TXS will not compile without qt4.7. I did not experience
    any crashes using the internal viewer on my Mac OSX 10.8 that wondertree
    reported. I used the internal viewer extensively. I side with spieb in adding
    a warning if this is indeed the case for the SVNs. Downgrading to qt4.7.4 is
    problematic using brew as qt4.7.4 does not compile and install via this

    You need to switch to the last version of Qt if you installed 4.8 or higher.
    List all version of qt available via brew
    $ cd /usr/local/Cellar
    $ brew versions qt
    Run the git command next to the version of qt (4.7.4) you want to install. and
    install qt version using brew.
    $ git checkout 83f742e /usr/local/Library/Formula/qt.rb
    $ brew upgrade qt
    List all install versions of qt. and switch to using any of the installed
    $ brew info qt
    $ brew switch qt 4.7.4

  • spieb

    I also use the internal viewer extensively, never had any problems yet, on OSX
    i compile a X64 version. It might be that the problem wondertree is
    experiencing is caused because of the way it was installed. I installed qt
    from homebrew (a command line installer) with the option "brew install poppler
    --with-qt4 --enable-xpdf-headers". wondertree instead used the gui version and
    had to manually fix a lot of stuff (like adding empty folders to get rid of
    warnings). I never had to do such things, it worked out of the box for me (at
    least with the changes to i described).

    For windwos I have no idea where to find the mingw version. It just says "Qt
    4.8.1 for Desktop - MinGW (Qt SDK)". I have to just MinGW since MSVC throws
    numerous compilation errors. It looks like i compiling a 32bit version under
    windows. At least my qmake call includes "win32-g++" and also i call
    "mingw32-make.exe". It might be that I use a different libpoppler-qt4 version
    though. I remember that the first time i was compiling texstudio I had a lot
    of missing dll's that I scratched together from the qt installation directory
    and from some google searches. My libpoppler and libpoppler-qt4 libs have the
    creation date 05.02.2012 14:07, but i didn't compile it myself.

  • Tim Hoffmann
    Tim Hoffmann

    Could you provide the libpoppler and libpoppler-qt4 versions you use for a

  • Robert

    Benito. Thank you for allowing Qt4.8 again!

  • spieb

    I just noticed that im using the same libpoppler dlls that you provided with
    the official texstudio 2.3 release (SVN2471). However I had to use updated qt-
    dlls to even get texstudio started. I installed the qt version "QtSdk-online-
    win-x86-v1_2_1" and than copied the relevant qt-dlls from ...

  • Tim Hoffmann
    Tim Hoffmann

    Ok, I'll look into that direction.

  • I compiled using qt 4.8.1 for svn 3240, it seems ok. if there is a specific
    document to test the internal pdfviewer, I can also do some tests

  • Tim Hoffmann
    Tim Hoffmann

    There is no specific document. The error I reported occured for every document
    as soon as the first page was loaded. Can you please give additional
    information on the build: which compiler are you using. Where did you take the
    dlls from (qt and poppler)?

  • Sorry, incomplete information:
    on windows 7 64bit using Qt SDK with mingw.

    Where did you take the dlls from (qt and poppler)?

    I grabbed them sometime ago, but I cannot remember exactly :(