Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#3468 LURE: Crash in 0.11.0 SVN

closed-fixed
Paul Gilbert
5
2007-12-02
2007-11-30
Joe Davison
No

If you Operate the Rack that the Serf is tied down in, ScummVM crashes.

Thia is the latest SVN.

Discussion

  • Logged In: YES
    user_id=166507
    Originator: NO

    Please, attach the save.

     
  • Paul Gilbert
    Paul Gilbert
    2007-11-30

    Logged In: YES
    user_id=51899
    Originator: NO

    Also remember to include the details of which language you are playing, and what system you're running it on.

     
  • Paul Gilbert
    Paul Gilbert
    2007-12-01

    • assigned_to: nobody --> dreammaster
    • status: open --> closed-fixed
     
  • Paul Gilbert
    Paul Gilbert
    2007-12-01

    Logged In: YES
    user_id=51899
    Originator: NO

    I'm going to presume that you were playing the German version, since I discovered that many of it's animation offsets were wrong in the data extract tool. I've committed a corrected lure.dat, so you'll need to grab a fresh copy to resolve the issue.

     
  • Joe Davison
    Joe Davison
    2007-12-01

    Logged In: YES
    user_id=1828858
    Originator: YES

    Oh sorry, it's the English version on Win32, yeah sorry I was in a rush.

    I didn't provide a save because it's so near the beginning, I assumed it didn't matter. Also because it did crash, I couldn't save.

     
  • Paul Gilbert
    Paul Gilbert
    2007-12-01

    • status: closed-fixed --> open-works-for-me
     
  • Paul Gilbert
    Paul Gilbert
    2007-12-01

    Logged In: YES
    user_id=51899
    Originator: NO

    Alright, this is being reopened again - I tried several times with the English version, but I haven't been able to get it to crash. What error message, if any, did it give you?

    If you can get it to happen repeatably, try making a savegame in the room before you do the action and posting it. Also, from a fresh game try opening the Debugger with Ctrl-D and typing 'enter 4' to jump directly to that room - see if it crashes that way as well.

    As a final resort, try getting the lastest copy of lure.dat and see if it makes any difference.

     
  • Joe Davison
    Joe Davison
    2007-12-01

    Logged In: YES
    user_id=1828858
    Originator: YES

    No error message, simply crashed. I'll get the very latest SVN and try it again.

     
  • Joe Davison
    Joe Davison
    2007-12-01

    Logged In: YES
    user_id=1828858
    Originator: YES

    Yes I've definately suffered the crash. Ratpouch screams that he likes being small and inadequate then clicking on the dialouge box to close it, the game crashes.

     
  • Logged In: YES
    user_id=166507
    Originator: NO

    No way. You just most probably do not see the message. Please, read our FAQ at http://www.scummvm.org/faq.php#id2551089 to learn how to see the message and provide that.

     
  • Paul Gilbert
    Paul Gilbert
    2007-12-02

    • status: open-works-for-me --> closed-fixed
     
  • Paul Gilbert
    Paul Gilbert
    2007-12-02

    Logged In: YES
    user_id=51899
    Originator: NO

    I discovered what was likely the cause for your crash - the game previously allowed you to interrupt an active animation sequence (such as the player operating the rack), which would cause a crash when the game tried to set the frame to a movement frame that wasn't available at the time. The newest version fixes this, but you should test your older version to see whether this was the reason for your crash.