#16 Python 2.2.2 + PyMPI 1.3 + OSF1 5.1 failed !

closed-fixed
None
5
2005-02-23
2003-03-17
Anonymous
No

Some days ago I've tried PyMPI, it was working pretty
well.

Today I try to generate PyMPI with Python 2.2.2 on OSF1
5.1
(COMPAQ Tru64UNIX).

All seems to work well during configure & make but,
when I try
"test" with the Unittest/PyMPITest.py, the script
SimpleSend failed for 4 processors.

Output looks like:
...
Cartesian <0>
CalcPi<0>
SampleMIMD<0>
NullComm<0>
Pickled<>
ReduceSum<0>
SimpleSend<

We then enter in a loop for ever endded with CTRL D !

My mpirun use "prun -N1 -c1" (one MPI task per node).

What can I do ?
What is your Python release number ?
Does it works bettre with Python 2.3 ?
/\/\/\/\/\-- Speaking for myself, and my employer
--/\/\/\/\/\ Paul LE TEXIER
CEA/CESTA
BP 2 EMail :
letexier@bordeaux.cea.fr
33114 Le Barp Cedex Tel : +33 (0) 557 04 49
53
France
\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/

Discussion

  • Patrick Miller
    Patrick Miller
    2005-02-23

    • assigned_to: nobody --> patmiller
    • status: open --> closed-fixed