Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#69 Policenauts End Credits in PEOpS Soft GPU 1.18

open
nobody
None
5
2009-05-03
2009-05-03
slowbeef
No

At the end of Disc 2, there's a movie that plays normally followed by end credits (usual staff roll over music). I found graphics only show up with the P.E.Op.S. Soft GPU Plugin 1.18 and then, they don't scroll correctly. Other Pete's plugins I've tried show no graphics during this credits sequence. They do a sort of overlap/jump effect instead of smooth scrolling upwards.

Audio plays fine and there's a movie afterwards that plays fine as well.

It's a little tough to describe the "overlap"/"jump" effect, so here is video of it occurring in ePSXe 1.7. I used our English graphics for demonstration since it'd be easier to read, but I can confirm the exact same behavior with the original game in Japanese.

How the end credits currently look: http://www.viddler.com/explore/slowbeef/videos/75

And here is VRAM in debug mode during this same sequence: http://www.viddler.com/explore/slowbeef/videos/76

It looks like the developers intended the game window to scroll downward as the graphics draw to create the illusion that the credits are scrolling upward. I'm thinking that the drawing window should wrap vertically (as the game window goes down) but in ePSXe (or more specifically the PEOpS plugin) it doesn't, though honestly, it's hard to be sure.

We have verified that this works normally in hardware.

I've tried running Fast/Nice, and using specific game fixes, though nothing seems to help or affect it. Note that I've gotten the exact behavior in SSSPSX with the PEOPS v1.18 plugin, so it does look like the plugin more than the emulator, but I can't get the game to run correctly for this one part in ePSXe 1.7 or 1.6.

Discussion