Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#125 opreport and opannotate segfaults

closed-duplicate
nobody
None
5
2004-08-24
2004-08-24
Anonymous
No

I have linux kernel 2.6.5 and glibc compiled with nptl.
I compiled oprofile 0.8 with (default) and without
optimization (gcc 3.3.2). All other flags were default.

This problem does not happen if I dont give flags -l or
-d to opreport at runtime. It does not depend on the
executable.
Opannotate segfaults if I use -a or -s flags.

Below is what gdb gave me for both of those programs:

Starting program: /usr/bin/opreport -l
/home/thor/Koodit/4k/a.out

Program received signal SIGSEGV, Segmentation fault.
0x0809fac3 in op_bfd (this=0xbffff8b0,
fname=@0x80d78e8, symbol_filter=@0x80d129c,
ok=@0xbffff8ef) at op_bfd.cpp:272
272 if (sect->flags & SEC_DEBUGGING) {

(gdb) bt
#0 0x0809fac3 in op_bfd (this=0xbffff8b0,
fname=@0x80d78e8, symbol_filter=@0x80d129c,
ok=@0xbffff8ef) at op_bfd.cpp:272
#1 0x08079067 in populate_for_image
(samples=@0xbffff970, ip=@0x80d78e8,
symbol_filter=@0x80d129c) at populate.cpp:56
#2 0x0804d965 in (anonymous namespace)::opreport
(non_options=Internal: global symbol
`vector<std::basic_string<char, std::char_traits<char>,
std::allocator<char>
>,std::allocator<std::basic_string<char,
std::char_traits<char>, std::allocator<char> > > >'
found in cverb.cpp psymtab but not in symtab.
vector<std::basic_string<char, std::char_traits<char>,
std::allocator<char>
>,std::allocator<std::basic_string<char,
std::char_traits<char>, std::allocator<char> > > > may
be an inlined function, or may be a template function
(if a template, try specifying an instantiation:
vector<std::basic_string<char, std::char_traits<char>,
std::allocator<char>
>,std::allocator<std::basic_string<char,
std::char_traits<char>, std::allocator<char> > > ><type>).
) at opreport.cpp:426
#3 0x0805d307 in run_pp_tool (argc=3, argv=0xbffffaa4,
fct=0x804d7e6 <(anonymous
namespace)::opreport(std::vector<std::string,
std::allocator<std::string> > const&)>)
at common_option.cpp:110
#4 0x0804da24 in main (argc=3, argv=0xbffffaa4) at
opreport.cpp:440

And for opannotate

Starting program: /usr/bin/opannotate --assembly
/home/thor/Koodit/4k/a.out

Program received signal SIGSEGV, Segmentation fault.
0x08088f1b in op_bfd (this=0xbffff860,
fname=@0x80bd560, symbol_filter=@0x80b7518,
ok=@0xbffff89f) at op_bfd.cpp:272
272 if (sect->flags & SEC_DEBUGGING) {
(gdb) bt
#0 0x08088f1b in op_bfd (this=0xbffff860,
fname=@0x80bd560, symbol_filter=@0x80b7518,
ok=@0xbffff89f) at op_bfd.cpp:272
#1 0x0806a36f in populate_for_image
(samples=@0x80c0360, ip=@0x80bd560,
symbol_filter=@0x80b7518) at populate.cpp:56
#2 0x0804f499 in (anonymous namespace)::opannotate
(non_options=@0xbffff980) at opannotate.cpp:669
#3 0x080574a7 in run_pp_tool (argc=3, argv=0xbffffa94,
fct=0x804f314 <(anonymous
namespace)::opannotate(std::vector<std::string,
std::allocator<std::string> > const&)>)
at common_option.cpp:110
#4 0x0804f69a in main (argc=3, argv=0xbffffa94) at
opannotate.cpp:694

Jani Huhtanen
jahu@kolumbus.fi

Discussion

  • John Levon
    John Levon
    2004-08-24

    • status: open --> closed
     
  • John Levon
    John Levon
    2004-08-24

    • status: closed --> closed-duplicate
     
  • John Levon
    John Levon
    2004-08-24

    Logged In: YES
    user_id=53034

    Duplicate of 1015040