#392 Windows Installer is outdated

v2.1-RC1
open
Triangle717
None
1
2013-06-19
2013-06-04
Triangle717
No

I guess through some miscommunication and my rapid updates, the new Windows installer is not only broken, but also outdated. When I was reading Ticket #390, I installed 2.1RC and discovered that that portable installation switch is broken completely, as it installs the non-portable Globals file, no matter if the switch is ticked or not. I also saw Ticket #391, and the fix for it. All these and other issues have been fixed in the newest release, available on GitHub and the Download archive.

With permission, I would like to have write access to the OpenSong SVN to fix the installer files, and help you get this all set up before 2.1 Final. I promise, I won't touch any of the OpenSong code (and I don't want to, lest I break something). I already have the OpenSong repo cloned onto my HDD, and they fixes won't take long to preform. Plus, I'll be able to finish up the compiling documentation on the wiki, as whatever files that need to be downloaded to compile I can add. If not, please remove all the new installer files added and add the ones in the ZIP archive, which will also fix the issues but might require a bit more maintenance to get everything working properly.

Thank you.

Discussion

  • Vwout
    Vwout
    2013-06-18

    • assigned_to: le717
    • Group: v2.0b1 --> v2.1RC1
     


Anonymous


Cancel   Add attachments