#4 Dependencies with no obvious way to satisfy them

v1.0 (example)
open
nobody
None
5
2014-06-11
2014-06-11
Robert Persson
No

I have been trying to build Newtonator but the cmake fails with what appear to be unmet dependencies with no obvious way to satisfy them. I have tried installing every package in the repositories that I am subscribed to that looks like it might possibly be a package or a dev package related to these variables, but nothing seems to work.

Here is the error message I get:

-- Could NOT find LV2-GUI (missing: LV2-GUI_LIBRARY LV2-GUI_INCLUDE_DIR)
-- Could NOT find LV2-PLUGIN (missing: LV2-PLUGIN_LIBRARY LV2-PLUGIN_INCLUDE_DIR)
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
LV2-GUI_INCLUDE_DIR
used as include directory in directory /usr/local/src/newtonator-0.6.0/src/newt_lv2_gui
LV2-GUI_LIBRARY
linked by target "newt_lv2_gui" in directory /usr/local/src/newtonator-0.6.0/src/newt_lv2_gui
LV2-PLUGIN_INCLUDE_DIR
used as include directory in directory /usr/local/src/newtonator-0.6.0/src/newt_lv2_instr
LV2-PLUGIN_LIBRARY
linked by target "newt_lv2_instr" in directory /usr/local/src/newtonator-0.6.0/src/newt_lv2_instr

Discussion

  • Thanks for reporting. Please tell me what distro or build environment you're using.