#146 Unable to compile on Ubuntu

closed-out-of-date
nobody
None
5
2012-07-27
2012-01-23
Jiri Barton
No

Hi, I also came over the bug with the accelerators -- which has been fixed in 1.0.5. I cannot compile it now though on Ubuntu 11.10 Oneiric. It says g_access is undeclared (and undefined). I found out it is some sort of a library standard on BSDs. I don't know how they compiled the sources on Ubuntu previously because the geom library is not in the Ubuntu repositories! I cannot create the old 1.0.3 package either now either.

Can I disable the Lua plugin for now somehow? I saw I could disable the Python plugin with --without-python but I can't find such option for Lua there.

Thanks!

Discussion

  • Yevgen Muntyan
    Yevgen Muntyan
    2012-07-27

    Very weird, g_access is a macro/function from glib. The only file that uses it does include appropriate header (glib/gstdio.h). I did build medit on ubuntu recently, so it should be fine now. Sorry I didn't get to it back when it was reported.

     
  • Yevgen Muntyan
    Yevgen Muntyan
    2012-07-27

    • status: open --> closed-out-of-date
     
  • I have been absent for a while, but now I remember why I used to love this site. Thanks , I will try and check back more frequently. How frequently you update your website?
    guild wars 2 gold http://www.gw2safe.net