Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#5 mysql invalid encryption method aes

closed-invalid
Jerry Stuckle
None
5
2005-07-01
2005-06-30
M3rlyn
No

I´m getting the error:
"mysql invalid encryption method aes"

But the module is working fine with plain text
passwords, the mysql AES function just work good:

mysql> select AES_ENCRYPT("teste", "kkk");
+-----------------------------+
| AES_ENCRYPT("teste", "kkk") |
+-----------------------------+
| eŻźĐ{"fĂ+ݕmú
e |
+-----------------------------+
1 row in set (0.04 sec)
mysql>

My system:
System: Slackware 10
Mysql: Ver 4.0.20 for slackware-linux on i486
Httpd: Apache/1.3.33 (Unix)
Mod: mod_auth_mysql-2.9.0

best regards,
Fabio

Discussion

  • Jerry Stuckle
    Jerry Stuckle
    2005-06-30

    • status: open --> closed-invalid
     
  • Jerry Stuckle
    Jerry Stuckle
    2005-06-30

    Logged In: YES
    user_id=1049703

    This is not a bug. Rather it is a missing item in the BUILD
    file.

    To build with AES encryption, you must include

    -DAES

    in your apxs compile system.

    This has been added to the BUILD file for the next release.

    Closing.

    Closing.

     
  • M3rlyn
    M3rlyn
    2005-07-01

    Logged In: YES
    user_id=1305631

    Now Im getting another error:

    root@srv:~/mod_auth_mysql-3.0.0# apachectl configtest
    Syntax error on line 207 of /web/httpd/conf/httpd.conf:
    Cannot load /web/httpd/libexec/mod_auth_mysql.so into
    server: /web/httpd/libexec/mod_auth_mysql.so: undefined
    symbol: my_aes_encrypt

    Can you help me, please?

     
  • M3rlyn
    M3rlyn
    2005-07-01

    • assigned_to: nobody --> jstuckle
    • status: closed-invalid --> open-invalid
     
  • Jerry Stuckle
    Jerry Stuckle
    2005-07-01

    Logged In: YES
    user_id=1049703

    Your error does not reflect a bug in mod_auth_mysql. Please
    look at the forums for further information.

     
  • Jerry Stuckle
    Jerry Stuckle
    2005-07-01

    • status: open-invalid --> closed-invalid