Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#172 Segmentation fault while trying to add plugin deicsonze

closed-wont-fix
nobody
None
5
2009-07-06
2007-12-27
klawzz
No

Happens every time i :
Add soft synth -> deicsonze

Here is a debug log, please do let me know how I can help provide a more detailed one :

museseq-1.0 -D -s -p -I
Using SSE optimized routines
load instrument definitions from </usr/share/muse-1.0pre1/instruments>
load instrument definition </usr/share/muse-1.0pre1/instruments/Access_Virus.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Alesis-Ion.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Alesis-QS-78R.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/AlesisQS6.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/emuproteus2000.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/gm.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/gs.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Hammond_XB-1.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/MC303.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/MC505.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/ns5r.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Quasimidi-Sirius.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-E28.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-JV-1010-All.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-JV-1010-Catagory.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-JV-1010-Country.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-JV-1010-Presets.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-JV-1010-Session.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-SCD70.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-XP30.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Roland_FantomXR.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Roland_SRX-02.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Roland_SRX-09.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Waldorf_Microwave-I.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/xg.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Yamaha-P50m.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Yamaha-P80.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Yamaha-PSR275.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Yamaha-PSR530.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/Yamaha-S90.idf>
load instrument definition </usr/share/muse-1.0pre1/instruments/ZynAdd-1_4.idf>
load instrument definitions from </home/jb/MusE/instruments>
readConfiguration </home/jb/.muse-1.0pre1>
readConfiguration </home/jb/.muse-1.0pre1>
init Jack Audio
JACK tmpdir identified as [/dev/shm]
init Jack Audio: register device
init Jack Audio: register device
create jack, 0x86c9a48
JackAudio::JackAudio(0x86c9a48,MusE)
create jack, client=0x86c9a48 jack=0x84ca770
init Jack Audio: register client
JACK: sample rate changed: 48000
global lib: </usr/lib/muse-1.0pre1>
global share: </usr/share/muse-1.0pre1>
muse home: </home/jb>
project dir: <MusE/projects>
config file: </home/jb/.muse-1.0pre1>
locale file not found for locale <C>
QtLibraryPath:
</usr/lib/qt4/plugins>
</usr/bin>
init AlsaMidi
magChanged method not overloaded
searching for software synthesizer in </usr/lib/muse-1.0pre1/synthi>
6 soft synth found
load synti </usr/lib/muse-1.0pre1/synthi/organ.so>
layout method not overloaded
JACK thread running SCHED_FIFO priority 69
JACK: graph changed!
Thread <Midi, id 0xb68dfb90> has SCHED_OTHER priority 71
midiseq thread running SCHED_FIFO priority 71
RtcTimer::setTimerFreq(): cannot set ticks 1024 on /dev/rtc: Inappropriate ioctl for device
precise timer not available
AlsaTimer::setTimerTicks(): requested freq 1024 Hz too high for timer (max is 1000)
freq stays at 1000 Hz
Thread <Prefetch, id 0xb58ddb90> has SCHED_OTHER priority 64
Thread <Writeback, id 0xb50dcb90> has SCHED_OTHER priority 64
jack connect <MusE:Out 1-0>0x8429700 - <alsa_pcm:playback_1>0x8604ee8
JACK: graph changed!
jack connect <MusE:Out 1-1>0x834ee60 - <alsa_pcm:playback_2>0x859a598
JACK: graph changed!
load synti </usr/lib/muse-1.0pre1/synthi/deicsonze.so>
MusE: Plugin <freeverb1> not found
initPluginInstance: zero plugin
Segmentation fault

Discussion

  • klawzz
    klawzz
    2007-12-27

    Logged In: YES
    user_id=1363785
    Originator: YES

    Happens on Gentoo 32 bit, realtime kernel
    uname -a
    Linux localhost 2.6.23.11-rt14 #7 PREEMPT RT Thu Dec 27 21:18:43 CET 2007 i686 Intel(R) Pentium(R) 4 CPU 2.00GHz GenuineIntel GNU/Linu

     
  • Logged In: YES
    user_id=1176572
    Originator: NO

    Hi,

    thanks for pointing this error out. I've committed a fixed for it. The problem was that DeicsOnze would make the assumption that all its LADSPA integrated plugins would always be loaded properly which cannot be case when using option -p.

    There is one temporary caution to keep it mind, if a song using deicsOnze is loaded while in non-LADSPA mode (using option -p) then if modifications are made on the song and saved the song will loose the configuration parameters about its plugins.

    I'll probably write a fix for that soon though...

    Nil

     
  • klawzz
    klawzz
    2007-12-30

    Logged In: YES
    user_id=1363785
    Originator: YES

    Thank you for the quick fix.

    Actually, I was using the debug options because I was hoping to get feedback on a random error on my start project (segmentation fault, again).
    Your reply made me think it could also be related to synths, and, indeed, things are smoother now that I have deleted the offenders :
    track organ-1 (and the related midi track).

    A project using organ is quick to die on transport start, with these famous last words :
    kbdMovementUpdate
    Segmentation fault

    I am back to using MusE with no soft synths (unless there is anything I can add in order to help you investigate ?).

    museseq-1.0 -D
    Using SSE optimized routines
    load instrument definitions from </usr/share/muse-1.0pre1/instruments>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Access_Virus.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Alesis-Ion.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Alesis-QS-78R.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/AlesisQS6.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/emuproteus2000.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/gm.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/gs.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Hammond_XB-1.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/MC303.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/MC505.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/ns5r.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Quasimidi-Sirius.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-E28.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-JV-1010-All.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-JV-1010-Catagory.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-JV-1010-Country.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-JV-1010-Presets.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-JV-1010-Session.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-SCD70.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Roland-XP30.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Roland_FantomXR.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Roland_SRX-02.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Roland_SRX-09.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Waldorf_Microwave-I.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/xg.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Yamaha-P50m.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Yamaha-P80.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Yamaha-PSR275.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Yamaha-PSR530.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/Yamaha-S90.idf>
    load instrument definition </usr/share/muse-1.0pre1/instruments/ZynAdd-1_4.idf>
    load instrument definitions from </home/jb/MusE/instruments>
    readConfiguration </home/jb/.muse-1.0pre1>
    readConfiguration </home/jb/.muse-1.0pre1>
    init Jack Audio
    init Jack Audio: register device
    init Jack Audio: register device
    create jack, 0x8930bc0
    JackAudio::JackAudio(0x8930bc0,MusE)
    create jack, client=0x8930bc0 jack=0x84e1b90
    init Jack Audio: register client
    JACK: sample rate changed: 48000
    global lib: </usr/lib/muse-1.0pre1>
    global share: </usr/share/muse-1.0pre1>
    muse home: </home/jb>
    project dir: <MusE/projects>
    config file: </home/jb/.muse-1.0pre1>
    locale file not found for locale <C>
    scan ladspa plugin dir </usr/lib/muse-1.0pre1/plugins>
    scan ladspa plugin dir </usr/lib/ladspa>
    scan midi plugin dir </usr/lib/muse-1.0pre1/midiplugins>
    load midi plugin </usr/lib/muse-1.0pre1/midiplugins/dump.so>
    load midi plugin </usr/lib/muse-1.0pre1/midiplugins/filter.so>
    load midi plugin </usr/lib/muse-1.0pre1/midiplugins/metronom.so>
    load midi plugin </usr/lib/muse-1.0pre1/midiplugins/splitlayer.so>
    load midi plugin </usr/lib/muse-1.0pre1/midiplugins/transform.so>
    load midi plugin </usr/lib/muse-1.0pre1/midiplugins/trigg.so>
    scan DSSI plugin dir </usr/local/lib/dssi>
    scan DSSI plugin dir </usr/lib/dssi>
    RemoteVSTClient: all cache files are up-to-date, not running scanner
    scan DSSI plugin dir </home/jb/.dssi>
    QtLibraryPath:
    </usr/lib/qt4/plugins>
    </usr/bin>
    init AlsaMidi
    magChanged method not overloaded
    searching for software synthesizer in </usr/lib/muse-1.0pre1/synthi>
    24 soft synth found
    load synti </usr/lib/muse-1.0pre1/synthi/fluidsynth.so>
    fluidsynth sampleRate 48000
    layout method not overloaded
    JACK thread running SCHED_FIFO priority 69
    JACK: graph changed!
    Thread <Midi, id 0xb5cd2b90> has SCHED_OTHER priority 71
    midiseq thread running SCHED_FIFO priority 71
    RtcTimer::setTimerFreq(): cannot set ticks 1024 on /dev/rtc: Inappropriate ioctl for device
    precise timer not available
    AlsaTimer::setTimerTicks(): requested freq 1024 Hz too high for timer (max is 1000)
    freq stays at 1000 Hz
    Thread <Prefetch, id 0xb4b1eb90> has SCHED_OTHER priority 64
    Thread <Writeback, id 0xb431db90> has SCHED_OTHER priority 64
    kbdMovementUpdate
    load synti </usr/lib/muse-1.0pre1/synthi/organ.so>
    kbdMovementUpdate
    Arranger::keyPressEvent
    kbdMovementUpdate
    JACK: graph changed!
    JACK: graph changed!
    kbdMovementUpdate
    Segmentation fault

     
  • Robert Jonsson
    Robert Jonsson
    2009-07-06

    • status: open --> closed-wont-fix
     
  • Robert Jonsson
    Robert Jonsson
    2009-07-06

    Unfortunately muse 2.0 is not under active development at the moment :(