#22 GtkGLExt won't compile with MINGW

open
nobody
5
2009-07-02
2009-07-02
Carlo Bramini
No

If the configure is launched under mingw+msys, you get this error message:

checking for BASE_DEPENDENCIES... configure: error: Package requirements (gtk+-2
.0 >= 2.0.0 gdk-2.0 >= 2.0.0 pango >= 1.0.0 pangox >= 1.0.0 gmodule-2.0 >= 2.0.0
) were not met:

No package 'pangox' found

Actually it will never work in this manner, because pangox does not exist under mingw; it must test pangowin32 instead.
Good solution would be a presence check for pangox OR pangowin32, since cygwin can use both.
I'm using GtkGLExt 1.2.0.

Discussion