#183 gretl: Does not support aarch64 in f19 and rawhide

v1.0_(example)
closed
nobody
None
5
2014-11-07
2014-05-08
johannes lips
No

Dear all,

I do have an open bug in the fedora bug tracker, that gretl does not compile on aarch64 because of an older autoconf version [1]. Could you please check, if this is still valid.
Thanks a lot!

Johannes

[1] https://bugzilla.redhat.com/show_bug.cgi?id=925489

Related

Bugs: #183

Discussion

  • Allin Cottrell
    Allin Cottrell
    2014-05-08

    On Thu, 8 May 2014, johannes lips wrote:

    I do have an open bug in the fedora bug tracker, that gretl does not
    compile on aarch64 because of an older autoconf version [1]. Could you
    please check, if this is still valid.

    Hmm, apparently yes. We've been checking config.guess and config.sub for
    up-to-dateness against libtool, but I see that lags far behind the files
    supplied with automake.

    In gretl CVS I've just updated the two files using the versions from
    current automake (config.guess of 2013-11-29, config.sub of 2013-10-01).

    Allin Cottrell

     
    • I have just build CVS gretl in Fedora 19 x64. Called autoconf before
      configure.
      [helio@localhost gretl]$ autoconf --version
      autoconf (GNU Autoconf) 2.69
      Copyright (C) 2012 Free Software Foundation, Inc.
      License GPLv3+/Autoconf: GNU GPL version 3 or later
      http://gnu.org/licenses/gpl.html, <http://gnu.org/licenses/exceptions.html

      This is free software: you are free to change and redistribute it.
      There is NO WARRANTY, to the extent permitted by law.

      Written by David J. MacKenzie and Akim Demaille.


      All OK.

      On Thu, May 8, 2014 at 10:30 AM, Allin Cottrell allin@users.sf.net wrote:

      On Thu, 8 May 2014, johannes lips wrote:

      I do have an open bug in the fedora bug tracker, that gretl does not
      compile on aarch64 because of an older autoconf version [1]. Could you
      please check, if this is still valid.

      Hmm, apparently yes. We've been checking config.guess and config.sub for
      up-to-dateness against libtool, but I see that lags far behind the files
      supplied with automake.

      In gretl CVS I've just updated the two files using the versions from
      current automake (config.guess of 2013-11-29, config.sub of 2013-10-01).

      Allin Cottrell


      [bugs:#183] gretl: Does not support aarch64 in f19 and rawhide

      Status: open
      Group: v1.0_(example)
      Created: Thu May 08, 2014 08:04 AM UTC by johannes lips
      Last Updated: Thu May 08, 2014 08:04 AM UTC
      Owner: nobody

      Dear all,

      I do have an open bug in the fedora bug tracker, that gretl does not
      compile on aarch64 because of an older autoconf version [1]. Could you
      please check, if this is still valid.
      Thanks a lot!

      Johannes

      [1] https://bugzilla.redhat.com/show_bug.cgi?id=925489


      Sent from sourceforge.net because you indicated interest in <
      https://sourceforge.net/p/gretl/bugs/183/>

      To unsubscribe from further messages, please visit <
      https://sourceforge.net/auth/subscriptions/>

       

      Related

      Bugs: #183

  • Sven S.
    Sven S.
    2014-05-27

    I don't think aarch64 and x64 are the same, Helio. OTOH Allin's comment sounded as if this should fix the problem. If I don't hear anything to the contrary in the next couple of weeks, I will close this.
    thanks,
    sven

     
  • Allin Cottrell
    Allin Cottrell
    2014-05-27

    aarch64 is ARM, not x86. The issue is now fixed; we have fully
    up to date autotools scripts in CVS

     
  • Sven S.
    Sven S.
    2014-11-07

    • status: open --> closed
     
  • Sven S.
    Sven S.
    2014-11-07

    Ok, this is the long overdue and promised closing of this bug.
    thanks,
    sven