#4 make doc gives errors

open
nobody
None
5
2014-08-21
2005-05-31
No

Using gnuplotfortran 0.2.2, and the default Makefile
provided, I am unable to execute 'make doc' command. I
dont know enough of texi2dvi to debug the problem. I
was hoping this would be fixed atleast in the next release.

After uncompiling the source, If I do

$make doc
makeinfo --html gnuplotfortran.texi
makeinfo gnuplotfortran.texi
texi2pdf gnuplotfortran.texi
This is pdfeTeXk, Version 3.14159-1.10b-2.1 (Web2C 7.4.5)
file:line:error style messages enabled.
entering extended mode
(/home/software/compileHere/gnuplotfortran-0.2.2/gnuplotfortran.texi{/usr/share
/texmf/pdftex/config/pdftex.cfg}
(/usr/share/texmf/tex/texinfo/texinfo.tex
Loading texinfo [version 2004-04-07.08]: Basics, pdf,
(/usr/share/texmf/pdftex/plain/misc/pdfcolor.tex)
fonts, page headings,
tables, conditionals, indexing, sectioning, toc,
environments, defuns, macros,
cross references, insertions,
(/usr/share/texmf/tex/generic/dvips/epsf.tex)
localization, and turning on texinfo input format.)
[1{/var/lib/texmf/dvips/con
fig/pdftex.map}] [2] [-1] Chapter 1 Chapter 2 [1]
Chapter 3 [2] Chapter 4
[3] [4] Cross reference values unknown; you must run
TeX again. [5] Chapter 5
[6] [7] [8] [9] [10] [11] [12] [13] [14] [15] [16] [17]
[18] [19] [20] [21]
[22] [23] [24]
Underfull \hbox (badness 10000) in paragraph at lines
1646--1647
[]/cmr10@10.95pt/Plots a spec-i-fied equa-tion r=f(t)
in po-lar co-or-di-nates
- in-voke gnu-
[25] [26] [27] [28] [29] [30] Chapter 6 [31] Appendix A
[32] [33] [34] [35]
[36] [37] [38] (Global Variables) [39] (Function Index)
[40] (Concept Index)
[41] [42] )
(see the transcript file for additional
information){/usr/share/texmf/dvips/tet
ex/09fbbfac.enc}</usr/share/texmf/fonts/type1/bluesky/cm/cmsltt10.pfb>{/usr/sha
re/texmf/dvips/tetex/f7b6d320.enc}</usr/share/texmf/fonts/type1/bluesky/cm/cmsl
10.pfb></usr/share/texmf/fonts/type1/bluesky/latex/lcircle1.pfb>{/usr/share/tex
mf/dvips/tetex/0ef0afca.enc}</usr/share/texmf/fonts/type1/bluesky/cm/cmcsc10.pf
b></usr/share/texmf/fonts/type1/bluesky/cm/cmtt9.pfb></usr/share/texmf/fonts/ty
pe1/bluesky/cm/cmr9.pfb></usr/share/texmf/fonts/type1/bluesky/cm/cmr7.pfb></usr
/share/texmf/fonts/type1/bluesky/cm/cmb10.pfb></usr/share/texmf/fonts/type1/blu
esky/cm/cmtt10.pfb>{/usr/share/texmf/dvips/tetex/74afc74c.enc}</usr/share/texmf
/fonts/type1/bluesky/cm/cmti10.pfb>{/usr/share/texmf/dvips/tetex/bbad153f.enc}<
/usr/share/texmf/fonts/type1/bluesky/cm/cmsy10.pfb></usr/share/texmf/fonts/type
1/bluesky/cm/cmr10.pfb></usr/share/texmf/fonts/type1/bluesky/cm/cmbx12.pfb>
Output written on gnuplotfortran.pdf (45 pages, 219369
bytes).
Transcript written on gnuplotfortran.log.
This is pdfeTeXk, Version 3.14159-1.10b-2.1 (Web2C 7.4.5)
file:line:error style messages enabled.
entering extended mode
(/home/software/compileHere/gnuplotfortran-0.2.2/gnuplotfortran.texi{/usr/share
/texmf/pdftex/config/pdftex.cfg}
(/usr/share/texmf/tex/texinfo/texinfo.tex
Loading texinfo [version 2004-04-07.08]: Basics, pdf,
(/usr/share/texmf/pdftex/plain/misc/pdfcolor.tex)
fonts, page headings,
tables, conditionals, indexing, sectioning, toc,
environments, defuns, macros,
cross references, insertions,
(/usr/share/texmf/tex/generic/dvips/epsf.tex)
localization, and turning on texinfo input format.)
(./gnuplotfortran.aux)
[1{/var/lib/texmf/dvips/config/pdftex.map}] [2]
(./gnuplotfortran.toc [-1])
[-2] (./gnuplotfortran.toc
./gnuplotfortran.toc:56: Missing number, treated as zero
./gnuplotfortran.toc:56: Missing $ inserted
) (./gnuplotfortran.toc)
/home/software/compileHere/gnuplotfortran-0.2.2/gnuplotfortran.texi:38:
Missing
$ inserted
Chapter 1 [1] Chapter 2 [2] Chapter 3 [3] Chapter 4 [4]
[5] [6] Chapter 5
[7] [8] [9] [10] [11] [12] [13] [14] [15] [16] [17]
[18] [19] [20] [21]
[22] [23] [24] [25]
Underfull \hbox (badness 10000) in paragraph at lines
1646--1647
[]/cmr10@10.95pt/Plots a spec-i-fied equa-tion r=f(t)
in po-lar co-or-di-nates
- in-voke gnu-
[26] [27] [28] [29] [30] [31] Chapter 6 [32] Appendix A
[33] [34] [35] [36]
[37] [38] [39] (Global Variables) [40]
(./gnuplotfortran.vrs) (Function Index)
[41] (./gnuplotfortran.fns) (Concept Index) [42]
(./gnuplotfortran.cps)
[43] )
(see the transcript file for additional
information){/usr/share/texmf/dvips/tet
ex/74afc74c.enc}</usr/share/texmf/fonts/type1/bluesky/cm/cmti9.pfb>{/usr/share/
texmf/dvips/tetex/09fbbfac.enc}</usr/share/texmf/fonts/type1/bluesky/cm/cmsltt1
0.pfb>{/usr/share/texmf/dvips/tetex/f7b6d320.enc}</usr/share/texmf/fonts/type1/
bluesky/cm/cmsl10.pfb></usr/share/texmf/fonts/type1/bluesky/latex/lcircle1.pfb>
</usr/share/texmf/fonts/type1/bluesky/cm/cmtt9.pfb></usr/share/texmf/fonts/type
1/bluesky/cm/cmr9.pfb></usr/share/texmf/fonts/type1/bluesky/cm/cmr7.pfb></usr/s
hare/texmf/fonts/type1/bluesky/cm/cmb10.pfb></usr/share/texmf/fonts/type1/blues
ky/cm/cmtt10.pfb>{/usr/share/texmf/dvips/tetex/0ef0afca.enc}</usr/share/texmf/f
onts/type1/bluesky/cm/cmcsc10.pfb></usr/share/texmf/fonts/type1/bluesky/cm/cmti
10.pfb></usr/share/texmf/fonts/type1/bluesky/cm/cmbxti10.pfb>{/usr/share/texmf/
dvips/tetex/bbad153f.enc}</usr/share/texmf/fonts/type1/bluesky/cm/cmsy10.pfb></
usr/share/texmf/fonts/type1/bluesky/cm/cmr10.pfb></usr/share/texmf/fonts/type1/
bluesky/cm/cmbx12.pfb>
Output written on gnuplotfortran.pdf (47 pages, 273615
bytes).
Transcript written on gnuplotfortran.log.
/usr/bin/texi2dvi: pdfetex exited with bad status,
quitting.
/usr/bin/texi2dvi: see gnuplotfortran.log for errors.
make: *** [doc] Error 1

-------------------- my system information
-------------------------------------
using Debian GNU/Linux unstable (sid) distribution.

$uname -a
Linux kusumanchi 2.6.9-1-686 #1 Thu Nov 25 03:48:29 EST
2004 i686 GNU/Linux

$texi2dvi --version
texi2dvi (GNU Texinfo 4.7) 1.3

$makeinfo --version
makeinfo (GNU texinfo) 4.7

I cannot think of any other information that could be
useful. But can provide upon request.

regards
raju

Discussion

    • status: open --> pending
     
  • Logged In: YES
    user_id=1026801

    Hi

    Thanks for your response. I cannot seem to reproduce this
    error on my system (texinfo version 4.6 on Debian Sarge
    (testing)). Until I can do it, I won't be able to fix it.
    Interestingly, texi2dvi is not invoked as a part of texi2pdf
    in my case (see transcript).

    You may use the manual on the project webpage or the
    included documentation (both PDF and html) in the meantime.

    -----------------------------------------------------------------------------------------------

    $ texi2pdf gnuplotfortran.texi
    This is pdfTeXk, Version 3.14159-1.10b (Web2C 7.4.5)
    file:line:error style messages enabled.
    (/home/m_singh/gnuplotfortran/gnuplotfortran.texi{/usr/local/teTeX/share/texmf/
    pdftex/config/pdftex.cfg}
    (/usr/local/teTeX/share/texmf/tex/texinfo/texinfo.tex
    Loading texinfo [version 2003-02-03.16]: Basics, pdf,
    (/usr/local/teTeX/share/texmf/pdftex/plain/misc/pdfcolor.tex)
    fonts,
    page headings, tables, conditionals, indexing, sectioning,
    toc, environments,
    defuns, macros, cross references,
    (/usr/local/teTeX/share/texmf/tex/generic/misc/epsf.tex)
    localization,
    and turning on texinfo input format.)
    [1{/usr/local/teTeX/share/texmf/dvips/con
    fig/pdftex.map}] [2] [-1] Chapter 1 Chapter 2 [1] Chapter 3
    [2] Chapter 4
    [3] [4] Cross reference values unknown; you must run TeX
    again. [5] Chapter 5
    [6] [7] [8] [9] [10] [11] [12] [13] [14] [15] [16] [17] [18]
    [19] [20] [21]
    [22] [23] [24] [25]
    Underfull \hbox (badness 10000) in paragraph at lines 1646--1647
    []/cmr10@10.95pt/Plots a spec-i-fied equa-tion r=f(t) in
    po-lar co-or-di-nates
    - in-voke gnu-
    [26] [27] [28] [29] [30] [31] Chapter 6 [32] Appendix A [33]
    [34] [35] [36]
    [37] [38] [39] (Global Variables) [40] (Function Index) [41]
    (Concept Index)
    [42] [43] )
    (see the transcript file for additional
    information){/usr/local/teTeX/share/tex
    mf/dvips/tetex/09fbbfac.enc}</usr/local/teTeX/share/texmf/fonts/type1/bluesky/c
    m/cmsltt10.pfb>{/usr/local/teTeX/share/texmf/dvips/tetex/f7b6d320.enc}</usr/loc
    al/teTeX/share/texmf/fonts/type1/bluesky/cm/cmsl10.pfb></usr/local/teTeX/share/
    texmf/fonts/type1/bluesky/latex/lcircle1.pfb>{/usr/local/teTeX/share/texmf/dvip
    s/tetex/0ef0afca.enc}</usr/local/teTeX/share/texmf/fonts/type1/bluesky/cm/cmcsc
    10.pfb></usr/local/teTeX/share/texmf/fonts/type1/bluesky/cm/cmtt9.pfb></usr/loc
    al/teTeX/share/texmf/fonts/type1/bluesky/cm/cmr9.pfb></usr/local/teTeX/share/te
    xmf/fonts/type1/bluesky/cm/cmr7.pfb></usr/local/teTeX/share/texmf/fonts/type1/b
    luesky/cm/cmb10.pfb></usr/local/teTeX/share/texmf/fonts/type1/bluesky/cm/cmtt10
    .pfb>{/usr/local/teTeX/share/texmf/dvips/tetex/74afc74c.enc}</usr/local/teTeX/s
    hare/texmf/fonts/type1/bluesky/cm/cmti10.pfb>{/usr/local/teTeX/share/texmf/dvip
    s/tetex/bbad153f.enc}</usr/local/teTeX/share/texmf/fonts/type1/bluesky/cm/cmsy1
    0.pfb></usr/local/teTeX/share/texmf/fonts/type1/bluesky/cm/cmr10.pfb></usr/loca
    l/teTeX/share/texmf/fonts/type1/bluesky/cm/cmbx12.pfb>
    Output written on gnuplotfortran.pdf (46 pages, 220544 bytes).
    Transcript written on gnuplotfortran.log.
    This is pdfTeXk, Version 3.14159-1.10b (Web2C 7.4.5)
    file:line:error style messages enabled.
    (/home/m_singh/gnuplotfortran/gnuplotfortran.texi{/usr/local/teTeX/share/texmf/
    pdftex/config/pdftex.cfg}
    (/usr/local/teTeX/share/texmf/tex/texinfo/texinfo.tex
    Loading texinfo [version 2003-02-03.16]: Basics, pdf,
    (/usr/local/teTeX/share/texmf/pdftex/plain/misc/pdfcolor.tex)
    fonts,
    page headings, tables, conditionals, indexing, sectioning,
    toc, environments,
    defuns, macros, cross references,
    (/usr/local/teTeX/share/texmf/tex/generic/misc/epsf.tex)
    localization,
    and turning on texinfo input format.) (./gnuplotfortran.aux)
    [1{/usr/local/teTe
    X/share/texmf/dvips/config/pdftex.map}] [2]
    (./gnuplotfortran.toc [-1])
    [-2] (./gnuplotfortran.toc) (./gnuplotfortran.toc) Chapter 1
    Chapter2 [1]
    Chapter 3 [2] Chapter 4 [3] [4] [5] Chapter 5 [6] [7] [8]
    [9] [10] [11]
    [12] [13] [14] [15] [16] [17] [18] [19] [20] [21] [22] [23]
    [24] [25]
    Underfull \hbox (badness 10000) in paragraph at lines 1646--1647
    []/cmr10@10.95pt/Plots a spec-i-fied equa-tion r=f(t) in
    po-lar co-or-di-nates
    - in-voke gnu-
    [26] [27] [28] [29] [30] [31] Chapter 6 [32] Appendix A [33]
    [34] [35] [36]
    [37] [38] [39] (Global Variables) [40]
    (./gnuplotfortran.vrs) (Function Index)
    [41] (./gnuplotfortran.fns) (Concept Index) [42]
    (./gnuplotfortran.cps)
    [43] )
    (see the transcript file for additional
    information){/usr/local/teTeX/share/tex
    mf/dvips/tetex/74afc74c.enc}</usr/local/teTeX/share/texmf/fonts/type1/bluesky/c
    m/cmti9.pfb>{/usr/local/teTeX/share/texmf/dvips/tetex/09fbbfac.enc}</usr/local/
    teTeX/share/texmf/fonts/type1/bluesky/cm/cmsltt10.pfb>{/usr/local/teTeX/share/t
    exmf/dvips/tetex/f7b6d320.enc}</usr/local/teTeX/share/texmf/fonts/type1/bluesky
    /cm/cmsl10.pfb></usr/local/teTeX/share/texmf/fonts/type1/bluesky/latex/lcircle1
    .pfb></usr/local/teTeX/share/texmf/fonts/type1/bluesky/cm/cmtt9.pfb></usr/local
    /teTeX/share/texmf/fonts/type1/bluesky/cm/cmr9.pfb></usr/local/teTeX/share/texm
    f/fonts/type1/bluesky/cm/cmr7.pfb></usr/local/teTeX/share/texmf/fonts/type1/blu
    esky/cm/cmb10.pfb></usr/local/teTeX/share/texmf/fonts/type1/bluesky/cm/cmtt10.p
    fb>{/usr/local/teTeX/share/texmf/dvips/tetex/0ef0afca.enc}</usr/local/teTeX/sha
    re/texmf/fonts/type1/bluesky/cm/cmcsc10.pfb></usr/local/teTeX/share/texmf/fonts
    /type1/bluesky/cm/cmti10.pfb></usr/local/teTeX/share/texmf/fonts/type1/bluesky/
    cm/cmbxti10.pfb>{/usr/local/teTeX/share/texmf/dvips/tetex/bbad153f.enc}</usr/lo
    cal/teTeX/share/texmf/fonts/type1/bluesky/cm/cmsy10.pfb></usr/local/teTeX/share
    /texmf/fonts/type1/bluesky/cm/cmr10.pfb></usr/local/teTeX/share/texmf/fonts/typ
    e1/bluesky/cm/cmbx12.pfb>
    Output written on gnuplotfortran.pdf (47 pages, 273437 bytes).
    Transcript written on gnuplotfortran.log.

     
    • status: pending --> open
     
  • Logged In: YES
    user_id=772150

    First of all, I am not sure how to bottom post to
    madhusudhansingh's message in this site. There is no way I
    can quote message from previous email etc.,.

    Coming to the point, I figured out the cause of the problem
    with the gnuplotfortran.texi file.

    In line 2434 of gnuplotfortran.texi file

    @appendixsubsec ADDENDUM: How to use this License for your
    documents

    But infact the above line should be

    @appendixsec ADDENDUM: How to use this License for your
    documents

    In other words, we cannot use appendixsubsec without using
    appendixsec (atleast in texinfo 4.7). For more details the
    following link might be useful.

    http://lists.gnu.org/archive/html/bug-texinfo/2004-04/msg00041.html

    The necessary patch reverting appendixsubsec to appendixsec
    is attached in the end.

    $diff -c gnuplotfortran.texi modified.texi > patch2.txt

    This patch can be applied by using
    $patch gnuplotfortran.texi < patch2.txt

    I have no idea whether this works in sarge. But it does work
    in sid. When I apply this patch and do 'make doc', then
    there are no errors and everything is fine.

    thanks in advance
    raju

     
  • patch which fixes the bug in texinfo 4.7

     
    Attachments
    • status: open --> closed
     
    • status: closed --> open
     
  • Logged In: YES
    user_id=772150

    I reopened this bug, based on a private conversation with
    Madhusudan Singh. This bug still needs to be fixed.

    raju