Python-poppler requiered?

Help
Anonymous
2011-03-29
2013-04-24

  • Anonymous
    2011-03-29

    Hi,
    I installed the plugin using the SVN repository.
    Everything worked fine except that the preview was never available.
    Michael told me to run gedit from the console and I found this error2011-03-29 20:02:36,307 DEBUG PreviewDocument - Initialize <GeditLaTeXPlugin.src.latex.livepreview.PreviewDocument instance at 0x9c02fcc>
    2011-03-29 20:02:36,309 WARNING PreviewDocument - Error loading poppler (python-poppler not installed ?).
    2011-03-29 20:02:36,309 WARNING PreviewPanel - Error while creating preview panel: <type 'exceptions.Exception'>, Error when opening the output file /home/juanpi/Projects/NonLinearFrequencyResponse/WandaXSpring/publications/Manuscript.pdf, ('Error when opening the output file /home/juanpi/Projects/NonLinearFrequencyResponse/WandaXSpring/publications/Manuscript.pdf',)
    2011-03-29 20:02:36,310 WARNING PreviewPanel - Creating default panel

    I installed python-poppler (using apt-get) and now it works fine.
    I did not find any note regarding python-poppler. Maybe a note could be added in the project homepage.

    Thanks

    JPi

     
  • The "INSTALL" file says "Poppler Python Bindings (optional, needed for embedded PDF preview)" in the "REQUIREMENTS" section.

    Michael

     

  • Anonymous
    2011-04-12

    Hi Michale,
    Yes, that is true. I hadn't check the INSTALL file, I just was reading the webpage. Maybe is a good idea to make the two list of requirements equivalent
    I mean this page
    http://www.michaels-website.de/gedit-latex-plugin/

    I also can not easily find a requirements section on the sourceforge page, that is maybe my mistake.

    Thanks

     

  • Anonymous
    2011-04-12

    Michael: Excuse me for the typo in your name