Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Can't activate plugin v0.2rc1

Help
Jan Rudy
2009-05-11
2013-04-24
  • Jan Rudy
    Jan Rudy
    2009-05-11

    I'm have trouble installing the plugin. I've unpacked to my gedit plugins folder and I see the LaTex plugin in my list of available plugins in gedit. But I am unable to activate the plugin - when I try the entry gets greyed out. Any suggestions?

    ps. I'm on ubuntu 9.04 - and I beleive the default Python install is 2.6.

     
    • Jan Rudy
      Jan Rudy
      2009-05-11

      also: pyGtk is v2.16.1 - and I have Python gnomeVFS installed (could find a version number).

      Are there any other dependancies I may be missing?

       
    • anthelios77
      anthelios77
      2009-05-11

      According to the INSTALL file in the downloaded package the requirements are:

      - gedit >=2.15.2
      - Python >=2.5
      - PyGTK >=2.12
      - GTK+ >=2.10.14

      I haven't tried installing it myself yet but that is what it says.

       
    • Jan Rudy
      Jan Rudy
      2009-05-11

      I've double checked my installed versions of the requirements and it seems to be in order.

      gedit v2.26.1
      python v2.6.2
      pyGtk v2.16.1
      GTK+ 2.16.1 (at least that's the version of my libgtk2.0xxx packages)

      I also want to point out that this is on Ubuntu 9.04 - 64bit. I've just tried installing on a 8.10 32bit system with out issue.

       
    • Jan Rudy
      Jan Rudy
      2009-05-11

      I've double checked my installed versions of the requirements and it seems to be in order.

      gedit v2.26.1
      python v2.6.2
      pyGtk v2.16.1
      GTK+ 2.16.1 (at least that's the version of my libgtk2.0xxx packages)

      I also want to point out that this is on Ubuntu 9.04 - 64bit. I've just tried installing on a 8.10 32bit system with out issue.

       
    • Jan Rudy
      Jan Rudy
      2009-05-17

      I figured it out. Python 2.6 does not allow imports by path. I got it working, then found out that it has already been patched in the SVN.