Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#1235 [Pokemon white 2] Assertion failed when battling a trainer

SVN past 0.9.8
closed-fixed
CrazyMax
JIT (22)
none
5
2013-10-15
2012-12-22
Anonymous
No

When JIT is enabled, battling a trainer in pokemon white 2 results in

desmume: arm_jit.cpp:3930: void sync_r15(u32, bool, bool): assertion "!instr_uses_r15(opcode)" failed.

This happens just before the battle starts. Disabling the assertion seems to work, but I don't know how safe it is.

Discussion

1 2 > >> (Page 1 of 2)

  • Anonymous
    2012-12-23

    ROM game code: IRDI
    ROM crc: E6F6B06A
    ROM serial: NTR-IRDI-ITA
    ROM internal name: POKEMON W2

     

  • Anonymous
    2012-12-24

    Do you think it may be due to running it under linux? Because I cannot think of anything else: I tried rebuilding from a fresh svn tarball, without any extra options (just HAVE_JIT=1), and then I ran it with ./desmume --cpu-mode=1 and it still happens. I also tried different optimization levels (from -O0 to -O3). If from the savestate I go left and battle the first trainer I find I can reproduce this every time.

     

  • Anonymous
    2012-12-24

    Just checked, and indeed under Windows it works without problems. So this seems a Linux-only bug

     
  • zeromus
    zeromus
    2013-01-08

    • status: closed-works-for-me --> open-accepted
     
1 2 > >> (Page 1 of 2)


Anonymous


Cancel   Add attachments