#343 Image not displayed when rt run

open
nobody
None
5
2014-04-01
2013-01-19
No

When I type the "rt" command in the Command Window, an empty black window is displayed. If resize by a couple of milimeters, the rendered model appears at last.

If I close the window, the following message appears in the Command Window:

------------------

XIO: fatal IO error 35 (Resource temporarily unavailable) on X server "/tmp/launch-nbvVv2/org.macosforge.xquartz:0"
after 28 requests (28 known processed) with 0 events remaining.
Raytrace failed.

------------------

Messages displayed when typing rt:

mged> rt
BRL-CAD Release 7.22.0 The BRL-CAD Raytracer RT
Fri, 24 Aug 2012 00:06:22 -0400, Compilation 0
morrison@sushi.local:/usr/brlcad/rel-7.22.0
BRL-CAD Release 7.22.0 The BRL-CAD Ray-Tracing Library
Fri, 24 Aug 2012 00:06:22 -0400, Compilation 0
morrison@sushi.local:/usr/brlcad/rel-7.22.0
BRL-CAD Release 7.22.0 The BRL-CAD Numerical Computation Library
Fri, 24 Aug 2012 00:06:22 -0400, Compilation 0
morrison@sushi.local:/usr/brlcad/rel-7.22.0
BRL-CAD Release 7.22.0 The BRL-CAD Utility Library
Fri, 24 Aug 2012 00:06:22 -0400, Compilation 0
morrison@sushi.local:/usr/brlcad/rel-7.22.0

Compile-time debug symbols are available
Running on xxx-iMac.local
Planning to run with 4 processors
rel-7.22.0/bin/rt -M -u model
opendb /Users/xxx/Desktop/BRLCad/tableaux.g;
tree mur_o_arb8.s t_arb8_1.s t_arb8_2.s t_arb8_3.s t_arb8_4.s t_arb8_5.s t_arb8_6.s t_arb8_7.s t_arb8_8.s t_arb8_9.s;
db title: xxx
DIRBUILD: cpu = 0.00015 sec, elapsed = 0.001009 sec
parent: 0.0user 0.0sys 0:00real 0% 0i+0d 2316288maxrss 0+71pf 0+2csw
children: 0.0user 0.0sys 0:00real 0% 0i+0d 0maxrss 0+0pf 0+0csw
Additional mem=0., #malloc=68, #free=52, #realloc=6 (16 retained)
0f83ce30 TOL 5.000000e-04 (sq=2.500000e-07) perp=1.000000e-06, para=9.999990e-01
BRL-CAD Release 7.22.0 The BRL-CAD Optical Shader Library
Fri, 24 Aug 2012 00:06:22 -0400, Compilation 0
morrison@sushi.local:/usr/brlcad/rel-7.22.0
ogl_getmem: shmget failed, errno=22
ogl_getmem: Unable to attach to shared memory.
Additional mem=0., #malloc=2053, #free=5, #realloc=1 (2048 retained)
GETTREE: cpu = 0.000488 sec, elapsed = 0.001068 sec
parent: 0.0user 0.0sys 0:00real 0% 0i+0d 7036928maxrss 0+52pf 0+168csw
children: 0.0user 0.0sys 0:00real 0% 0i+0d 0maxrss 0+0pf 0+0csw
Additional mem=0., #malloc=1279, #free=1193, #realloc=3 (86 retained)

...................Frame 0...................
PREP: cpu = 8.6e-05 sec, elapsed = 0.000155 sec
parent: 0.0user 0.0sys 0:00real 0% 0i+0d 7067648maxrss 0+15pf 0+0csw
children: 0.0user 0.0sys 0:00real 0% 0i+0d 0maxrss 0+0pf 0+0csw
Additional mem=0., #malloc=116, #free=74, #realloc=4 (42 retained)
NUBSP: 0 nu, 21 cut, 22 box (22 empty)
Tree: 10 solids in 10 regions
Model: X(-10, 20), Y(-256, 256), Z(-150, 150)
View: 0 azimuth, 90 elevation off of front view
Orientation: 0, 0, 0, 1
Eye_pos: 0, 0, 1773.62
Size: 1024mm
Grid: (2, 2) mm, (5

Discussion

  • Can you please give an example of object you raytraced that led to this error that you need to resize the window to view it.