1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #20896 (assigned)

Opened 3 years ago

Last modified 2 years ago

HTML5-based file upload usually fails, wish SFTP could manage files

Reported by: jmichae3 Owned by: ctsai
Keywords: PEND Cc:
Private: no

Description

the current provided service of HTML5 upload for managing file uploads for projects is really cool, and I like it, but it has 2 flaws.
1. the upload usually fails, especially the first time when I am uploading files over 20MB in size.
2. I get an error if I try to upload from different directories on my 32-bit windows XP SP3 system. for instance, I try to upload 2 20MB files from "c:\www\jimm\code\windows\kitchentimer.zip" and "c:\www\jimm\code\windows\kitchentimer-1.3-setup.exe" and a readme.txt from "c:\prj\kitchentimer\kitchentimer-1.3\win\readme.txt", this fails, or if I do "c:\prj\kitchentimer\kitchentimer.zip" and "c:\prj\kitchtntimer\kitchentimer-1.3-setup.exe" and "c:\prj\kitchentimer\kitchentimer-1.3\win\readme.txt", this fails. the problem seems to stem from having these files come from different directories. I don't have this problem when I work with my PHP uploads. code samples have been given that work well (although PHP is not known for good file sizes).
3. no SFTP option is available for uploading my downloadable packaged files (zips, tarballs, installers, whatever). and then managing it later with the web interface - the suggestion at would be good that the account holder manage their file properties, such as OS type in the circle-i icon, etc. after they are done uploading their files.) having something stable would be welcome at this point, especially with large file uploads (cd ISO's, DVD ISO's).

sftp only allows me to make changes to the web pages.
this is only half useful.

there is nothing said about the features of the web hosting on the sf.net web hosting. is it PHP+MySQL? PHP only? no PHP? ASP? shtml? any server-sided scripting at all?

Change History

  Changed 3 years ago by ctsai

  • keywords PEND added
  • owner set to ctsai
  • status changed from new to assigned

Hello,

I'm going to address the third item first, as it will probably solve 1 and 2 for you.

SFTP uploads are available (and have been for quite some time). See our SFTP docs for details on authentication and logging in. To upload to your file release space, you should upload to /home/frs/project/P/PR/PROJECTNAME so for your atoi64 project, you would upload to /home/frs/project/a/at/atoi64

As for Project web, from that list, yes, we support php, we provide a database for mysql, shtml, and various scripting languages. We do not support ASP. You can find all these details in our web platform documentation.

Does this help?

Regards,
Chris Tsai, SourceForge.net Support

  Changed 3 years ago by jmichae3

the documentation isn't that clear about project filepaths like this, in fact, there is no documentation on filepaths.

I glazed over this, when in fact it requires close studying.

having 2 different examples makes things exceedingly clear. could that web page be modified? https://sourceforge.net/apps/trac/sourceforge/wiki/Release%20files%20for%20download#SFTP

many thanks, it will help a lot of people I think, since most people have filezilla available to them and not SSH.

  Changed 3 years ago by jmichae3

that is only partially helpful, but it does not help the other people out there who are using HTML5 to upload their stuff and are getting frustrated. please fix the HTML5 problem - no bugs please thanks.

I am using firefox 5.0, also had problems with 4.x on windows xp 32-bit sp3.

  Changed 3 years ago by jmichae3

tried to upload via HTML5 and it failed 3 times in a row. it seems to depend on which files are in order first, the zip file or the setup .exe. and sometimes it doesn't work no matter what I try.

  Changed 3 years ago by jmichae3

since the zip file is larger than the setup .exe it may be the file size, the readme's usually come through great now when I upload all 3 in a row, but the other 2 fail most of the time.

  Changed 3 years ago by ctsai

  • keywords ENGR NF-2600 added; PEND removed

Apologies for the late response on this ticket. The engineering team has been looking into file upload issues via this ticket: https://sourceforge.net/p/allura/tickets/2600/

Regards,
Chris Tsai, SourceForge.net Support

  Changed 3 years ago by ctsai

  • keywords PEND added; ENGR NF-2600 removed

The engineering team has pushed the fix for this issue and it is now live on the site.

In both their testing and mine, uploads are much smoother now, please try it yourself and let us know.

Regards,
Chris Tsai, SourceForge.net Support

  Changed 3 years ago by jmichae3

works great from what I can see now, very consistent for small uploads (20MB), but I tried a 999999999-byte file and a 1000000000 byte file at the same time, and both gave me red bars. the file appear to have uploaded successfully though. the 999999999 byte file shows as 1000.0MB and the 1000000000 byte file shows as a 1.0GB file.

the same files upload with a green bar if I upload singly.

odd that it failed yet succeeds.

I have a project called createfile in sourceforge that you can use to create test files for testing this of any size. it runs under windows.
http://sf.net/projects/createfile

I have also discovered that if I am doing a virus scan, and up html5 uploads in separate browser tabs, they will both fail. (windows xp, hard disk accesses always stop the OS, this was fixed in either vista or 7)

  Changed 3 years ago by jmichae3

I think it works well enough for reasonable stuff that this could be closed.
however, I think someone misinterpreted the definition of "files up to 1GB in size can be uploaded".

this means I should be able to upload multiple files that are 1GB in size in one batch. yes?

If this is not the case, please reword the wording on the upload thing of the html5 upload. this ability seems to be broken for large files.

  Changed 3 years ago by jmichae3

say guys, the HTML 5 upload is back to being broken again. I am getting red (pink) bars, and dark red text blocks saying that the file upload didn't work. and this is happening a lot.

  Changed 3 years ago by ctsai

Hello,

Upload is working well for me. What size file are you trying to upload?

Regards,
Chris Tsai, SourceForge.net Support

  Changed 3 years ago by jmichae3

2 files of 15-20MB each and some small text files. the small text files are successful.

  Changed 3 years ago by jmichae3

this time, uploaded 2 files, got light green bar, and the files were not uploaded.

  Changed 2 years ago by jmichae3

this seems to be working fine again.

  Changed 2 years ago by ilan1

The upload problem is now bothering me. I have a 1.3MB file which always goes up to 16% and then gives me a pink bar. What is strange is if I do a download, the file looks OK. Still there is a nasty feeling that it hasn't been uploaded correctly.

Ilan

follow-up: ↓ 17   Changed 2 years ago by jmichae3

I am not having problems over on the west side of the USA.

I have noticed that If I try to do HTML5 uploads at the same time as I do other activities on the internet, it fails miserably. so it needs to be the ONLY thing you do. so much for TCP/IP multithreading. I suppose this could also apply to windows updates...! so if you have the yellow shield, don't bother trying.

windows supports up to 5 client connections. but this doesn't seem to applywith HTML5 upload for some reason on firefox.

in reply to: ↑ 16   Changed 2 years ago by ilan1

After I tried and tried I finally gave up. Then I had to update one of my other files as well. So I put in the other file first and then my problem update. Both went through this time. I'm going to leave well enough alone.
Here I am running Ubuntu Linux, not Windows. I usually run other things in parallel on the Internet but I had turned everything else off when I was struggling. This is the first and only time I've run into the problem and I'll be happy if I never see it again.

  Changed 2 years ago by jmichae3

I have had this problem before! I just worked around it and never said anything about it (or did I?)

  Changed 2 years ago by jmichae3

I had this problem on windows. so it's not platform specific. I think you should report the problem here. like was said above. https://sourceforge.net/p/allura/tickets/2600/

  Changed 2 years ago by jmichae3

just out of curiosity, what browser are you using, what OS? these are the kinds of questions the techs usually ask anyway...

I listed the problem there on https://sourceforge.net/p/allura/tickets/2600/ but it seems the bug is closed, not sure if they are taking requests any more on that. you MIGHT have to make a new ticket to get a response from sf.net.

Note: See TracTickets for help on using tickets.