1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #18710 (closed: wontfix)

Opened 3 years ago

Last modified 23 months ago

Anomalous Brain Workshop download activity

Reported by: jtoomim Owned by: ctsai
Keywords: ENGR NF-1905 Cc:
Private: no

Description

I'm one of the two developers for Brain Workshop, a project hosted on
Sourceforge. I've been noticing that Brain Workshop occasionally has weird
download spikes from Russia. When it happens, it's always one file, always
from one country, always Russia, and usually lasts a few days and exceeds
our normal download activity by around one order of magnitude. Over the last
few months, these spikes have accounted for around half of our total
downloads. The most recent spike occurred on the source distribution for
version 4.7 (the most current is 4.8) over 4 days in the last week:

Date Downloads
2011-03-28 3
2011-03-27 3
2011-03-26 2,236
2011-03-25 5,498
2011-03-24 1,819
2011-03-23 1,716
2011-03-22 1,734
2011-03-21 7

https://sourceforge.net/projects/brainworkshop/files/brainworkshop/Brain%20Workshop%204.7/stats/timeline

The <10/day rate is typical for old versions of our software. The most
recent version gets ~200 downloads/day.

We haven't noticed any problems as a result of these download spikes, but
they do use a considerable amount of bandwidth (around 100 GB for the last
one), so I thought you guys might want to hear about it.

Jonathan

Change History

Changed 3 years ago by ctsai

  • keywords ENGR NF-1905 added
  • owner set to ctsai
  • status changed from new to assigned

Hello,

I'm escalating this to our engineering team for further review here: https://sourceforge.net/p/allura/tickets/1905/

Regards,
Chris Tsai, SourceForge.net Support

Changed 23 months ago by ctsai

  • status changed from assigned to closed
  • resolution set to wontfix

Greetings,

Indeed we occasionally see strange stats anomalies often caused by bots or misbehaving download management software.

With that said though, unless it's re-curring, it's often not worth the time to investigate this. This particular issue, the team is electing not to spend the time on.

Regards,
Chris Tsai, SourceForge.net Support

Note: See TracTickets for help on using tickets.