1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #16555 (closed: wontfix)

Opened 3 years ago

Last modified 20 months ago

OpenID and redirection

Reported by: luci_stanescu Owned by: ctsai
Keywords: ENGR AT-729 Cc:
Private: no

Description

Hi,

I'm trying to login using my OpenID which is hosted by myself: http://id.cnix.ro/luci. The weird thing about it is that this page reports http://id.cnix.ro/server as the OpenID Provider URL, which is actually redirected using a 302 to https://openid.cnix.ro/server. So, watching the logs, sourceforge does a POST request to http://id.cnix.ro/server and then a *GET* request to https://openid.cnix.ro/server (without any query arguments) and fails immediately showing the following error on the web page where I just entered by OpenID identifier: "There was an error using your OpenID."

I think the problem is it doesn't handle the redirection correctly.

Thanks,
Luci Stanescu

Change History

Changed 3 years ago by ctsai

  • keywords ENGR AT-729 added; openid,redirection removed
  • owner set to ctsai
  • status changed from new to assigned

Hello,

Thank you for this report, I'm escalating this to our engineering team for further review.

Regards,
Chris Tsai, SourceForge.net Support

Changed 20 months ago by ctsai

  • status changed from assigned to closed
  • resolution set to wontfix

Greetings,

We are going to be re-writing our login system, and I expect that the new implementation will solve this issue, however this will not be fixed in the current system so I'm closing this ticket out as "wontfix".

Regards,
Chris Tsai, SourceForge.net Support

Note: See TracTickets for help on using tickets.