1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Installing PDL on Linux

From pdl

Revision as of 13:37, 26 July 2010 by Danielcarrera (Talk | contribs)
Jump to: navigation, search

PDL is already available in most Linux distributions. For a default install, follow the instructions below. But if you want more control over the installation, you want the latest PDL, or you want features that your distribution does not offer by default, please go to Installing PDL Manually.


Ubuntu 10.04 LTS (tested)

Should work with:

  • Ubuntu 10.04 or later
  • Knoppix 6.0 or later
  • Debian 5.0 or later
# Install core PDL (includes PLplot and 3D graphics).
apt-get install pdl

# Install PGPLOT
apt-get install pgplot5 libpgplot-perl

Note: Could not setup PDL::PP.

Mandriva ES 5 (tested)

Should work with:

  • Mandriva 2010 or later
# Install core PDL (no PGPLOT, no 3D graphics, no PLplot)
urpmi perl-PDL

Note: Could not setup PGPLOT, OpenGL, PLplot or PDL::PP.

Cent OS 5.0 (untested)

Should work with:

  • RHEL 5.0 or later
  • Fedora 13 or later
yum install perl-PDL

OpenSUSE (untested)

Use YaST to search for "perl-PDL"
Gentoo (untested)
emerge dev-perl/PDL
Personal tools