
CodeBlocks and Arduino (tutorial by zdena 20190427) 
Note: This is summary of my weak knowledge about C::B and Arduino and C/C++ programming generally. I am neither 

programming expert nor English speaker, so it could happen that some words or terms I used in wrong sense. Sorry. But I 

believe it could help to someone. And feel free to improve the wizard or anything else concerning this matter. 

 

Annotation: One of possibilities and I think the easiest one how to get from ArduinoIDE to C::B is to 

use still original arduino-builder.exe (next called ArBu) but inside the C::B environment. 

Let’s imagine the arduino-builder.exe serves as a make.  

The input conditions are still the same as in ArduinoIDE programming: 

1) Source files are inside directory example. 

2) Main file names example.ino. 

Next we have to tell to the ArBu: 

1) What board and what MCU we try to program. 

2) Where are Arduino libraries or our own ones. 

Then, if we are lucky we have got example.ino.hex (or example.ino.with_bootloader.hex) after 

building. This one we need to upload to the Arduino board. Avrdude.exe serves well for it like in 

ArduinoIDE. We only have to tell to the avrdude what MCU, via what port, with what speed etc. 

ArduinoIDE has useful SerialMonitor. As a replacement we can use alternative “serial terminals”. 

Here we use TeraTerm. The outputs can be logged into a textfile. Inputs via serial maybe work also 

and maybe not – I don’t care. 

Nomenclature: The program example is called sketch. The example.ino file is called sketch. The 

directory example is called sketch directory. The files in sketch directory are called sketch files. 

 

How does the ArBu inside ArduinoIDE work usually? 
In summary what I understood: ArBu collects all .c, .cpp, .h, .hpp as well as the main .ino files from 

the sketch directory, then adds desirable libraries, also the core libraries (dependent on MCU), puts 

all of them somewhere in temp and abracadabra the .hex is somewhere in temp and you can upload 

it to your board. 

If you have an error somewhere in your sketch you are moved (?parsed?) in the correct place of the 

error in the sketch file. 

How does the ArBu inside C::B work usually? 
Shortly: ArBu collects all .c, .cpp, .h, .hpp as well as the main .ino files from the sketch directory, then 

adds desirable libraries, also the core libraries (dependent on MCU), puts all of them in temp defined 

by us and abracadabra the .hex is where we tell. And from this place we can then upload it to the 

board. 

If you have an error or warning somewhere in your sketch you are moved (?parsed?) in the usually 

wrong  place of the error in the temporary sketch file. Only .ino file works well. 



Help of wizard 
Seems there are many parameters what have to be set to print “Hello world”. However, C::B has an 

instrument called Project Wizard. So let’s call the wizard. 

Sorry, prior the start: 

 We have to have an Arduino compiler. You can download it from 

https://www.arduino.cc/en/Main/Software and “Windows ZIP file for non admin install”. 

Inside the package is directory “arduino-1.8.5” (number depends on the version you 

want use). Extract it in Codeblocks directory. 

Now you can run C::B (?CbLauncher.exe?). Detection of compilers may appear if you run C::B for the 

first time. 

 

Select what you want. 

 Here comes the first (easy) setting of C::B. ArBu wants know what version of Arduino 

compiler we use. Therefore we have to set C::B environmental variables. (There is possibility 

to set it as project variables but in case of change version you have to change it in all 

projects.)  

Settings -> Environment… -> Environment variables -> Add 

https://www.arduino.cc/en/Main/Software


 

ARDUINO_VERZE = arduino-1.8.5 is name of Arduino directory and  

ARDUINO_IDE_VERZE = 10805  is… evident. 

 

 Now, when the \AppData directory created automatically, we have to create our directory 

\MyLibraries there. 

\codeblocks-17.12\AppData\MyLibraries\  



 Next (more complicated) setting is creating of “dummy” compiler. The C::B needs compiler 

for each project probably. And we don’t use any compiler in C::B sense. 

So Settings -> Compiler… -> choose the nearest one : GNU GCC Compiler for AVR and make 

Copy 

 

We have got Copy of GNU GCC Compiler for AVR. 

It seems the compiler have to have to set Toolchain executables. 

Go to Settings -> Compiler… -> Copy of GNU GCC Compiler for AVR -> Toolchain executables 

Put $(CODEBLOCKS)\$(ARDUINO_VERZE)\hardware\tools\avr\ in Compiler’s 

installation directory and set other fields according to figure: 

 



 

The right wizard is not here yet. Maybe in next version of C::B will be.  

 So we have to invite him (more more complicated) now: 

File -> New -> Project… 

 

 

Right-click on any of the icons and select Edit global registration script: 

 

The config.script will open in editor. Find section “Embedded Systems” and add there the 

row: 

RegisterWizard(wizProject,     _T("arduinoBuilder"),      _T("Arduino Builder Project"),       _T("Embedded 

Systems")); 

 



You will get new file here: 

\CodeBlocks\AppData\codeblocks\share\codeblocks\templates\wizard\config.script 

In the same place copy the \arduinoBuilder directory with these files: logo.png, 

wizard.png, wizard.script, wizard.xrc. (from arduinoBuilder.zip) 

After restart of C::B and File -> New -> Project… you should see something like this: 

 

 

Try select, of course, Arduino Builder Project. (You probably will have to edit it, but later. The 

red icons mean they are our modifications of wizards located in the user AppData section. In 

this section are all your settings, also your Arduino libraries will be there.) 

 

  



So, finally, select “Arduino Builder Project” and click “Go”.  
Maybe a Security Warning comes: 

 

Marking it trusted permanently prevents next appearance. 

 

We probably have got an error (no idea why) 

 but we can ignore it by clicking OK. 

And we are in Welcome page of wizard: 

 

(You can nike the Skip, but the unniking back is difficult if you don’t know how.) 



On the next page: 

 

we can choose: 

1) The target name 

2) The programmer used for uploading of .hex (you probably don’t need to change it) 

3) The port for it (you probably need to change it) 

4) Baudrate for communication of the sketch via serial monitor (Terminal), not for .hex 

uploading 

All of these parameters will be stored as project variables in .cbp and you can change them later in 

project’s Build options. Sometimes there are connected more variables together so try to understand 

what all of the variables mean before changing. 

 

On the last page we name the project example for example: 

 

And Finish. 

 

  



We should get something like this: 

 

And the directory example with example.cbp and example.ino. 

(Syntax highlighting and file types sorting we will do later.) 

And now we can Build (Ctrl-F9) (without Run).  If we Build and Run we will got an error. 

After successful build we get new subdirectory example\hexy\ with the most interesting four files as 

a result of building. 

And in system temporary are directories example\build\ and example\cache\ with some products of 

the build. These files could short building time next time. 

(Note: If you feel the building is too slow, check your antivirus and try to set exception.) 

 

Uploading the .hex and other tools 

All communication in Arduino projects is done by help of Tools+. 

The easiest way is to import file Tools_plus.  

Tools+ -> Configure Tools… -> Import… -> Select file Tools_plus 

There are four tools there. They call commands hidden inside project variables created by wizard. 

 dude_upload  $(DUDE_UPLOAD)  

uploads the .hex to the board 

 dude_EEread $(DUDE_EEREAD)  

reads board’s EEPROM and store it to file in raw format _r.eep in sketch directory 

 dude_EEwrit $(DUDE_EEWRIT)  

writes raw formatted file _w.eep from sketch directory to board’s EEPROM 

 Terminal $(TERMINAL)   

runs serial monitor (the board is resetted with start of terminal) 



And two tools in addition: 

 Clean  cmd /C del /S /Q $(PROJECT_DIR)hexy $(TEMP)\$(PROJECT_NAME) 

Deletes products (files) of building from project directory as well as from temporary 

 Archiving $(APP_PATH)\7zip\7za.exe a -mx7 $(PROJECTDIR)..\$(PROJECT_NAME)_$(NOW).zip 

$(PROJECTDIR) 
Makes zip archive of the complete project directory named with date and time. Standard 

Arduino libraries or MyLibraries are not included. For this tool you have to have \7zip 

directory with 7za.exe in your CodeBlocks directory. 

 

The uploading of the sketch in traditional ArduinoIDE causes rebuilding of the sketch and then 

uploading.  

In C::B you need to build the project only once, thereby you have .hex and then you can upload it so 

many times you want. Without repeatedly building.  

Could happen at first that the avrdude communication fails. Try unplugging the USB and plugging it 

again. Maybe you have set wrong port, maybe wrong communication protocol. You can try 

documentation for avrdude. But if your board worked under ArduinoIDE you are able to set it to be 

working also in C::B. 

 

 

Set syntax highlighting 

Settings -> Editor… -> Syntax highlighting -> Syntax highlighting for: C/C++ -> Filemasks… -> and add 

*.ino there. 

 

 



Code completion 

Settings -> Editor… -> Code completion -> C/C++ parser (adv.) tab -> File extension to parse as source 

files -> Filemasks… -> and add ino there. 

 

 

Sorting in project tree 

Right click on Workspace -> Edit file types & categories… -> Sources -> File masks for selected 

category: -> add *.ino to the list. 

   

Serial monitor - TeraTerm 

You can use any serial terminals. I choose TeraTerm. You can download it from this place: 

http://cznic.dl.osdn.jp/ttssh2/70691/teraterm-4.102.zip 

and unpack it to the \codeblocks\teraterm-4.102\ directory. 

Archiving with 7zip 

Download 7zip from https://www.7-zip.org/ and create \codeblocks\7zip directory. Copy 

7za.exe there. This one file is enough.  

http://cznic.dl.osdn.jp/ttssh2/70691/teraterm-4.102.zip
https://www.7-zip.org/


No more settings – only description 

Project variables 

These variables are made automatically and depend on chosen parameters during wizard. 

 

 

List of the project variables (example of ATmega2560): 

VARIABLE Value Description 

BOARD ATmega2560 (Mega 2560) Name of our board or target 

CPU_FREQ 16000000L  

DUDE_EEREAD 
$(TARGET_COMPILER_DIR)bin\avrdude -C$(TARGET_COMPILER_DIR)etc\avrdude.conf -v -
p$(MCU) -c$(PROTOCOL) -P$(UPLOAD_PORT) -b$(UPLOAD_SPEED) -D -
Ueeprom:r:$(PROJECT_DIR)$(TARGET_OUTPUT_DIR)$(TARGET_OUTPUT_BASENAME)_r.eep:r 

avrdude command to 
read onboard EEPROM 
to file (raw format) 

DUDE_EEWRIT 
$(TARGET_COMPILER_DIR)bin\avrdude -C$(TARGET_COMPILER_DIR)etc\avrdude.conf -v -
p$(MCU) -c$(PROTOCOL) -P$(UPLOAD_PORT) -b$(UPLOAD_SPEED) -D -
Ueeprom:w:$(PROJECT_DIR)$(TARGET_OUTPUT_DIR)$(TARGET_OUTPUT_BASENAME)_w.eep:r 

avrdude command to 
upload file (raw) to the 
onboard EEPROM 

DUDE_UPLOAD 
$(TARGET_COMPILER_DIR)bin\avrdude -C$(TARGET_COMPILER_DIR)etc\avrdude.conf -v -
p$(MCU) -c$(PROTOCOL) -P$(UPLOAD_PORT) -b$(UPLOAD_SPEED) -D -
Uflash:w:$(PROJECT_DIR)$(TARGET_OUTPUT_DIR)$(TARGET_OUTPUT_BASENAME).hex:i 

avrdude command to 
upload file (intel hex) 
to the program FLASH 

FQBN arduino:avr:mega:cpu=atmega2560 One of parameters of arduino-builder.exe 

MAX_SIZE 253952 FLASH space available for our program = total device FLASH size - bootloader size 

MAX_SRAM 8192 RAM size for our data. Whole RAM is for us. 

MCU atmega2560 Processor used 

PROTOCOL wiring Protocol with which avrdude will communicate with board.  

SERIALMONITOR_BAUDRATE 9600 Baudrate in “Serial.begin(9600);” command. Communication between sketch and serial monitor. 

SERIAL_PORT 1 Only number of UPLOAD_PORT variable. Needed in TERMINAL value. 

TERMINAL $(APP_PATH)\teraterm-4.102\TTERMPRO \C=$(SERIAL_PORT) 
\BAUD=$(SERIALMONITOR_BAUDRATE) \L=$(PROJECT_DIR)Log.txt \LA=E 

Command for launching of “serial monitor” 

UPLOAD_PORT COM1 Serial port used 

UPLOAD_SPEED 115200 Baudrate used for avrdude communication 

 



Pre/post build steps 

 
Pre-build steps: 

 Creates directory \hexy in our project directory for most interesting products of building: 

"cmd /X /C if not exist $(PROJECT_DIR)hexy (md $(PROJECT_DIR)hexy)" 

 Creates build directory in system temp: 

"cmd /X /C if not exist $(temp)\$(PROJECT_NAME)\build (md $(temp)\$(PROJECT_NAME)\build)" 

 Creates cache directory in system temp: 

"cmd /X /C if not exist $(temp)\$(PROJECT_NAME)\cache (md $(temp)\$(PROJECT_NAME)\cache)" 

 Runs the main compiling of our project: 

"$(CODEBLOCKS)\$(ARDUINO_VERZE)\arduino-builder -compile    -logger=machine -hardware 

$(CODEBLOCKS)\$(ARDUINO_VERZE)\hardware -tools $(CODEBLOCKS)\$(ARDUINO_VERZE)\tools-builder -

tools $(TARGET_COMPILER_DIR) -built-in-libraries $(CODEBLOCKS)\$(ARDUINO_VERZE)\libraries -

libraries $(CODEBLOCKS)\AppData\MyLibraries -fqbn=$(FQBN) -ide-version=$(ARDUINO_IDE_VERZE) -

build-path $(temp)\$(PROJECT_NAME)\build -warnings=all -build-cache 

$(temp)\$(PROJECT_NAME)\cache -prefs=build.warn_data_percentage=75 -

prefs=runtime.tools.avrdude.path=$(TARGET_COMPILER_DIR) -prefs=runtime.tools.avr-

gcc.path=$(TARGET_COMPILER_DIR) -prefs=runtime.tools.arduinoOTA.path=$(TARGET_COMPILER_DIR) -

verbose $(PROJECT_DIR)$(PROJECTNAME).ino" 

 

Post-build steps: 

 Copies the four most interesting products of building into the directory \hexy in our project 

directory: 

"cmd /X /C copy /Y $(temp)\$(PROJECT_NAME)\build\$(PROJECT_NAME)*.* $(PROJECT_DIR)hexy\*.*" 

 Shows program and data memories usage. The percentual usage is calculated from total 

FLASH size - not from FLASH space for us. What a pity. 

"avr-size --mcu=$(MCU) --format=avr $(TARGET_OUTPUT_FILE)" 

 Shows the real FLASH size for us and RAM for us. Only the information what is the limit.  

"cmd /C echo        Board $(BOARD) total FLASH $(MAX_SIZE) Bytes   total RAM $(MAX_SRAM) Bytes" 

 



Search directories 

For code completion during code writing we have to set search directories for compiler. (Probably) 

The wizard adds some most important. If you use any next libraries you should add them also. You 

can add them as a project option or as a global option of our Copy of GNU GCC Compiler for AVR. But 

is recommended to use not absolute path but variables $(CODEBLOCKS) and/or $(ARDUINO_VERZE) 

in the path. 

 

"$(CODEBLOCKS)/AppData/MyLibraries" 

"$(CODEBLOCKS)/$(ARDUINO_VERZE)/libraries" 

"$(CODEBLOCKS)/$(ARDUINO_VERZE)/hardware/arduino/avr/cores/arduino" 

"$(CODEBLOCKS)/$(ARDUINO_VERZE)/hardware/tools/avr/avr/include" 

"$(CODEBLOCKS)/$(ARDUINO_VERZE)/hardware/tools/avr/avr/include/avr" 

"$(CODEBLOCKS)/$(ARDUINO_VERZE)/hardware/tools/avr/avr/include/util" 

The searching doesn’t go inside subdirectories so the first two are only for example of path. 

 

Libraries 

More complicated projects use libraries. 

You can use Arduino libraries in   

\CodeBlocks\arduino-1.8.5\libraries\  ("$(CODEBLOCKS)/$(ARDUINO_VERZE)/libraries") 

Or your own or modified libraries in   

\CodeBlocks\AppData\MyLibraries\  ("$(CODEBLOCKS)/AppData/MyLibraries") 

 

ArduinoIDE has a Library Manager, which cares about libraries updating. From time to time you can 

run ArduinoIDE and check the libraries.  

Into this directory \codeblocks\AppData\MyLibraries put Arduino libraries modified by you or another 

„unofficial“ arduino libraries. These libraries are independent on Arduino version and are not 

updated with the Library Manager. 

Both directories will be searched for Arduino system libraries during building.  



What if… 

Your board not in wizard? 
If you had gone here and the example was built successfully, you should be able to modify the wizard 

to put missing boards there. 

Select File -> New -> Project… -> right click on Arduino Builder Project -> Edit this script 

 

 

The wizard.script will open in C::B editor: 

 

Find function SetupProject(project) and there are some if…else if… else if… 

 

  



Select last else if statement (four rows) : 

 

And duplicate it Ctrl-d. Then edit the last new else if statement according your needs  

OK, what are your needs? 

Find \CodeBlocks\arduino-1.8.5\hardware\arduino\avr\boards.txt and open it. (You 

can use makefile syntax highlighting.) Find your board section there and use the information from 

there. Let’s try Leonardo. 

 



You will need following items and values:  

Item in wizard.script Item and value in board.txt Value in wizard.script 

targetName .name=Arduino Leonardo Arduino Leonardo 

fqbn       Not in board.txt arduino:avr:leonardo 

mcu .build.mcu=atmega32u4 atmega32u4 

f_cpu .build.f_cpu=16000000L 16000000L 

protocol .upload.protocol=avr109 avr109 

max_size .upload.maximum_size=28672 28672 

max_data_size .upload.maximum_data_size=2560 2560 

upload_speed .upload.speed=57600 57600 

The protocol variable value can be override later in wizard by combobox Programmer used. 

fqbn value we get from ArduinoIDE.  

Run ArduinoIDE (Arduino.exe). Select board Arduino Leonardo. 

 

And compile (Ctrl-r). 

In the first message find -fqbn and copy the value (Ctrl-c). 

 

Then you can put the values into the wizard.script. Don’t forget copy the targetName also in the else 

if condition and in project.SetActiveBuildTarget(). 

 



Save the wizard.script (Ctrl-s) and we are halfway through the wizard modification. 

Now open 

 \CodeBlocks\AppData\codeblocks\share\codeblocks\templates\wizard\arduinoBuilder\wizard.xrc 

We can edit it in simple text editor – the file is xml based. Or more funny is to open it in C::B.  Drag 

and drop the file in the C::B. 

Maybe you have to select wizard.xrc tab once more. And you will see something like this: 

 

1) Select the combobox wit avr_target 

2) Click three dots in the choice values and Edit item window appear 

3) Add your board name (targetName) 

4) OK 

 

In the similar way you can add COM > 9 if you need. 

And you can extend also “Programmer used”. The list of programmers is now: arduino, avrisp, 

avrispmkII, usbtiny, usbasp, buspirate, stk500, dasa, wiring. And empty choice – it lets the 

programmer (protocol) value from the wizard.script. 

It could be possible to let the comboboxes editable and in running wizard you could write your own 

value, but it didn’t work for unknown reason. Therefore the comboboxes are locked. 

 

Don’t forget to save the wizard.xrc (Ctrl-s).  



If you try to run the wizard now you should see this: 

 

Congratulation  

  



If it doesn’t work 
Principally in this mission the C::B works the same way as the AruinoIDE. So check the Arduino-

builder.exe parameters. 

1)  

 Run arduinoIDE from your CodeBlocks directory (CodeBlocks\arduino-

1.8.5\arduino.exe) 

 Open your example.ino created by C::B wizard 

 Compile it Ctrl-r 

You will see the messages. The first one “CodeBlocks\arduino-1.8.5\arduino-

builder -dump-prefs …” is for checking of parameters. The second one 

“CodeBlocks\arduino-1.8.5\arduino-builder –compile …” is the command what 

we want call from C::B. Remember this row. 

2)  

 Build the project in C::B and in Build log window you will see messages also 

Running target pre-build steps 

cmd /X /C if not exist \example\hexy (md \example\hexy) 

cmd /X /C if not exist \Temp\example\build (md \Temp\example\build) 

cmd /X /C if not exist \Temp\example\cache (md \Temp\example\cache) 

CodeBlocks\arduino-1.8.5\arduino-builder –compile  ... 

The first three cmds create needed directories and the fourth is 

“CodeBlocks\arduino-1.8.5\arduino-builder –compile …” 

Now check if the commands (arduino-builder …) are the same. If not, investigate the reasons of 

differences and correct them by changing of environmental variables, project variables, compiler 

properties, or so on. 

 

Do the same procedure if .hex uploading doesn’t work. 

 

If it worked in the past and it doesn’t work now: 
Try to clean the building products (Tools+ -> Clean). 

 

Also look in the following Known (bad) behaviour section. 

 

  



Known (bad) behaviour: 
 Parsing of the warnings and errors goes in the Temp\example\build\sketch\file.h (or .c) 

and not in the correct example\file.c. You have to open the correct file manually and go to 

the error line manually (Ctrl-g works for it). Only .ino file works well. 

Maybe some setting in Settings -> Compiler… -> Choose Copy of GNU GCC Compiler for AVR -> 

Other settings tab -> Advanced options… -> Output parsing tab could fix it but I don’t know how. 

 

 From time to time, the nike happens in build targets files (no idea why): 

 

It brings error: 

 

Unchecking it in Project -> Properties… -> Build targets fixes it. Maybe Clean will also be 

necessary.  
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