Tweak warning message for unexpected_not_comparison
Rename "unexpected_not_for_in" to "unexpected_not_in".
Respect escaping within regular expressions.
Fix the useless assignment warning.
Fix traceback when dumping loops.
Split into two separate warnings.
Rename warning for clarity; add test.
Add a warning against invalid ! usage