requests

requests

Python Software Foundation
+
+

Related Products

  • InboxAlly
    136 Ratings
    Visit Website
  • PostScan Mail
    137 Ratings
    Visit Website
  • MOVEit
    625 Ratings
    Visit Website
  • NewOrg
    125 Ratings
    Visit Website
  • Click2Mail
    55 Ratings
    Visit Website
  • BrandMail
    332 Ratings
    Visit Website
  • Proton Mail
    108,634 Ratings
    Visit Website
  • sellerboard
    308 Ratings
    Visit Website
  • Proton VPN
    41,009 Ratings
    Visit Website
  • ESET PROTECT Advanced
    2,332 Ratings
    Visit Website

About

Inspired by MailCatcher, easier to install. MailHog is an email testing tool for developers: Configure your application to use MailHog for SMTP delivery. View messages in the web UI, or retrieve them with the JSON API. Optionally release messages to real SMTP servers for delivery. See MailHog libraries for a list of MailHog client libraries. ESMTP server implementing RFC5321. Support for SMTP AUTH (RFC4954) and PIPELINING (RFC2920). Web interface to view messages (plain text, HTML or source). Supports RFC2047 encoded headers. Real-time updates using EventSource. Release messages to real SMTP servers. Chaos Monkey for failure testing. See Introduction to Jim for more information. HTTP API to list, retrieve and delete messages. See APIv1 and APIv2 documentation for more information. HTTP basic authentication for MailHog UI and API. Multipart MIME support. Download individual MIME parts. In-memory message storage. MongoDB and file-based storage for message persistence.

About

Requests is a simple, yet elegant, HTTP library. Requests allows you to send HTTP/1.1 requests extremely easily. There’s no need to manually add query strings to your URLs, or to form-encode your PUT & POST data, but nowadays, just use the JSON method! Requests is one of the most downloaded Python packages today, pulling in around 30M downloads/week, according to GitHub, Requests is currently depended upon by 1,000,000+ repositories. You may certainly put your trust in this code. Requests is available on PyPI. Requests is ready for the demands of building robust and reliable HTTP–speaking applications, for the needs of today. Automatic content decompression and decoding. International domains and URLs. Sessions with cookie persistence. Browser-style TLS/SSL verification. Basic & digest authentication, and familiar dict–like cookies. Multi-part file uploads. SOCKS proxy support. Connection timeouts and streaming downloads.

Platforms Supported

Windows Not Supported
Mac Not Supported
Linux Not Supported
Cloud Supported
On-Premises Not Supported
iPhone Not Supported
iPad Not Supported
Android Not Supported
Chromebook Not Supported

Platforms Supported

Windows Supported
Mac Supported
Linux Supported
Cloud Not Supported
On-Premises Not Supported
iPhone Not Supported
iPad Not Supported
Android Not Supported
Chromebook Not Supported

Audience

Organizations interested in an open source email testing tool

Audience

Teams, individuals and developers looking for a solution providing a HTTP library to send requests

Support

Phone Support Not Supported
24/7 Live Support Not Supported
Online Not Supported

Support

Phone Support Not Supported
24/7 Live Support Not Supported
Online Supported

API

Offers API Not Supported

API

Offers API Not Supported

Screenshots and Videos

Screenshots and Videos

Pricing

No information available.
Free Version Not Supported
Free Trial Not Supported

Pricing

Free
Free Version Supported
Free Trial Not Supported

Reviews/Ratings

Overall 0.0 / 5
ease 0.0 / 5
features 0.0 / 5
design 0.0 / 5
support 0.0 / 5

This software hasn't been reviewed yet. Be the first to provide a review:

Review this Software

Reviews/Ratings

Overall 0.0 / 5
ease 0.0 / 5
features 0.0 / 5
design 0.0 / 5
support 0.0 / 5

This software hasn't been reviewed yet. Be the first to provide a review:

Review this Software

Training

Documentation Supported
Webinars Not Supported
Live Online Not Supported
In Person Not Supported

Training

Documentation Supported
Webinars Supported
Live Online Not Supported
In Person Not Supported

Company Information

MailHog
github.com/mailhog/MailHog

Company Information

Python Software Foundation
United States
pypi.org/project/requests/

Alternatives

Debug Mail

Debug Mail

DebugMail.io

Alternatives

Zunoy Sandbox

Zunoy Sandbox

Mentcube Innovations Pvt Ltd
HttpMaster

HttpMaster

Borvid
SpamCheetah

SpamCheetah

Gayatri Hitech
Fiddler

Fiddler

Progress Software
yarl

yarl

Python Software Foundation
HELO

HELO

Beyond Code
Unirest

Unirest

Kong

Categories

Email Testing Supported

Categories

Integrations

Oxylabs Not Supported
Python Not Supported
Stat Proxies Not Supported

Integrations

Oxylabs Supported
Python Supported
Stat Proxies Supported
Claim MailHog and update features and information
Claim MailHog and update features and information
Claim requests and update features and information
Claim requests and update features and information