TekSIP

TekSIP

KaplanSoft
+
+

Related Products

  • MuukTest
    34 Ratings
    Visit Website
  • CEX.IO
    29 Ratings
    Visit Website
  • Parasoft
    152 Ratings
    Visit Website
  • Checksum.ai
    2 Ratings
    Visit Website
  • Virtuoso QA
    131 Ratings
    Visit Website
  • KrakenD
    76 Ratings
    Visit Website
  • DataImpulse
    31 Ratings
    Visit Website
  • Cerberus FTP Server
    159 Ratings
    Visit Website
  • DataHub
    10 Ratings
    Visit Website
  • Codemagic
    138 Ratings
    Visit Website

About

API Tester is a completely free mobile app available on iOS, Android, macOS, and watchOS. It is a functional API testing tool that allows users to complete compound tasks on any device. - Test any API on the go: REST, GraphQL, WebSocket, SOAP, JSON RPC, XML, HTTP, HTTPS. - GET, POST, PUT, PATCH, DELETE, etc. HTTP request methods are supported. - Perform the API calls with any kind of request data encoding and transfer type. - Import collections from Swagger, Postman, and YAML, or import requests using cURL, as well as export created requests via link or cURL. - Use a powerful GraphQL editor with full-scale experience. - WebSocket testing tool is available: handles connection and message exchange via WS or WSS. The API Tester mobile app allows you to get the job away from your workstation. Save time, work from anywhere!

About

TekSIP is a SIP Registrar and SIP Proxy for Windows. TekSIP supports UDP, TCP, TLS and WebSocket (IPv4 & IPv6) transports. TLS and Secure WebSocket are supported in only commercial editions. TekSIP is tested on Microsoft Windows Vista, Windows 7/8/10/11 and Windows 2008-2022 server. TekSIP can be deployed as a signaling server for WebRTC based SIP phones. TekSIP complies with RFC 3261, RFC 3263, RFC 3311, RFC 3581 and RFC 3891. It supports NAT traversal and ENUM. Please see technical details about NAT traversal in Readme. You can select IP address to be listened and alternative SIP endpoints for outgoing calls. You can also log session details into a log file and monitor active registrations and sessions in real-time. You can monitor number of active registrations and sessions using Windows Performance Monitor (Perfmon.exe). TekSIP can redirect calls to alternate endpoint when called endpoint is unavailable (Off-line, busy...). Active SIP session can be terminated via GUI.

Platforms Supported

Windows Not Supported
Mac Supported
Linux Not Supported
Cloud Not Supported
On-Premises Not Supported
iPhone Supported
iPad Supported
Android Supported
Chromebook Not Supported

Platforms Supported

Windows Supported
Mac Not Supported
Linux Not Supported
Cloud Not Supported
On-Premises Supported
iPhone Not Supported
iPad Not Supported
Android Not Supported
Chromebook Not Supported

Audience

Programmers and developers who design, debug, and test APIs

Audience

Enterprise, Service Providers, Utility Companies

Support

Phone Support Not Supported
24/7 Live Support Not Supported
Online Supported

Support

Phone Support Supported
24/7 Live Support Supported
Online Supported

API

Offers API Not Supported

API

Offers API Supported

Screenshots and Videos

Screenshots and Videos

Pricing

Completely free
All features are available for free
Free Version Supported
Free Trial Not Supported

Pricing

$239
Freeware version allows maximum 3 SIP endpoints registration and 3 simultaneous SIP sessions. Enterprise edition allows upto 100 simultaneous registration and SIP sessions. Following features are not supported in free edition;

Enterprise
* SDP Manipulation
* TLS Transport
* SMPP Gateway

SP
* Enterprise features
* External Authenticator
* SRTP -> RTP interworking
* WebRTC Media Gateway
* Unlimited number of simultaneous SIP registrations and sessions
* Route incoming calls to registered extensions
* IPv6 support
* RADIUS AAA
Free Version Supported
Free Trial Supported

Reviews/Ratings

Overall 5.0 / 5
ease 5.0 / 5
features 4.5 / 5
design 5.0 / 5
support 5.0 / 5

Reviews/Ratings

Overall 0.0 / 5
ease 0.0 / 5
features 0.0 / 5
design 0.0 / 5
support 0.0 / 5

This software hasn't been reviewed yet. Be the first to provide a review:

Review this Software

Pros & Cons from Real Users

Pros

  • API Tester is free. The best GraphQL editor I ever saw. It gives the option to run literally any type of API. Easy import options. Pleasant user experience overall. Learning how to use the app wouldn't take too long.
  • Application is pretty simple, straightforward and works well. Validating Restful and SOAP APIs, WebSocket applications, as well as GraphQL applications has been a good experience using API Tester. All the underlying challenges that come to mind for testing backend applications are well served. What is more important - it's completely free and all features are available without any fees. This mobile app increased my productivity, and I can test APIs from anywhere on the planet using only a mobile device.

Cons

  • Not optimal for fully automated testing, but it would be unfair to demand this from a mobile solution.
  • The only cons is the lack of a desktop version. I think it could replace my other desktop alternatives.

Training

Documentation Supported
Webinars Not Supported
Live Online Not Supported
In Person Not Supported

Training

Documentation Supported
Webinars Not Supported
Live Online Supported
In Person Not Supported

Company Information

API Tester
Founded: 2020
United Kingdom
apitester.org

Company Information

KaplanSoft
Founded: 2011
Turkey
www.kaplansoft.com

Alternatives

JIterator

JIterator

Windex Inc

Alternatives

TekIVR

TekIVR

KaplanSoft
TekRADIUS

TekRADIUS

KaplanSoft
websockets

websockets

Python Software Foundation
HttpMaster

HttpMaster

Borvid
SoapUI

SoapUI

SmartBear

Categories

API Testing Supported

Categories

Telephony Supported

API Testing Features

Functional Testing Supported
Fuzz Testing Supported
Load Testing Supported
Penetration Testing Supported
Runtime and Error Detection Supported
Security Testing Supported
UI Testing Supported
Validation Testing Supported

Telephony Features

Auto-Dialer Not Supported
Call Center Management Not Supported
Call Monitoring Supported
Contact Management Not Supported
Inbound Reporting Not Supported
IVR / Voice Recognition Not Supported
Outbound Reporting Not Supported
Predictive Dialer Not Supported
Telemarketing Management Not Supported
Voice & Data Integration Supported
VoIP Supported

Integrations

TekRADIUS Not Supported

Integrations

TekRADIUS Supported
Claim API Tester and update features and information
Claim API Tester and update features and information
Claim TekSIP and update features and information
Claim TekSIP and update features and information