| Name | Modified | Size | Downloads / Week |
|---|---|---|---|
| Parent folder | |||
| README.md | 2026-07-29 | 21.8 kB | |
| v0.15.0 source code.tar.gz | 2026-07-29 | 20.6 MB | |
| v0.15.0 source code.zip | 2026-07-29 | 20.8 MB | |
| Totals: 3 Items | 41.4 MB | 0 | |
What's Changed
- Notify memtable writer channels on close by @criccomini in https://github.com/slatedb/slatedb/pull/1727
- Add "Clones, branches & rescaling" feature to homepage & docs links by @agavra in https://github.com/slatedb/slatedb/pull/1728
- Write amplification metrics by @oliverrogalski1001 in https://github.com/slatedb/slatedb/pull/1648
- Track the entire scanned range in
DbIteratorRangeTrackerto fix some phantom reads and write skew by @kirinrastogi in https://github.com/slatedb/slatedb/pull/1710 - enable
staticlibfor slatedb-uniffi by @vitoordaz in https://github.com/slatedb/slatedb/pull/1734 - Fix flaky
test_commit_compacted_entries_writes_manifestby @criccomini in https://github.com/slatedb/slatedb/pull/1736 - Add Taquba to Adopters list in README by @micllam in https://github.com/slatedb/slatedb/pull/1738
- Remove Copy constraint from transactional Ids by @fracek in https://github.com/slatedb/slatedb/pull/1737
- Bounds validation by @zach-schoenberger in https://github.com/slatedb/slatedb/pull/1729
- Error on same key with different TTL in batch by @criccomini in https://github.com/slatedb/slatedb/pull/1740
- Update SST size estimations by @cadonna in https://github.com/slatedb/slatedb/pull/1739
- feat(txn-obj): add Invariant<t> predicates run implicitly in update() by @geeknarrator in https://github.com/slatedb/slatedb/pull/1741
- feat: use batch delete for GC by @KarinaMilet in https://github.com/slatedb/slatedb/pull/1742
- feat: add L0 flush stall metric by @viveknathani in https://github.com/slatedb/slatedb/pull/1745
- Distributed Compaction (RFC-0025) Phase 3: Compaction Worker by @ryandielhenn in https://github.com/slatedb/slatedb/pull/1730
- fix compaction bench & add zstd [minor] by @agavra in https://github.com/slatedb/slatedb/pull/1748
- Improve
WriteBatchperformance by @criccomini in https://github.com/slatedb/slatedb/pull/1746 - chore: use
SlateDBErrorinstead ofdebug_assertby @KarinaMilet in https://github.com/slatedb/slatedb/pull/1751 - Verify
test_should_compact_expired_entriessettles on one SR by @criccomini in https://github.com/slatedb/slatedb/pull/1752 - docs: add range scans tutorial by @ryanmiville in https://github.com/slatedb/slatedb/pull/1744
- feat(manifest): add l0_ulid_cutoff invariant + L0 ULID watermark helper by @geeknarrator in https://github.com/slatedb/slatedb/pull/1747
- revert batch GC deletion by @agavra in https://github.com/slatedb/slatedb/pull/1756
- RFC for decoupled pluggable object store cache by @nomiero in https://github.com/slatedb/slatedb/pull/1653
- Retry bounds by @zach-schoenberger in https://github.com/slatedb/slatedb/pull/1743
- update RFC 0027 to change the order of object store wrappers by @nomiero in https://github.com/slatedb/slatedb/pull/1761
- Extend DST nightly timeout length by @criccomini in https://github.com/slatedb/slatedb/pull/1764
- perf(compaction): increase blocks_to_fetch default (+ configuration) by @agavra in https://github.com/slatedb/slatedb/pull/1763
- add RFC-0028: subcompactions by @agavra in https://github.com/slatedb/slatedb/pull/1755
- perf(compaction): pipeline SST close() off the main merge loop by @agavra in https://github.com/slatedb/slatedb/pull/1762
- feat: make metric level configurable by @viveknathani in https://github.com/slatedb/slatedb/pull/1760
- Remove boundary checks in GC deletion path by @criccomini in https://github.com/slatedb/slatedb/pull/1766
- Fix nightly microbenchmark baseline updates by @criccomini in https://github.com/slatedb/slatedb/pull/1765
- Improve nightly microbenchmark failure reporting by @criccomini in https://github.com/slatedb/slatedb/pull/1767
- website: add HelixDB to "used by" logos by @xav-db in https://github.com/slatedb/slatedb/pull/1725
- Revert "Improve nightly microbenchmark failure reporting (#1767)" by @criccomini in https://github.com/slatedb/slatedb/pull/1770
- Update local checkpoint in DbReader on refresh by @criccomini in https://github.com/slatedb/slatedb/pull/1771
- Enforce ordering in FlatBuffer maps by @criccomini in https://github.com/slatedb/slatedb/pull/1776
- Propose listing segments API in RFC-0024 by @cadonna in https://github.com/slatedb/slatedb/pull/1731
- Distributed compaction (RFC-0025) Phase 3.1: Wire up Compactor to use CompactionWorker and add Scheduled State by @ryandielhenn in https://github.com/slatedb/slatedb/pull/1753
- Drop unsurviving segment prefixes in ImmutableMemtable::filter_after_seq by @cadonna in https://github.com/slatedb/slatedb/pull/1773
- Bump commit compacted interval to 5s in DST by @criccomini in https://github.com/slatedb/slatedb/pull/1780
- [bindings] expose CloneBuilder to bindings by @vitoordaz in https://github.com/slatedb/slatedb/pull/1782
- fix: rename data block cache options and always cache SST metadata by @viveknathani in https://github.com/slatedb/slatedb/pull/1772
- Move ownership of transaction into WriteBatchMessage to prevent cancellation race by @kirinrastogi in https://github.com/slatedb/slatedb/pull/1733
- Honor visible_range when popping SSTs in SortedRunView by @criccomini in https://github.com/slatedb/slatedb/pull/1781
- Add Admin::create_clone_builder_from_source to preserve per-source projection range by @rkhachatryan in https://github.com/slatedb/slatedb/pull/1785
- Move
rand.rstoslatedb-commonby @criccomini in https://github.com/slatedb/slatedb/pull/1789 - Remove
PrefixStorefromslatedb-txn-objobject store protocol by @criccomini in https://github.com/slatedb/slatedb/pull/1792 - Retry in compactor state protocol instantiation by @criccomini in https://github.com/slatedb/slatedb/pull/1795
- Distributed Compaction (RFC-0025) Phase 3.2: Add per-ticker jitter to MessageDispatcherTicker by @ryandielhenn in https://github.com/slatedb/slatedb/pull/1784
- Deflake test_dispatcher_ticker_jitter_does_not_block_messages by @ryandielhenn in https://github.com/slatedb/slatedb/pull/1796
- Expose segment prefixes through DbStatus and report them from the writer by @cadonna in https://github.com/slatedb/slatedb/pull/1774
- Unify
GarbageCollector::runandCompactor::runimplementation style by @criccomini in https://github.com/slatedb/slatedb/pull/1793 - Require a matching segment extractor when opening a DbReader by @cadonna in https://github.com/slatedb/slatedb/pull/1775
- Distributed Compaction (RFC-0025) Phase 4: Add worker heartbeats and job reclamation by @ryandielhenn in https://github.com/slatedb/slatedb/pull/1786
- Generalize
scan_prefixto scan a subrange within the prefix by @apurvam in https://github.com/slatedb/slatedb/pull/1783 - Expose Go, Java, Python, and Node bindings for list_segments() by @cadonna in https://github.com/slatedb/slatedb/pull/1804
- Add
scancommand to slatedb-cli (#1788) by @hniksic in https://github.com/slatedb/slatedb/pull/1805 - Fix bug in segment reporting by @cadonna in https://github.com/slatedb/slatedb/pull/1803
- Expose
ObjectMetadatafor generic object metadata info by @criccomini in https://github.com/slatedb/slatedb/pull/1798 - feat: add ByteRangeBounds to improve scan and scan_prefix ergonomics by @viveknathani in https://github.com/slatedb/slatedb/pull/1809
- feat(compaction): add subcompaction data model (RFC-0028) [1/N] by @agavra in https://github.com/slatedb/slatedb/pull/1812
- clone: allow union clones over fence-only WAL sources by @rkhachatryan in https://github.com/slatedb/slatedb/pull/1811
- Use multithreaded Tokio runtime for background tasks in bindings by @criccomini in https://github.com/slatedb/slatedb/pull/1819
- feat(compaction): report worker progress as subcompactions (RFC-0028) [2/N] by @agavra in https://github.com/slatedb/slatedb/pull/1817
- chore: expose prefix subranges in UniFFI bindings by @viveknathani in https://github.com/slatedb/slatedb/pull/1821
- Add
GcFilterto garbage collector by @criccomini in https://github.com/slatedb/slatedb/pull/1807 - RFC 0027 impl (1/N) - Add tags for table store calls to ObjectStore by @nomiero in https://github.com/slatedb/slatedb/pull/1808
- docs: remove extra space from note block declaration by @viveknathani in https://github.com/slatedb/slatedb/pull/1824
- feat(compaction): execute subcompactions in parallel (RFC-0028) [3/N] by @agavra in https://github.com/slatedb/slatedb/pull/1820
- ci: add TableStoreKind to subcompaction test helper by @ryandielhenn in https://github.com/slatedb/slatedb/pull/1826
- Remove OpenDAL environment variables by @criccomini in https://github.com/slatedb/slatedb/pull/1827
- decouple job state from compaction state + fix merge retention by @rodesai in https://github.com/slatedb/slatedb/pull/1825
- Upgrade object_store to 0.14 by @criccomini in https://github.com/slatedb/slatedb/pull/1828
- Update caching.mdx cached object store docs by @criccomini in https://github.com/slatedb/slatedb/pull/1830
- Distributed Compaction (RFC-0025) Phase 5: Compaction Metrics by @ryandielhenn in https://github.com/slatedb/slatedb/pull/1802
- feat(compaction): subcompaction planning heuristic (RFC-0028) [4/N] by @agavra in https://github.com/slatedb/slatedb/pull/1829
- test(dst): calibrate deterministic simulation runs by @criccomini in https://github.com/slatedb/slatedb/pull/1834
- Validate compacted compactions against local segment sr IDs by @criccomini in https://github.com/slatedb/slatedb/pull/1836
- fix submit-compaction clap arg group by @agavra in https://github.com/slatedb/slatedb/pull/1839
- fix: merge_remote_compactions should accept stale terminal/compacted entries by @ryandielhenn in https://github.com/slatedb/slatedb/pull/1840
- [bindings] add checkpoints operations to admin by @vitoordaz in https://github.com/slatedb/slatedb/pull/1842
- Remove compactor worker metric pruning by @criccomini in https://github.com/slatedb/slatedb/pull/1843
- [bindings] add unit tests for new admin checkpoint methods by @vitoordaz in https://github.com/slatedb/slatedb/pull/1844
- fix(compaction): carry block transformer and filter policies on CompactionWorkerBuilder by @Barre in https://github.com/slatedb/slatedb/pull/1833
- [codex] Fix Python aarch64 manylinux wheel build by @criccomini in https://github.com/slatedb/slatedb/pull/1847
- Format bytes in International System of Units (SI) by @criccomini in https://github.com/slatedb/slatedb/pull/1848
- Add merge operator to admin builder by @cadonna in https://github.com/slatedb/slatedb/pull/1841
- Improve GC logging by @criccomini in https://github.com/slatedb/slatedb/pull/1855
- Stop executing compaction job if it's no longer owned by @criccomini in https://github.com/slatedb/slatedb/pull/1856
- minor: collapse
active_jobsintojob_progressin CompactionWorkerHandler by @ryandielhenn in https://github.com/slatedb/slatedb/pull/1861 - fix wal replay point propagation by serializing flush on writer task by @rodesai in https://github.com/slatedb/slatedb/pull/1857
- Make DST
MergeOperatorassociative by @criccomini in https://github.com/slatedb/slatedb/pull/1866 - Enable hourly DST runs by @criccomini in https://github.com/slatedb/slatedb/pull/1868
- cleanup durable clock tick bookkeeping by @rodesai in https://github.com/slatedb/slatedb/pull/1867
- Change DST runner to ubuntu-latest by @criccomini in https://github.com/slatedb/slatedb/pull/1869
- Heartbeat in CompactorWorker by @criccomini in https://github.com/slatedb/slatedb/pull/1864
- site: initial blog post and misc homepage changes by @agavra in https://github.com/slatedb/slatedb/pull/1865
- site: generate opengraph images for blogs by @agavra in https://github.com/slatedb/slatedb/pull/1870
- (site) add google analytics by @agavra in https://github.com/slatedb/slatedb/pull/1872
- use the CompactorBuilder's own object store for the in-process compactor by @Barre in https://github.com/slatedb/slatedb/pull/1852
- website LLM/Agent friendliness by @agavra in https://github.com/slatedb/slatedb/pull/1874
- Allow users to specify DST seeds to make replay easier by @criccomini in https://github.com/slatedb/slatedb/pull/1877
- update FAQ about column families (minor) by @agavra in https://github.com/slatedb/slatedb/pull/1878
- Remove
CompactionExecutorbyte-based heartbeating by @criccomini in https://github.com/slatedb/slatedb/pull/1875 - minor: downgrade log level in
validate_compactionby @ryandielhenn in https://github.com/slatedb/slatedb/pull/1880 - Remove useless
last_hb_msfromCompactionWorkerby @criccomini in https://github.com/slatedb/slatedb/pull/1881 - RFC 0027 impl (2/N) - Define CachedObjectStore policy and use it in the cache by @nomiero in https://github.com/slatedb/slatedb/pull/1876
- Tolerate key gaps in sorted runs during manifest projection by @rkhachatryan in https://github.com/slatedb/slatedb/pull/1887
- [fix] : Add UnownedDbCache to fix FoyerHybridCache close behaviour by @geeknarrator in https://github.com/slatedb/slatedb/pull/1889
- [codex] Split hourly DST tests by @criccomini in https://github.com/slatedb/slatedb/pull/1891
- Add standalone GC docs by @criccomini in https://github.com/slatedb/slatedb/pull/1897
- Add
run_gc_onceto bindings by @criccomini in https://github.com/slatedb/slatedb/pull/1895 - add docs and uniffi bindings for segments by @agavra in https://github.com/slatedb/slatedb/pull/1896
- Merge External DB entries based on contents, not on checkpoint ID by @rkhachatryan in https://github.com/slatedb/slatedb/pull/1851
- RFC 0027 impl (3/N) - Support for multipart upload caching by @nomiero in https://github.com/slatedb/slatedb/pull/1883
- Disable
CompactorWorker.compactionwrites on SST progress by @criccomini in https://github.com/slatedb/slatedb/pull/1884 - Add GCS support to CLI by @criccomini in https://github.com/slatedb/slatedb/pull/1898
- Reestablish checkpoint in
DbReaderif removed by @criccomini in https://github.com/slatedb/slatedb/pull/1900 - Run GC deletion passes with bounded concurrency by @flexorRegev in https://github.com/slatedb/slatedb/pull/1894
- Replace
DefaultStoreProviderwithObjectStoresinDbReaderby @criccomini in https://github.com/slatedb/slatedb/pull/1905 - Fix flaky test_compactor_compacts_only_target_segment by @criccomini in https://github.com/slatedb/slatedb/pull/1906
- Resolve external SSTs in DbReader so zero-copy clones are readable by @widagdos in https://github.com/slatedb/slatedb/pull/1907
- [k/N] wal refactor: reorganize wal buffer so its owned by batch writer by @rodesai in https://github.com/slatedb/slatedb/pull/1882
- [k/n] wal refactor: only update last seen wal id with flushed wals by @rodesai in https://github.com/slatedb/slatedb/pull/1885
- Blog post on segmentation by @hachikuji in https://github.com/slatedb/slatedb/pull/1912
- [1908] Wire RetryingObjectStore into Admin and Clone paths by @geeknarrator in https://github.com/slatedb/slatedb/pull/1909
- 1707 RFC-0029 GC Safe SST Ulid Allocator by @geeknarrator in https://github.com/slatedb/slatedb/pull/1822
- Did small refactoring for db_state.rs triple-duplicates first/last key logic by @KrishnaSindhur in https://github.com/slatedb/slatedb/pull/1916
- Optimize DST binary by @criccomini in https://github.com/slatedb/slatedb/pull/1918
- RFC 0027 impl (4/N) - wiring object store cache for compaction and gc by @nomiero in https://github.com/slatedb/slatedb/pull/1899
- extract gc deletion into maybe_delete methods by @nomiero in https://github.com/slatedb/slatedb/pull/1919
- Add a DST for DB rescaling by @criccomini in https://github.com/slatedb/slatedb/pull/1920
- Allow users to disable boundary files in GC by @criccomini in https://github.com/slatedb/slatedb/pull/1917
- adds schema evolution docs wrt
PrefixExtractorby @owen-d in https://github.com/slatedb/slatedb/pull/1921 - Regenerate Go bindings by @criccomini in https://github.com/slatedb/slatedb/pull/1922
- Add
DbReaderModeand latest manifest polling by @criccomini in https://github.com/slatedb/slatedb/pull/1915 - Clarify impact of disabled boundary files by @criccomini in https://github.com/slatedb/slatedb/pull/1925
- [k/N] wal refactor: reorganize WalBufferManager into separate handles that share inner by @rodesai in https://github.com/slatedb/slatedb/pull/1886
- fix accounting for max_concurrent_compactions by @agavra in https://github.com/slatedb/slatedb/pull/1926
- k/N wal refactor: drop last seq tracking from the wal by @rodesai in https://github.com/slatedb/slatedb/pull/1927
- switch fence fault injection over to fail channel from fail-parallel by @rodesai in https://github.com/slatedb/slatedb/pull/1928
- [1923] Add configurable object-store retry bound by @geeknarrator in https://github.com/slatedb/slatedb/pull/1924
- Eliminate unnecessary object store requests made on each
CommitCompactedtick and increase worker default heartbeat_interval by @ryandielhenn in https://github.com/slatedb/slatedb/pull/1931 - [1941] Fix stale nightly benchmark description in slatedb-bencher README by @1996fanrui in https://github.com/slatedb/slatedb/pull/1942
- [1923] Expose object_store_max_retries on UniFFI by @geeknarrator in https://github.com/slatedb/slatedb/pull/1933
- Fix flaky local filesystem boundary test by @criccomini in https://github.com/slatedb/slatedb/pull/1940
- remove fsync from cached object store by @nomiero in https://github.com/slatedb/slatedb/pull/1945
- [1932] Expose manifest structural counts as DbStats gauges by @1996fanrui in https://github.com/slatedb/slatedb/pull/1934
- wal refactor k/N: simplify backpressure to use flushed events only by @rodesai in https://github.com/slatedb/slatedb/pull/1930
- Fix stale external SSTs after manifest merge by @tysont in https://github.com/slatedb/slatedb/pull/1936
- [1938] Count active memtable in total_mem_size_bytes (fix 0 with WAL disabled) by @1996fanrui in https://github.com/slatedb/slatedb/pull/1939
- rename wait_until_wal_released->wait_until_wal_flushed by @rodesai in https://github.com/slatedb/slatedb/pull/1946
- [1943] Add Settings::validate to reject conflicting configuration by @1996fanrui in https://github.com/slatedb/slatedb/pull/1950
- fix: prune SST IDs from external_dbs that were projected out by @rkhachatryan in https://github.com/slatedb/slatedb/pull/1949
- fix: avoid retaining full cache parts for range reads by @criccomini in https://github.com/slatedb/slatedb/pull/1953
- add RFC for custom WAL implementations by @rodesai in https://github.com/slatedb/slatedb/pull/1911
- Update README with database split/merge status by @nomiero in https://github.com/slatedb/slatedb/pull/1959
- Freeze large memtables on WAL replay by @criccomini in https://github.com/slatedb/slatedb/pull/1955
- (RFC-0029) Move L0 SST id allocation to dispatch by @geeknarrator in https://github.com/slatedb/slatedb/pull/1957
- RFC 0031 - pluggable block cache policy by @nomiero in https://github.com/slatedb/slatedb/pull/1913
- Apply ruff check --fix with ruff 0.16 for python bindings by @nomiero in https://github.com/slatedb/slatedb/pull/1965
- Account for WAL bytes in write backpressure by @criccomini in https://github.com/slatedb/slatedb/pull/1967
- RFC - 0031 impl: Block cache policy - writes by @nomiero in https://github.com/slatedb/slatedb/pull/1962
- Make object store cache pluggable and external by @nomiero in https://github.com/slatedb/slatedb/pull/1947
- [rfc-30 1/N]: refactor writer WAL write path to use new traits by @rodesai in https://github.com/slatedb/slatedb/pull/1961
- Fix panic when probing a zero-bit prefix Bloom filter by @uttom-akash in https://github.com/slatedb/slatedb/pull/1969
- fix flaky test_size_based_flush_triggering by @criccomini in https://github.com/slatedb/slatedb/pull/1979
- [1977] Fix flaky test_backpressure_waiter_exits_when_db_is_fenced by @1996fanrui in https://github.com/slatedb/slatedb/pull/1978
- Fix test_compactor_applies_output_cache_policy by @criccomini in https://github.com/slatedb/slatedb/pull/1981
- convert block prefetch panic to error by @nomiero in https://github.com/slatedb/slatedb/pull/1983
- Add simple trivial moves to compactor scheduler by @criccomini in https://github.com/slatedb/slatedb/pull/1982
- Add DbIterator.next_batch to the UniFFI binding by @JayJamieson in https://github.com/slatedb/slatedb/pull/1986
- Probe latest sequenced objects before listing by @criccomini in https://github.com/slatedb/slatedb/pull/1968
New Contributors
- @oliverrogalski1001 made their first contribution in https://github.com/slatedb/slatedb/pull/1648
- @micllam made their first contribution in https://github.com/slatedb/slatedb/pull/1738
- @fracek made their first contribution in https://github.com/slatedb/slatedb/pull/1737
- @geeknarrator made their first contribution in https://github.com/slatedb/slatedb/pull/1741
- @viveknathani made their first contribution in https://github.com/slatedb/slatedb/pull/1745
- @ryanmiville made their first contribution in https://github.com/slatedb/slatedb/pull/1744
- @xav-db made their first contribution in https://github.com/slatedb/slatedb/pull/1725
- @hniksic made their first contribution in https://github.com/slatedb/slatedb/pull/1805
- @flexorRegev made their first contribution in https://github.com/slatedb/slatedb/pull/1894
- @widagdos made their first contribution in https://github.com/slatedb/slatedb/pull/1907
- @owen-d made their first contribution in https://github.com/slatedb/slatedb/pull/1921
- @1996fanrui made their first contribution in https://github.com/slatedb/slatedb/pull/1942
- @tysont made their first contribution in https://github.com/slatedb/slatedb/pull/1936
- @uttom-akash made their first contribution in https://github.com/slatedb/slatedb/pull/1969
- @JayJamieson made their first contribution in https://github.com/slatedb/slatedb/pull/1986
Full Changelog: https://github.com/slatedb/slatedb/compare/v0.13.1...v0.15.0