Password quality checker for LDAP Icon

Password quality checker for LDAP

Plugin for OpenLDAP who checks password quality

Add a Review
0 Downloads (This Week)
Last Update:
Download pqchecker-1.2.0-src.tgz
Browse All Files
BSD Mac Solaris Linux

Screenshots

Description

ppInspect become pqChecker (just change the name)
OpenLDAP directory with the PPolicy overlay can manage a passwords policy, especially the password quality. Making this feature pass through adding a plug-in ( dynamic shared library) who execute the essential of job. pqChecker is this plug-in. Settings of passwords quality are:

. Number of required uppercase characters.
. Number of required lowercase characters.
. Number of required special characters.
. Number of required digits.
. Forbidden characters list.

Password quality checker for LDAP Web Site

Features

  • Control the quality of the password before storing it in the dedicated directory attribute. If the password mets configured parameters, it is accepted. It is rejected otherwise.
  • Allows easy parameters management, by providing two functions for consultation and modification: bool set_params(char *params, char *fmt); bool get_params(char *params, char *fmt);

KEEP ME UPDATED

Write a Review

User Reviews

Be the first to post a review of Password quality checker for LDAP!

Additional Project Details

Languages

English

Intended Audience

System Administrators, Developers

Programming Language

C

Registered

2014-03-16

Thanks for helping keep SourceForge clean.

Screenshot instructions:
Windows
Mac
Red Hat Linux   Ubuntu

Click URL instructions:
Right-click on ad, choose "Copy Link", then paste here →
(This may not be possible with some types of ads)

More information about our ad policies
X

Briefly describe the problem (required):

Upload screenshot of ad (required):
Select a file, or drag & drop file here.

Please provide the ad click URL, if possible:

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks