No Virtual Drive

  • Anonymous - 2012-04-14

    Installed x64 2.1.1 Full and all seemed to go fine. Everything seems to be
    working as it should, except there is on Z drive, or any other new drive
    letter. X: is the lowest drive letter I have assigned to a network share.

  • Bong Cosca

    Bong Cosca - 2012-04-14

    Try opening a cmd prompt and switch to drive Z:, Y:, etc. Are you using Win7?

  • Anonymous - 2012-04-14

    Win 7 Pro 64bit. I tried every drive letter not assigned to a known share or
    drive. No luck.

  • Anonymous - 2012-05-10


    I have a similar problem!

    I am using Z-WAMP 2.1.2. (i386 build) on Windows Vista Ultimate (32bits).

    WAMP is working fine.

    Z: drive is already mapped as a network share by our network administrator.

    Z-WAMP doesn't create a new virtual drive. When I open access log from menu
    and try to save it, it shows path

    Z:.sys\apache2\logs and won't save the log, because Z: drive is already taken
    by network share.

  • Balerion

    Balerion - 2012-07-04

    I also have this issue. When I run zwamp it doesn't create the z drive. It
    adds all the stuff to the path variable but doesn't create the drive.

    I am on windows 7 64bit. Using Zwamp 2.1.5 (x86_64 build).

    It would be really nice if this could be sorted out as I have to edit the path
    variable every time I start it up to path PHP to where I have it sitting
    because it wipes out the changes and adds the reference to the z drive that it
    isn't creating. So command line PHP isn't working.

  • Bong Cosca

    Bong Cosca - 2012-07-04

    Z-WAMP requires elevated privileges to run. Does your Windows account have
    administrative rights? Do you have other virtual drive software running, e.g.
    Daemon Tools, WinCDEmu, MagicISO?

  • Balerion

    Balerion - 2012-07-04

    It is running as an Admin and I have no other virtual drive software running.
    I am actually having this issue on both my computers. They are both running
    win7 and the same version of Zwamp.

  • Bong Cosca

    Bong Cosca - 2012-07-04

    Try executing this on the command line using cmd:

    subst z: <directory>

    Replace <directory> with the full path to the location of Z-WAMP's vdrive
    folder. For example,

    subst z: "C:\Program Files\ZWAMP\vdrive"

    Does that generate any error? Does it create a z: drive?

  • Balerion

    Balerion - 2012-07-04

    No error at all and it creates the virtual drive. I guess that is a bonus.
    Just need to find out why zwamp isn't doing it.

  • Bong Cosca

    Bong Cosca - 2012-07-04

    Try disabling UAC temporarily and restart ZWAMP. This way we can rule out
    administrative rights as the issue.

  • Balerion

    Balerion - 2012-07-06

    Ok. Disabling UAC seems to do it. Any way around that. With UAC on I have it
    set to run as an admin so it should be able to.

  • seof

    seof - 2013-05-09

    Hi, I run into the same problem. example as an administrator
    the subst shows the drive
    In fact the Z drive is well created .. at least if we run zwamp.exe as administrator but the command cmd as a simple user will not show any drive
    if I run cmd through totalcommander as administrator subst showsit well.
    Z:\: => C:\zwamp\vdrive


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks