Constant Joins/Parts (Freenode Timeouts)

  • CyberMonk

    CyberMonk - 2010-07-19

    I've been using ZNC for some time, and have tried a number of things to no avail, so I thought I'd ask here.  One of my IRC connections is to Freenode, and for some reason that connection (and only that connection) is plagued with tons of joins/parts whenever I reattach to the connection.  Once attached, there is no problem; however, as I generally detach overnight, when I return in the morning and reattach I'm presented with a horde of joins/parts in my buffer (I have buffextras enabled in order to keep track).

    The joins/parts generally present as ping timeouts; however, I never experience any timeouts once attached to the connection via an IRC client.  (I've been using Colloquy, and am wondering if that could be the cause of this issue?)  I have fakeonline, fixfreenode, log, nickserv, simple_away, and stickychan modules enabled for the Freenode connection.  I have tried various combinations of these modules to no avail.

    Has anyone else experienced a problem like, and/or does anyone know what might be causing it?  Thanks in advance for any help, and let me know if any further information on my setup is needed.

    P.S. I'm running ZNC 0.092 on Ubuntu Server, compiled with -enable-extras and using checkinstall.

  • Nobody/Anonymous

    Your znc reconnects to the IRC server? Why? How often?

  • Nobody/Anonymous

    I don't know why, hence my question :)

    I don't seem to disconnect at all when I'm attached to the ZNC user.  However, as soon as I detach, the ZNC bot starts parting/joining Freenode, lising ping timeouts as the reason.  This only occurs when detached; I experience no timeout behavior when attached.

  • Steven

    Steven - 2010-07-21

    It sounds like ZNC is not replying to Freenode's PING requests. Have you tried different servers on the Freenode network, with this issue occurring on all of them?

    First option I suggest is to use the antiidle module.

    If the issue persists, or would prefer a specific fix, restart ZNC in debug mode (znc -D), have it connect to Freenode, attach yourself, load the raw module, do nothing but sit and wait (to force Freenode to send a PING request) and note (either in your shell or IRC client) how your IRC client responds to Freenode's PING requests. Then, detach yourself, switch back to your shell, wait for Freenode to issue another PING request and see how ZNC responds.

    If you want, reply with the output - the PING request and PONG response (if one was returned) - when both attached and detached.

  • Nobody/Anonymous

    Thanks for the response!

    I have tried a couple different Freenode servers and had the same issue.  I've just enabled Antiidle and am leaving the user detached; I'll report back in the morning if there are issues.  Thanks a bunch!


Log in to post a comment.