#3 Screen trashed when change methods

closed
nobody
None
5
2006-05-17
2006-05-14
Shixin Zeng
No

to produce the bug:
1. install zhcon 0.2.5
2. launch it with parameter: --utf8
3. show some Chinese charactors on screen. To do so,
you could do 'cat a_file_contains_Chinese_charactors.txt'
4. Active Chinese input methods by Ctrl-Space.
5. Hit 'Ctrl-Shift' to change input methods. Stare at
the Charactors display produced by the step 3. The
Chinese charactors would be garbled when the input
method changed to 'Hanglie30', and they wouldn't be
normal until the input method changed to 'QuanPin2'.

zhcon 0.2.5, launched with '--utf8'
x86_64, CentOS with the kernel 2.6.9 and gcc 3.4.5

Discussion

  • Le Zhang

    Le Zhang - 2006-05-17
    • status: open --> closed
     
  • Le Zhang

    Le Zhang - 2006-05-17

    Logged In: YES
    user_id=209841

    It's a known issue under x86_64. Someone sent me a patch a
    while ago, but is not incorporated in 0.2.5 because I have
    no x86_64 machine to test it. I'll design a new version of
    input module to address this problem.

    ejoy

     
  • Le Zhang

    Le Zhang - 2006-05-17
    • status: closed --> open
     
  • Le Zhang

    Le Zhang - 2006-05-17
    • status: open --> pending
     
  • Le Zhang

    Le Zhang - 2006-05-17

    Logged In: YES
    user_id=209841

    Well, when switching to big5 input method, the encoding will
    be changed to big5, causing some gb text looks crashed. This
    is a limitation of zhcon's encoding scheme, not a bug.
    Future zhcon will have ucs2 internal and will not have such
    problem.

    Thanks for the report.
    ejoy

     
  • Le Zhang

    Le Zhang - 2006-05-17
    • status: pending --> closed
     

Log in to post a comment.