Stephan Petzl - 2013-04-25

I have integrated zbar in my Android-app in minutes (great library!),
nevertheless I am thinking of replacing it with another QR code reader now.
The reason is, that there is much scepticism[1][2] on the web whether
LGPL is compatible with commercial Android projects.

Can someone tell me why zbar uses LGPL?
Is there a way to make sure my app meets the license requirements?

[1] http://source.android.com/source/licenses.html
[2] http://www.gnu.org/licenses/lgpl-java.html

Best regards
Stephan