Need beta testers for ZBar iPhone SDK 1.3.1

spadix
2012-10-15
2013-10-10
  • spadix

    spadix - 2012-10-15

    A much needed update for the iOS SDK is ready for beta testing!  This release includes updates for iOS 6 and new devices.

    Please test this distribution in your environment.  We really need feedback from developers with access to an iPad 3 or iPhone 5.

    You can find the disk image on the FRS:
    http://sourceforge.net/projects/zbar/files/iPhoneSDK/beta

    If you do try out this new SDK version, please follow up here with your experience (positive or negative).

    Thank you for your help!
    -spadix

     
  • Mike Milzz

    Mike Milzz - 2012-10-15

    That's awesome. I'll download now and start testing right away on iOS6 with iPhone 4S, iPhone 3GS, iPad2 and iPad3.

     
  • Christian

    Christian - 2012-10-16

    It works perfectly on the simulator, but i'm getting the same error as with the old library when i try testing it on a Device.

     
  • spadix

    spadix - 2012-10-16

    @lorenjaffrey  What error with what device?

    It's working fine for me w/an iPad 2 and claims to include the new architecture…

     
  • Anonymous - 2012-10-16

    This is working great for me on iPad 3 and iPhone 5. (Worth noting: my app has a custom overlay, so I haven't tested the default overlay. If you need someone to try it out I can.)

     
  • Christian

    Christian - 2012-10-17

    ld: file is universal (3 slices) but does not contain a(n) armv7s slice: /Users/rainbird/Desktop/myapp/iFileManager/iFileManager/ZBarSDK/libzbar.a for architecture armv7s
    clang: error: linker command failed with exit code 1 (use -v to see invocation)

    the usual error.

    I tested it on both an iPhone 4S and on an iPad 3, both with the GM Seed.

     
  • spadix

    spadix - 2012-10-17

    Are you sure that you're linking against the 1.3.1 binary distribution?

    My tools indicate that armv7s *is* included in the distribution:

    # hdiutil attach -noautoopen ZBarSDK-1.3.1.dmg
    # lipo -info /Volumes/ZBarSDK/ZBarSDK/libzbar.a
    Architectures in the fat file: /Volumes/ZBarSDK/ZBarSDK/libzbar.a are: armv7 armv7s i386
    

    and I have no problem using this to build applications that include the new architecture.
    Also note that robotspacer already has 1.3.1 running on the iPhone 5…

     
  • Christian

    Christian - 2012-10-17

    Hm, is there anything important to do besides replacing the libzbar.a?
    I only changed this, because ist was the only error.

     
  • Mike Milzz

    Mike Milzz - 2012-10-17

    I removed the whole folder from my project and copied the new 1.3.1 back in. Give that a shot and you should be good. I've tested on 4S, 3GS and new iPad w no issue.

     
  • Sharky1232

    Sharky1232 - 2012-10-25

    i had a problem, with testing "readertest.project" on my iphone 4s (ios 6) at old 1.2 SDK, because of this issue "armv7 armv7s"
    with this project there are some another problem existed. sintax error was occured. i fix it and there it's all become fine

     
  • macKasper

    macKasper - 2012-10-30

    Hi Spadix,

    we've migrated 2 Apps from SDK 1.2 to 1.3.1 - everything works fine !!

    Thanks a lot !!!

    Env:

    - iOS 5.1.1 on iPhone4
    - iOS 6 on iPhone 5

    Incl. resizing our ReaderOverlayViews to the new iPhone5 Screen size !

     
  • Matteo

    Matteo - 2012-10-31

    Hello everybody,
    Just tried the beta with an iPhone 4S and iOS6. Orientation mask doesn't seem to work.

    For example, if you modify in the ReaderSample project the mask:

        reader.supportedOrientationsMask = ZBarOrientationMask(UIInterfaceOrientationPortrait);

    It still rotates to landscape. Am I doing something wrong?

    Thank you!

     
  • Anonymous - 2012-11-14

    A very straightforward upgrade and no problems found.  Devices I am using are ipad2 at ios5 and iphone5 at ios 6.  If I find any issues I will report back.

    Chris

     
  • Saravanarajhan

    Saravanarajhan - 2013-01-15

    Hi,

    I have used ZBar in my project for  iPhone 4 & 4s and it works fine. But when i started using the same in iPhone 5,  am getting linker error. The linker error appears only in iPhone 5 but it works fine in iPad 3.

    file is universal (3 slices) but does not contain a(n) armv7s slice:

    As per the above reference, i downloaded the beta from the link and checked the info using the lipo -info and getting the below message,

    karthiks-MacBook-Pro-2:ZBarSDK administrator$ lipo -info libzbar.a
    Architectures in the fat file: libzbar.a are: armv7 (cputype (12) cpusubtype (11)) i386

    Could somebody help on this.

    Thanks in Advance.

     
  • Ethan

    Ethan - 2013-05-09

    Any way we can get an official release on this? Are there any known bugs?

     
  • howardor

    howardor - 2013-05-10

    I am looking at options for including scanning in a brand new app. Is 1.2 the latest available version, or is 1.3.1 coming. I am inclined to use 1.3.1 Beta, if it's expected to be released at some point soon.

     
  • Matthew Lowe

    Matthew Lowe - 2013-05-20

    Seems solid in our app, but the viewcontroller rotation mask doesn't work anymore. André Mathlener's patch (35) fixes it, so it would be nice to get that into the build.

     
  • LeadSuccess

    LeadSuccess - 2013-10-10

    when will 1.3.1 be out of beta, released?
    Or is beta stable enough to use it productively?

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks