ubuntu 9.04 has bug in libtheora-dev

aapoaapo
2009-09-13
2013-05-28
  • aapoaapo

    aapoaapo - 2009-09-13

    I can configure  0.2.9 but not svn 35.
    Difference is

    -  ($PKG_CONFIG -exists -print-errors "sdl vorbisfile gl theora ftgl") 2>&5

    +  ($PKG_CONFIG -exists -print-errors "sdl vorbisfile gl theoraenc theoradec") 2>&5

    This is bug in ubuntu 9.04

    https://bugs.launchpad.net/ubuntu/+source/libtheora/+bug/347235

    Fixed in 9.10.

    I installed libtheora-dev_1.0-2.1build1_amd64.deb libtheora0_1.0-2.1build1_amd64.deb from Karmic and got it compiled (maybe no other package is broken)

     
  • agapito perez

    agapito perez - 2009-10-10

    Hi. Compiled version 0.3.0 by installing package libtheora-dev from Debian Squeeze repositories. Yes i use Debian Lenny, and that did the trick, since i could not compile it  with package libtheora-dev provided by lenny repositories.
    So if anybody uses Lenny just add :
    deb http://ftp.de.debian.org/debian squeeze main
    to your sources.list, install the package and there you go !
    Oh… Finally ive made a post on my Linux blog about this game. My blog is in portuguese, but thats always more rfree advertising for the author of this game ! Anyaway, once more here goes a big thanks for this game. Cheers !

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks