Problem using JDeveloper

Help
2007-08-29
2013-04-25
  • Ivan Petrovic

    Ivan Petrovic - 2007-08-29

    While deploying war I got an error message during compiling:

    E:\javaprojekti\yawebmailwar\yawebmail\displayMail.jsp
    Error: java.lang.NullPointerException

    I'm using JDeveloper 9.1 with Java 1.3.
    Anyone has a solve?
    Thanks in advance

     
    • Stephan Sann

      Stephan Sann - 2007-08-29

      yawebmail will not compile with Java 1.3 (see http://yawebmail.sourceforge.net/faq.html#system-requirements\).

      If you post Exceptions, please post a stacktrace, too.

       
    • Ivan Petrovic

      Ivan Petrovic - 2007-09-01

      ok, I've moved yawebmail to Jdev10 and it worked fine. But today I got an error messages for each jsp which uses cuic.tld:
      Error(109): Internal error, ClassNotFound creating tag parser for cuic:outputPerFolderLevel, class: null

      Where I have to copy those tld files to make yawebmail to work again.

       
      • Stephan Sann

        Stephan Sann - 2007-09-03

        The best thing would be if you download the "ready-to-run"-WAR-File (yawebmail-1.0.0beta.zip).
        Unzip it and study its content. In this WAR is everything where it belongs.

        Here is how to unJAR the WAR-File:
        http://yawebmail.sourceforge.net/adjustment.html

         
    • Ivan Petrovic

      Ivan Petrovic - 2007-09-04

      I tried to deploy .war under the Tomcat 5.5 and found exception that solved by adding the following line into web.xml:
      <listener>
        <listener-class>org.apache.myfaces.webapp.StartupServletContextListener</listener-class>
      </listener>

      it may be useful for someone.

      I've translated yawebmail into Serbian and will send you a copy.

      Thanks a lot,
      Ivan

       

Log in to post a comment.