ukixantstm - 2010-02-24

Hi,

I have a problem installing the YaSSL lib on Linux.

I run

  ./configure
  make

without any obvious errors. However, when I call

  make install

I get the message: make: Nothing to be done for `install' .

The last lines of output from make where:

g++ -DNO_MAIN_DRIVER -Wall -Wno-unused -g -fno-exceptions -fno-rtti -pthread -o .libs/testsuite testsuite-testsuite.o testsuite-test.o testsuite-client.o testsuite-server.o testsuite-echoclient.o testsuite-echoserver.o  -L/data2/temp/download/yassl-1.9.9/src -L/data2/temp/download/yassl-1.9.9/taocrypt/src -L/usr/lib ../src/.libs/libyassl.so /data2/temp/download/yassl-1.9.9/taocrypt/src/.libs/libtaocrypt.so ../taocrypt/src/.libs/libtaocrypt.so /usr/local/lib/libstdc++.so -lz
creating testsuite
make: Leaving directory `/data2/temp/download/yassl-1.9.9/testsuite'
make: Entering directory `/data2/temp/download/yassl-1.9.9'
make: Nothing to be done for `all-am'.
make: Leaving directory `/data2/temp/download/yassl-1.9.9'

The 'install'-rule in Makefile is:

install:
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:

Versions:
YaSSL 1.9.9
gcc 4.4.2
make 3.8.1

Help would be appreciated.