paravirtualized - 2007-11-21

Dear Developers,
Am not sure if this is the right forum to request for any assistance. Forgive me if its not intended for such helps.

I am trying to compile xway into xen 3.0.3, but I am running into problems. I have followed the steps as given in INSTALL. The patched Xen compiles fine but upon reboot, it shows net/ipv4/xway_proto.c:xsw_accept:143: inet_accept() err=-11.  I am trying this on
AMD Opteron 248, with 2 GHz ram and IWILL motherboard. My distribution is ubuntu 7.04 (64 bit). The GCC version is 4.1.2.  The dmesg is attached below. I may mention that if i ignore the error and try to compile xwaya etc, i get the following warning:

make -C /lib/modules/2.6.16.29-xen/build SUBDIRS=/usr/src/xway-0.6-i386/xwaya modules
make[1]: Entering directory `/usr/src/xen-3.0.3_0-src/linux-2.6.16.29-xen'
  Building modules, stage 2.
  MODPOST
*** Warning: "HYPERVISOR_get_domid" [/usr/src/xway-0.6-i386/xwaya/xwaya.ko] undefined!
make[1]: Leaving directory `/usr/src/xen-3.0.3_0-src/linux-2.6.16.29-xen'

==================== dmesg output =============================
Bootdata ok (command line is root=/dev/mapper/volume_1-host_disk ro console=tty0)
Linux version 2.6.16.29-xen (root@vorpalblade3) (gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)) #1 SMP Wed Nov 21 14:20:34 EST 2007
BIOS-provided physical RAM map:
Xen: 0000000000000000 - 00000000ee8d6000 (usable)
On node 0 totalpages: 977110
  DMA zone: 977110 pages, LIFO batch:31
  DMA32 zone: 0 pages, LIFO batch:0
  Normal zone: 0 pages, LIFO batch:0
  HighMem zone: 0 pages, LIFO batch:0
ACPI: RSDP (v002 ACPIAM                                ) @ 0x00000000000f6f50
ACPI: XSDT (v001 A M I  OEMXSDT  0x07000519 MSFT 0x00000097) @ 0x00000000f9ff0100
ACPI: FADT (v003 A M I  OEMFACP  0x07000519 MSFT 0x00000097) @ 0x00000000f9ff0290
ACPI: MADT (v001 A M I  OEMAPIC  0x07000519 MSFT 0x00000097) @ 0x00000000f9ff0390
ACPI: OEMB (v001 A M I  OEMBIOS  0x07000519 MSFT 0x00000097) @ 0x00000000f9ffe040
ACPI: SRAT (v001 A M I  OEMSRAT  0x07000519 MSFT 0x00000097) @ 0x00000000f9ff36a0
ACPI: DSDT (v001  PATHV PATHV180 0x00000000 INTL 0x02002026) @ 0x0000000000000000
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
ACPI: LAPIC (acpi_id[0x02] lapic_id[0x01] enabled)
ACPI: LAPIC (acpi_id[0x03] lapic_id[0x82] disabled)
ACPI: LAPIC (acpi_id[0x04] lapic_id[0x83] disabled)
ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 2, version 17, address 0xfec00000, GSI 0-23
ACPI: IOAPIC (id[0x03] address[0xfe6fe000] gsi_base[24])
IOAPIC[1]: apic_id 3, version 17, address 0xfe6fe000, GSI 24-27
ACPI: IOAPIC (id[0x04] address[0xfe6ff000] gsi_base[28])
IOAPIC[2]: apic_id 4, version 17, address 0xfe6ff000, GSI 28-31
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
Setting APIC routing to xen
Using ACPI (MADT) for SMP configuration information
Allocating PCI resources starting at fa800000 (gap: fa000000:4c00000)
Built 1 zonelists
Kernel command line: root=/dev/mapper/volume_1-host_disk ro console=tty0
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 131072 bytes)
Xen reported: 2405.544 MHz processor.
Console: colour VGA+ 80x25
Dentry cache hash table entries: 524288 (order: 10, 4194304 bytes)
Inode-cache hash table entries: 262144 (order: 9, 2097152 bytes)
Software IO TLB enabled:
Aperture:     64 megabytes
Kernel range: 0xffff88000607e000 - 0xffff88000a07e000
PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
Memory: 3736832k/3908440k available (1906k kernel code, 162756k reserved, 809k data, 164k init)
Calibrating delay using timer specific routine.. 4812.49 BogoMIPS (lpj=24062499)
Security Framework v1.0.0 initialized
Capability LSM initialized
Mount-cache hash table entries: 256
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 1024K (64 bytes/line)
Brought up 2 CPUs
Initializing CPU#1
migration_cost=752
checking if image is initramfs... it is
Freeing initrd memory: 17279k freed
DMI 2.3 present.
Grant table initialized
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: Using configuration type 1
ACPI: Subsystem revision 20060127
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
Boot video device is 0000:01:06.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCI1._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.GOLA._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.GOLB._PRT]
ACPI: PCI Root Bridge [PCIB] (0000:04)
PCI: Probing PCI hardware (bus 04)
ACPI: PCI Interrupt Routing Table [\_SB_.PCIB._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 *5 6 7 9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 *9 10 11 12 14 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: ACPI device : hid PNP0A03
pnp: ACPI device : hid PNP0200
pnp: ACPI device : hid PNP0B00
pnp: ACPI device : hid PNP0303
pnp: ACPI device : hid PNP0800
pnp: ACPI device : hid PNP0C04
pnp: ACPI device : hid PNP0501
pnp: ACPI device : hid PNP0501
pnp: ACPI device : hid PNP0700
pnp: ACPI device : hid PNP0C02
pnp: ACPI device : hid PNP0C02
pnp: ACPI device : hid PNP0C02
pnp: ACPI device : hid PNP0C01
pnp: ACPI device : hid PNP0A03
pnp: PnP ACPI: found 14 devices
xen_mem: Initialising balloon driver.
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
pnp: the driver 'system' has been registered
pnp: match found with the PnP device '00:09' and the driver 'system'
pnp: 00:09: ioport range 0xa00-0xa0f has been reserved
pnp: match found with the PnP device '00:0a' and the driver 'system'
pnp: match found with the PnP device '00:0b' and the driver 'system'
pnp: 00:0b: ioport range 0xca2-0xca3 has been reserved
pnp: match found with the PnP device '00:0c' and the driver 'system'
PCI: Bridge: 0000:00:01.0
  IO window: c000-cfff
  MEM window: fe300000-fe5fffff
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:02.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:06.0
  IO window: 9000-bfff
  MEM window: fc100000-fe2fffff
  PREFETCH window: disabled.
IA-32 Microcode Update Driver: v1.14-xen <tigran@veritas.com>
IA32 emulation $Id: sys_ia32.c,v 1.32 2002/03/24 13:02:28 ak Exp $
audit: initializing netlink socket (disabled)
audit(1195620665.970:1): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
PCI: MSI quirk detected. pci_msi_quirk set.
PCI: MSI quirk detected. pci_msi_quirk set.
Real Time Clock Driver v1.12ac
Non-volatile memory driver v1.2
pnp: the driver 'i8042 kbd' has been registered
pnp: match found with the PnP device '00:03' and the driver 'i8042 kbd'
pnp: the driver 'i8042 aux' has been registered
PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
PNP: PS/2 controller doesn't have AUX irq; using default 12
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
loop: loaded (max 8 devices)
Xen virtual console successfully installed as ttyS0
Event-channel device installed.
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
pnp: the driver 'ide' has been registered
mice: PS/2 mouse device common for all mice
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
NET: Registered protocol family 2
IP route cache hash table entries: 131072 (order: 8, 1048576 bytes)
TCP established hash table entries: 262144 (order: 10, 4194304 bytes)
TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
TCP: Hash tables configured (established 262144 bind 65536)
TCP reno registered
NET: Registered protocol family 1
NET: Registered protocol family 17
input: AT Translated Set 2 keyboard as /class/input/input0
device-mapper: 4.5.0-ioctl (2005-10-04) initialised: dm-devel@redhat.com
ACPI: Processor [CPU1] (supports 8 throttling states)
Intel(R) PRO/1000 Network Driver - version 6.3.9-k4-NAPI
Copyright (c) 1999-2005 Intel Corporation.
GSI 16 sharing vector 0xA0 and IRQ 16
ACPI: PCI Interrupt 0000:03:03.0[A] -> GSI 27 (level, low) -> IRQ 16
usbcore: registered new driver usbfs
usbcore: registered new driver hub
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
SCSI subsystem initialized
e1000: 0000:03:03.0: e1000_probe: (PCI:66MHz:32-bit) 00:d0:68:09:18:da
libata version 1.20 loaded.
FDC 0 is a post-1991 82077
e1000: eth0: e1000_probe: Intel(R) PRO/1000 Network Connection
GSI 17 sharing vector 0xA8 and IRQ 17
ACPI: PCI Interrupt 0000:03:04.0[A] -> GSI 24 (level, low) -> IRQ 17
e1000: 0000:03:04.0: e1000_probe: (PCI:66MHz:32-bit) 00:d0:68:09:18:db
e1000: eth1: e1000_probe: Intel(R) PRO/1000 Network Connection
GSI 18 sharing vector 0xB0 and IRQ 18
ACPI: PCI Interrupt 0000:01:05.0[A] -> GSI 17 (level, low) -> IRQ 18
e1000: 0000:01:05.0: e1000_probe: (PCI:33MHz:32-bit) 00:0e:0c:aa:db:89
e1000: eth2: e1000_probe: Intel(R) PRO/1000 Network Connection
GSI 19 sharing vector 0xB8 and IRQ 19
ACPI: PCI Interrupt 0000:01:00.0[D] -> GSI 19 (level, low) -> IRQ 19
ohci_hcd 0000:01:00.0: OHCI Host Controller
ohci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 1
ohci_hcd 0000:01:00.0: irq 19, io mem 0xfe1fd000
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 3 ports detected
ACPI: PCI Interrupt 0000:01:00.1[D] -> GSI 19 (level, low) -> IRQ 19
ohci_hcd 0000:01:00.1: OHCI Host Controller
ohci_hcd 0000:01:00.1: new USB bus registered, assigned bus number 2
ohci_hcd 0000:01:00.1: irq 19, io mem 0xfe1fe000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
sata_sil 0000:03:05.0: version 0.9
GSI 20 sharing vector 0xC0 and IRQ 20
ACPI: PCI Interrupt 0000:03:05.0[A] -> GSI 25 (level, low) -> IRQ 20
sata_sil 0000:03:05.0: Applying R_ERR on DMA activate FIS errata fix
ata1: SATA max UDMA/100 cmd 0xFFFFC2000000EC80 ctl 0xFFFFC2000000EC8A bmdma 0xFFFFC2000000EC00 irq 20
ata2: SATA max UDMA/100 cmd 0xFFFFC2000000ECC0 ctl 0xFFFFC2000000ECCA bmdma 0xFFFFC2000000EC08 irq 20
ata3: SATA max UDMA/100 cmd 0xFFFFC2000000EE80 ctl 0xFFFFC2000000EE8A bmdma 0xFFFFC2000000EE00 irq 20
ata4: SATA max UDMA/100 cmd 0xFFFFC2000000EEC0 ctl 0xFFFFC2000000EECA bmdma 0xFFFFC2000000EE08 irq 20
ata1: SATA link down (SStatus 0)
scsi0 : sata_sil
ata2: SATA link up 1.5 Gbps (SStatus 113)
ata2: dev 0 cfg 49:2f00 82:7c6b 83:7f09 84:4773 85:7c69 86:3e01 87:4763 88:207f
ata2: dev 0 ATA-7, max UDMA/133, 398297088 sectors: LBA48
ata2: dev 0 configured for UDMA/100
scsi1 : sata_sil
ata3: SATA link down (SStatus 0)
scsi2 : sata_sil
ata4: SATA link down (SStatus 0)
scsi3 : sata_sil
  Vendor: ATA       Model: Maxtor 6V200E0    Rev: VA11
  Type:   Direct-Access                      ANSI SCSI revision: 05
AMD8111: IDE controller at PCI slot 0000:00:07.1
AMD8111: chipset revision 3
AMD8111: not 100% native mode: will probe irqs later
AMD8111: 0000:00:07.1 (rev 03) UDMA133 controller
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:pio, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:pio
Probing IDE interface ide0...
SCSI device sda: 398297088 512-byte hdwr sectors (203928 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
SCSI device sda: 398297088 512-byte hdwr sectors (203928 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
sda: sda1 sda2
sd 1:0:0:0: Attached scsi disk sda
sd 1:0:0:0: Attached scsi generic sg0 type 0
SGI XFS with ACLs, security attributes, realtime, large block/inode numbers, no debug enabled
SGI XFS Quota Management subsystem
XFS mounting filesystem dm-1
Ending clean XFS mount for filesystem: dm-1
Probing IDE interface ide1...
hdc: SONY DVD-ROM DDU1615, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
e1000: eth0: e1000_watchdog_task: NIC Link is Up 1000 Mbps Full Duplex
e1000: eth2: e1000_watchdog_task: NIC Link is Up 1000 Mbps Full Duplex
e1000: eth1: e1000_watchdog_task: NIC Link is Up 1000 Mbps Full Duplex
hdc: ATAPI 40X DVD-ROM drive, 254kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
input: PC Speaker as /class/input/input1
hw_random: AMD768 system management I/O registers at 0x5000.
hw_random hardware driver 1.0.0 loaded
pnp: the driver 'parport_pc' has been registered
lp: driver loaded but no devices found
ieee1394: Initialized config rom entry `ip1394'
ieee1394: sbp2: Driver forced to serialize I/O (serialize_io=1)
ieee1394: sbp2: Try serialize_io=0 for better performance
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
Adding 1023992k swap on /dev/mapper/volume_1-host_swap.  Priority:-1 extents:1 across:1023992k
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver
net/ipv4/xway_proto.c:xsw_accept:143: inet_accept() err=-11
Bridge firewalling registered
device vif0.0 entered promiscuous mode
xenbr0: port 1(vif0.0) entering learning state
ADDRCONF(NETDEV_UP): peth0: link is not ready
xenbr0: topology change detected, propagating
xenbr0: port 1(vif0.0) entering forwarding state
e1000: peth0: e1000_watchdog_task: NIC Link is Up 1000 Mbps Full Duplex
ADDRCONF(NETDEV_CHANGE): peth0: link becomes ready
device peth0 entered promiscuous mode
xenbr0: port 2(peth0) entering learning state
xenbr0: topology change detected, propagating
xenbr0: port 2(peth0) entering forwarding state
eth2: no IPv6 routers present
eth1: no IPv6 routers present
eth0: no IPv6 routers present