jpeg/lame not found

Help
2005-02-18
2013-04-24
  • Nobody/Anonymous

    I do have lame installed on the system:
    # ls -la /usr/local/lib |grep lame
    -rw-r--r--   1 root root   387826 2005-02-17 18:00 libmp3lame.a
    -rwxr-xr-x   1 root root      804 2005-02-17 18:00 libmp3lame.la*
    lrwxr-xr-x   1 root root       19 2005-02-17 18:00 libmp3lame.so -> libmp3lame.so.0.0.0*
    lrwxr-xr-x   1 root root       19 2005-02-17 18:00 libmp3lame.so.0 -> libmp3lame.so.0.0.0*
    -rwxr-xr-x   1 root root   353508 2005-02-17 18:00 libmp3lame.so.0.0.0*

    and also jpeg lib:
    # ls -la /usr/lib |grep libjpeg
    -rw-r--r--    1 root root   150580 2003-02-14 00:20 libjpeg.a
    lrwxr-xr-x    1 root root       13 2005-02-18 18:08 libjpeg.so -> libjpeg.so.62*
    lrwxr-xr-x    1 root root       17 2005-02-18 18:08 libjpeg.so.62 -> libjpeg.so.62.0.0*
    -rwxr-xr-x    1 root root   114152 2003-02-14 00:20 libjpeg.so.62.0.0*

    Here is the output from the configure:
    $ ./configure --with-gtk2
    checking for a BSD-compatible install... /usr/bin/ginstall -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ANSI C... none needed
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc3
    checking whether make sets $(MAKE)... (cached) yes
    checking for ranlib... ranlib
    checking how to run the C preprocessor... gcc -E
    checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
    checking for gethostbyname... yes
    checking for connect... yes
    checking for remove... yes
    checking for shmat... yes
    checking for IceConnectionNumber in -lICE... yes
    checking for zlibVersion in -lz... yes
    checking for png_set_filter in -lpng... yes
    checking for jpeg_CreateCompress in -ljpeg... no
    To use jpeg you need libjpeg version 6+
    checking for lame_init in -lmp3lame... no
    To use mp3 audio codecs you need liblame/liblame-dev
    checking for img_convert in -lavcodec... yes
    checking for avienc_init in -lavformat... yes
    checking for audio_init in -lavformat... (cached) no
    Checking for GTK2 version ... 2.6.1
    checking for pthread_mutex_init in -lpthread... yes
    checking for egrep... grep -E
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking fcntl.h usability... yes
    checking fcntl.h presence... yes
    checking for fcntl.h... yes
    checking limits.h usability... yes
    checking limits.h presence... yes
    checking for limits.h... yes
    checking for stdlib.h... (cached) yes
    checking for string.h... (cached) yes
    checking sys/ioctl.h usability... yes
    checking sys/ioctl.h presence... yes
    checking for sys/ioctl.h... yes
    checking sys/time.h usability... yes
    checking sys/time.h presence... yes
    checking for sys/time.h... yes
    checking for unistd.h... (cached) yes
    checking zlib.h usability... yes
    checking zlib.h presence... yes
    checking for zlib.h... yes
    checking sys/soundcard.h usability... yes
    checking sys/soundcard.h presence... yes
    checking for sys/soundcard.h... yes
    checking for stdint.h... (cached) yes
    checking ctype.h usability... yes
    checking ctype.h presence... yes
    checking for ctype.h... yes
    checking for an ANSI C-conforming const... yes
    checking whether time.h and sys/time.h may both be included... yes
    checking whether gcc needs -traditional... no
    checking for stdlib.h... (cached) yes
    checking for GNU libc compatible malloc... yes
    checking for stdlib.h... (cached) yes
    checking for unistd.h... (cached) yes
    checking for getpagesize... yes
    checking for working mmap... yes
    checking for stdlib.h... (cached) yes
    checking for GNU libc compatible realloc... yes
    checking for fdatasync... yes
    checking for gettimeofday... yes
    checking for memmove... yes
    checking for memset... yes
    checking for munmap... yes
    checking for strcasecmp... yes
    checking for strchr... yes
    checking for strdup... yes
    checking for strstr... yes
    checking for getopt_long... yes
    configure: creating ./config.status
    config.status: creating Makefile
    config.status: creating src/Makefile
    config.status: creating gt/Makefile
    config.status: creating Xw/Makefile
    config.status: creating config.h
    config.status: config.h is unchanged
    config.status: executing depfiles commands

    Since liblame isn't found compiling returns errors:
    if gcc -DHAVE_CONFIG_H -I. -I. -I..    -I/usr/X11R6/include -DVERSION=\"1.1.4\"   `pkg-config --cflags gtk+-2.0`   -g -O2 -MT gvidcap-codecs.o -MD -MP -MF ".deps/gvidcap-codecs.Tpo" \   -c -o gvidcap-codecs.o `test -f 'codecs.c' || echo './'`codecs.c; \ then mv -f ".deps/gvidcap-codecs.Tpo" ".deps/gvidcap-codecs.Po"; \ else rm -f ".deps/gvidcap-codecs.Tpo"; exit 1; \ fi
    codecs.c:161: error: `AU_CODEC_MP2' undeclared here (not in a function)
    codecs.c:161: error: initializer element is not constant
    codecs.c:161: error: (near initialization for `mp2.id')
    codecs.c:177: error: `AU_CODEC_PCM16' undeclared here (not in a function)
    codecs.c:177: error: initializer element is not constant
    codecs.c:177: error: (near initialization for `pcm16.id')
    codecs.c:300: error: `AU_CODEC_MP2' undeclared here (not in a function)
    codecs.c:300: error: initializer element is not constant
    codecs.c:300: error: (near initialization for `avi.def_au_codec')
    codecs.c:316: error: `AU_CODEC_MP2' undeclared here (not in a function)
    codecs.c:316: error: initializer element is not constant
    codecs.c:316: error: (near initialization for `divx.def_au_codec')
    codecs.c:362: error: `AU_CODEC_MP3' undeclared here (not in a function)
    codecs.c:362: error: initializer element is not constant
    codecs.c:362: error: (near initialization for `swf.def_au_codec')
    codecs.c:379: error: `AU_CODEC_MP2' undeclared here (not in a function)
    codecs.c:379: error: initializer element is not constant
    codecs.c:379: error: (near initialization for `dv_format.def_au_codec')
    codecs.c:383: error: `ff_dv_init' undeclared here (not in a function)
    codecs.c:383: error: initializer element is not constant
    codecs.c:383: error: (near initialization for `dv_format.init')
    codecs.c:392: error: `AU_CODEC_MP2' undeclared here (not in a function)
    codecs.c:392: error: initializer element is not constant
    codecs.c:392: error: (near initialization for `mpeg.def_au_codec')
    codecs.c:405: error: `AU_CODEC_MP2' undeclared here (not in a function)
    codecs.c:405: error: initializer element is not constant
    codecs.c:405: error: (near initialization for `svcd.def_au_codec')
    codecs.c:418: error: `AU_CODEC_MP2' undeclared here (not in a function)
    codecs.c:418: error: initializer element is not constant
    codecs.c:418: error: (near initialization for `mov.def_au_codec')
    make[1]: *** [gvidcap-codecs.o] Error 1
    make[1]: Leaving directory `/root/xvidcap-1.1.4pre2/src'
    make: *** [gvidcap] Error 1

     
    • Nobody/Anonymous

      checking for jpeg_CreateCompress in -ljpeg... no
      To use jpeg you need libjpeg version 6+
      checking for lame_init in -lmp3lame... no
      To use mp3 audio codecs you need liblame/liblame-dev

      I found these can be fixed because these libs need -lm:
      export LDFLAGS="-lm"

      that should fix that problem, however the codecs.o still complains

       
      • Karl H. Beckers

        Karl H. Beckers - 2005-02-19

        Please DO read the release notes and use

        ./configure --with-gtk2 --with-forced-embedded-ffmpeg

        Karl.

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks