Error when compiling xvidcap 1.1.4

Help
Jer
2005-03-15
2013-04-24
  • Jer

    Jer - 2005-03-15

    I am running SLES 9 and and also the Novell Linux Desktop. I have tried both Gnome and KDE and get the same results.  The "./configure --with-gtk2 --with-forced-embedded-ffmpeg" command executes without any errors. However when running  "make gvidcap" I get the error:

    main.c: In function `main':
    main.c:550: error: `CAP_AVI' undeclared (first use in this function)
    make[1]: *** [gvidcap-main.o] Error 1
    make[1]: Leaving directory

    Do you have any suggestions on how to get around this?

     
    • Karl H. Beckers

      Karl H. Beckers - 2005-03-15

      Hi,

      please note that the configure script is not as smart as it should. It might not bail out and still not yield a result that will allow you to build correctly. This is one of the things that need to be fixed for release time.
      For now, you have to watch configure output closely -- esp. around checks for av*

      You might want to do
      ./configure --with-gtk2 --with-forced-embedded-ffmpeg 2>&1 >myconfig.log

      and send the file myconfig.log to me in a separate email.
      Will check it and reply through the forum (for archival) ... and I might create a FAQ entry as well ;)

      Cheers,

      Karl.

       
    • Jer

      Jer - 2005-03-16

      Hi Karl,

      I just wanted to let you know that the myconfig.log has be sent to you.

      Cheers,

      Jeremy

       
    • Karl H. Beckers

      Karl H. Beckers - 2005-03-17

      Jeremy,

      right after configure builds libavcodec you have:

      make[1]: Leaving directory `/root/xvidcap-1.1.4pre2/xvidcap-1.1.4pre2/ffmpeg/libavcodec'
      checking for img_convert in -lavcodec... (static?) ... no
      checking for img_convert in -lavcodec... no
      checking for avienc_init in -lavformat... no

      This basically means you don't have a usable libavcodec ... therefore on-the-fly encoding support is not built in.

      Why is that so?

      Further up, you have:

      checking for zlibVersion in -lz... no
      checking for png_set_filter in -lpng... no
      checking for jpeg_CreateCompress in -ljpeg... yes
      checking for lame_init in -lmp3lame... no
      To use mp3 audio codecs you need liblame/liblame-dev

      Please try installing the following libraries and their respective devel packages: libz, libpng3, libmp3lame.
      then extract the source tarball again to a fresh directory, configure and build again.

      Cheers,

      Karl.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks