Error, when opening F1-Help

Help
2007-08-27
2013-04-24
  • Nobody/Anonymous

    I compiled and installed by myself on a Kubuntu 6.06 machine (the deb-file didn't work)
    Now when I try to view the help by CTRL+H or F1 the helpbrowser opens with this error:

    Could not load document: The Uniform Resource Identifier ‘ghelp:xvidcap’ is invalid or does not point to an actual file.

    ???

     
    • Karl H. Beckers

      Karl H. Beckers - 2007-08-27

      Well, since you're on KDE but apparently have yelp I suppose you're missing scrollkeeper.
      Scrollkeeper keeps an index of registered documents and hence ghelp:xvidcap works. If you don't register xvidcap with scrollkeeper, yelp will not be able to find it by that name but you could try yelp ghelp:file:///<path-to-xvidcap-doc>.xml ... That won't work with F1, though.

      Karl.

       
    • Nobody/Anonymous

      Thank you for answering.

      I have yelp and also scrollkeeper installed.

      In other applications i.e. gnucash the help-system with yelp works.

      I added /usr/local/share/omf to scrollkeeper.conf, but it didn't work.

      yelp /usr/share/doc/xvidcap/doc/xvidcap/de/xvidcap.xml works but is not very satisfying.

       
    • Karl H. Beckers

      Karl H. Beckers - 2007-08-28

      Ah wait, I forgot smth.
      because the scrollkeeper update requires root permission and also interferes with package building, I have extracted that stuff to a separate target. Try "make install-doc" after "make install".
      HTH,
      Karl.

       

Log in to post a comment.