xvidcap go down

Help
2007-12-29
2013-04-24
  • Nobody/Anonymous

    Soory for my bad english, i'm from Russia.

    I have problem. When i push on red (record) button, program go down. All that i can do it is Control+C. And output file has lenght 1 sec.((

    Please tell me, whats wrong?

    OS:GNU/Linux openSuse 10.3
    Xvidcap: 1.1.6

     
    • Nobody/Anonymous

      This is prolly the new "minimize to tray" feature. Look at the system notification tray for an led meter icon that displays capture rate and right-click there, or disable the feature in the general options.

       
    • Nobody/Anonymous

      Hi, I also use xvidcap 1.1.6. But when I start the record Button there is a black tray-icon. When I make a right-click xvidcap crushes and is gone!

      Greets
      Mike

       
      • Nobody/Anonymous

        more info needed here:
        what distro/version, how did you install xvidcap, which parameters.
        Have you tried 1.1.7rc1?

         
    • Nobody/Anonymous

      Distri: SIDUX-Debian (daily upgraded) and I installed it with the package-installer "Synaptic"
      My xvidcap version is 1.1.6-0.1. I haven't seen 1.1.7rcl on my package installer and I can't manually install any programes...

      Greets
      Mike

       
      • Nobody/Anonymous

        I have no idea who built that package and how. Could you find out who the package maintainer is from synaptic and get in contact with him?

         
    • Nobody/Anonymous

      OK!
      Synaptic is an apt based package-installer. http://www.nongnu.org/synaptic

      It reads my sources.list an makes installs like "apt-get-install"

      That's it...

      Greetings
      Mike

       
      • Karl H. Beckers

        Karl H. Beckers - 2008-03-17

        Hrmpf,
        been using distros based on Debian since 2000 and know synaptic quite well.
        What I meant was: Last time I checked, there was no official deb for ubuntu or Debian as such.
        Certainly, I have NOT created any package for Debian, only ever for the ubuntu version I chance to use at a given point in time.

        So, if you install a deb through synaptic, somebody else has compiled that, and I have no idea what he or she did. There are a few options to chose from when building. Therefore, you should try to get in contact with your package maintainer and he will contact me if he thinks that's not a packaging bug but an upstream bug.

        You should be able to find the package maintainer by running "dpkg -s xvidcap".

        HTH,

        Karl.

         
    • Nobody/Anonymous

      OK!
      Thank you! I will mail the maintainer...
      HTH
      Mike

      Package: xvidcap
      Status: install ok installed
      Priority: optional
      Section: x11
      Installed-Size: 2736
      Maintainer: Christian Marillat <marillat@debian.org>
      Bugs: mailto:marillat@debian.org
      Architecture: i386
      Version: 1.1.6-0.1
      Depends: libatk1.0-0 (>= 1.13.2), libavcodeccvs51 (>= 3:20070528), libavformatcvs51 (>= 3:20070528), libavutilcvs49 (>= 3:20070528), libc6 (>= 2.5-5), libcairo2 (>= 1.4.0), libdbus-1-3 (>= 0.94), libdbus-glib-1-2 (>= 0.73), libfontconfig1 (>= 2.4.0), libglade2-0 (>= 1:2.5.1), libglib2.0-0 (>= 2.12.9), libgtk2.0-0 (>= 2.10.3), liblame0 (>= 3.97), libpango1.0-0 (>= 1.16.4), libswscalecvs0 (>= 3:20070528), libx11-6, libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3 (>= 1:4.0.1), libxi6, libxinerama1, libxml2 (>= 2.6.28), libxmu6, libxrandr2 (>= 2:1.2.0), libxrender1
      Description: Screen video capture for X
      A screen capture enabling you to capture videos off your X-Window desktop
      for illustration or documentation purposes. It is intended to be a
      standards-based alternative to tools like Lotus ScreenCam.
      .
      Video can be saved in MPEG or AVI files format.

       
    • Nobody/Anonymous

      I found the Problem!

      If you disable the audio-recording funktion, then XVIDCAP will work well!
      But I want to have the audio funktion enabled...

      HTH
      Mike

       
    • Nobody/Anonymous

      This is why it crashed when Audio is enabled to /dev/dsp:

      The program 'xvidcap' received an X Window System error.
      This probably reflects a bug in the program.
      The error was 'BadMatch (invalid parameter attributes)'.
        (Details: serial 2473068 error_code 8 request_code 161 minor_code 1)
        (Note to programmers: normally, X errors are reported asynchronously;
         that is, you will receive the error a while after causing it.
         To debug your program, run it with the --sync command line
         option to change this behavior. You can then get a meaningful
         backtrace from your debugger if you break on the gdk_x_error() function.)

      HTH
      Mike

       
    • Nobody/Anonymous

      HI I used xvidcap in gutsy gibbon with few problems but will not work in hardy heron!

      when I click to record anything (xvidcap) programe just shuts down!

      need better codecs though

      I installed new version from repositorys

      Jpd

       
      • Nobody/Anonymous

        From what repositories? AFAIK xvidcap is not in the ubuntu repos, is it?
        Also, try to start xvidcap from a terminal and see what error message shows up.

         
    • Nobody/Anonymous

      jpd@jpd-desktop:~$ xvidcap
      MPlayer 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team
      CPU: Intel(R) Pentium(R) D CPU 3.00GHz (Family: 15, Model: 6, Stepping: 2)
      CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
      Compiled with runtime CPU detection.
      mplayer: could not connect to socket
      mplayer: No such file or directory
      Failed to open LIRC support. You will not be able to use your remote control.

      Playing test-0000.mpeg.
      AVI file format detected.
      [aviheader] Video stream found, -vid 0
      [aviheader] Audio stream found, -aid 1
      VIDEO:  [FMP4]  1220x786  24bpp  10.000 fps  118.2 kbps (14.4 kbyte/s)
      Clip info:
      Software: Lavf51.12.1
      xscreensaver_disable: Could not find XScreenSaver window.
      GNOME screensaver disabled
      ==========================================================================
      Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
      Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
      ==========================================================================
      ==========================================================================
      Forced audio codec: mad
      Opening audio decoder: [libmad] libmad mpeg audio decoder
      AUDIO: 44100 Hz, 2 ch, s16le, 64.0 kbit/4.54% (ratio: 8000->176400)
      Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)
      ==========================================================================
      AO: [pulse] 44100Hz 2ch s16le (2 bytes per sample)
      Starting playback...
      VDec: vo config request - 1220 x 786 (preferred colorspace: Planar YV12)
      VDec: using Planar YV12 as output csp (no 0)
      Movie-Aspect is 1.55:1 - prescaling to correct movie aspect.
      VO: [xv] 1220x786 => 1220x786 Planar YV12
      No bind found for key 'MOUSE_BTN2'.                         0% 0 0
      Cannot sync MAD frame:  0.001 ct:  0.054 320/320  4%  0%  1.0% 0 0
      Cannot sync MAD frame
      Cannot sync MAD frame:  0.005 ct:  0.053 321/321  4%  0%  1.0% 0 0
      Cannot sync MAD frame: -0.001 ct:  0.053 322/322  4%  0%  1.0% 0 0
      Cannot sync MAD frame:  0.002 ct:  0.053 323/323  4%  0%  1.0% 0 0
      Cannot sync MAD frame: -0.003 ct:  0.053 324/324  4%  0%  1.0% 0 0
      Cannot sync MAD frame: -0.008 ct:  0.052 325/325  4%  0%  1.0% 0 0
      Cannot sync MAD frame: -0.108 ct:  0.042 326/326  4%  0%  1.0% 0 0
      Cannot sync MAD frame: -0.208 ct:  0.032 327/327  4%  0%  1.0% 0 0
      Cannot sync MAD frame: -0.308 ct:  0.022 328/328  4%  0%  1.0% 0 0
      Cannot sync MAD frame: -0.408 ct:  0.012 329/329  4%  0%  1.0% 0 0
      Cannot sync MAD frame: -0.508 ct:  0.002 330/330  4%  0%  1.0% 0 0
      A:  32.4 V:  32.9 A-V: -0.508 ct: -0.008 330/330  4%  0%  1.0% 0 0
      GNOME screensaver enabled

      Exiting... (End of file)

       
    • Nobody/Anonymous

      Xvidcap is in ubuntu 8.03 repos (sudo aptitude xvidcap):

      "
      Version 1.1.6-0.1ubuntu1:

        * Merge from debian-multimedia (LP: #120003), Ubuntu Changes:
         - For ffmpeg-related build-deps, remove cvs from package names.
         - Standards-Version 3.7.3
         - Maintainer Spec
      "
      Sadly it does not work. Program freezes.
      I downloaded the 1.1.7rc1.deb and... wow...it works!

      I have noticed that the 1.1.7rc1 installs Imagemagic-package, the ubuntu-repos-version does not.
      Funny thing is: Update claims that the ubuntu-version is the new one! (And wants to update :-()

      bw
      Bernd

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks