xvidcap and libXmu issue in suse 10.0

Help
2006-07-16
2013-04-24
  • Nobody/Anonymous

    Hello!

    I try to compile xvidcap 1.1.4pre3 in suse 10.0 but no success so far. I end up to the following message:

    checking for dgettext in libc... yes
    checking for bind_textdomain_codeset... yes
    checking for msgfmt... /usr/bin/msgfmt
    checking for dcgettext... yes
    checking for gmsgfmt... /usr/bin/msgfmt
    checking for xgettext... no
    checking for catalogs to be installed...  de
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for PACKAGE... yes
    checking for XmuClientWindow in -lXmu... no
    libXmu required for drawing the frame around the area to capture

    Thats weird because i have that libXmu in my system. And /usr/X11R6/lib is in my ld.so.conf

    @linux:~> locate libXmu
    /usr/X11R6/lib/libXmu.a
    /usr/X11R6/lib/libXmu.so
    /usr/X11R6/lib/libXmu.so.6
    /usr/X11R6/lib/libXmu.so.6.2
    /usr/X11R6/lib/libXmuu.a
    /usr/X11R6/lib/libXmuu.so
    /usr/X11R6/lib/libXmuu.so.1
    /usr/X11R6/lib/libXmuu.so.1.0

     
    • Nobody/Anonymous

      OK. I find that it is a bug, it was discussed on the earlier topic below. I get it to compile with the following line:

      LDFLAGS="-L/usr/X11R6/lib" ./configure --with-forced-embedded-ffmpeg --with-gtk2

       
    • Karl H. Beckers

      Karl H. Beckers - 2006-07-17

      hi,
      it would be helpfule if you could verified that the configure script attached to bug # 1523447 works for you (after a make distclean, of course).

      Thanks,

      Karl.

       
    • Nobody/Anonymous

      Yes, the configure script attached to bug# 1523447 did the trick and it did find libXmu. But now there is a new issue with libm.

      Configure with original configure script:

      @linux:~> ./configure --with-forced-embedded-ffmpeg --with-gtk2

      .
      .
      .
      checking for pkg-config... /usr/bin/pkg-config
      checking pkg-config is at least version 0.9.0... yes
      checking for PACKAGE... yes
      checking for XmuClientWindow in -lXmu... no
      libXmu required for drawing the frame around the area to capture

      And.. Configure with the new (attached to bug # 1523447) one:

      @linux:~> ./configure --with-forced-embedded-ffmpeg --with-gtk2

      .
      .
      .
      checking for pkg-config... /usr/bin/pkg-config
      checking pkg-config is at least version 0.9.0... yes
      checking for PACKAGE... yes
      checking for XmuClientWindow in -lXmu... yes
      checking for pow in -lm... no
      libm required by ffmpeg

       
    • Nobody/Anonymous

      Hmm,
      can you send your config.log to my sf address?

      Thanks,

      Karl.

       

Log in to post a comment.