Audio Microphone Issue worse problem

  • Nobody/Anonymous

    well i have read whole documentation really..but still no luck
    situation my microphone works nice with audacity and rec but with xvidcap no.

    kmix set, with boosted microphone

    if i use

    rec temp.wav

    i got nice volume really nice.

    if i use  rec -d /dev/dsp temp.wav

    i got  rec soxio: Failed reading `/dev/dsp': unknown file type

    if i use audacity i got nice very nice volume and my kmix boost

    i have tried to set up xvid cap


    where xxx is :


    without no luck...

    if i check what programs are using with :

    lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

    when i record with "rec" ,sox subprogram, or audacity i get

    artsd    6388 user  mem    CHR 116,16      12057 /dev/snd/pcmC0D0p
    artsd    6388 user    9r   CHR 116,33      11642 /dev/snd/timer
    artsd    6388 user   10u   CHR 116,16      12057 /dev/snd/pcmC0D0p
    artsd    6388 user   12u   CHR  116,0      12099 /dev/snd/controlC0
    rec     12639 user  mem    CHR 116,24      12064 /dev/snd/pcmC0D0c
    rec     12639 user    3r   CHR 116,33      11642 /dev/snd/timer
    rec     12639 user    4u   CHR 116,24      12064 /dev/snd/pcmC0D0c
    rec     12639 user   5u   CHR  116,0      12099 /dev/snd/controlC0

    instead with xvidcap

    xvidcap 11323 user    8w   CHR   14,3      12071 /dev/dsp

    thank you

    • Karl H. Beckers

      Karl H. Beckers - 2008-07-12

      the main thing for xvidcap is that it requires oss because that's what ffmpeg does.
      All your other apps typically use alsa or even a sound daemon like artsd, esd, pulseaudio. To test your setup with sox do:

      sox -t ossdsp /dev/dsp test.wav

      Then play that file back.
      I cannot really test mic sampling with current svn atm, because I have none with me. But piped audio input works and I cannot test /dev/dsp input from playing back an audio file because I cannot set up the mixer on this stupid intel HDA chipset on this laptop.
      Will test with a mic later (perhaps tomorrow).


    • Nobody/Anonymous

      sox -t ossdsp /dev/dsp test.wav
      sox soxio: Failed reading `/dev/dsp': unknown file type `ossdsp'

    • Karl H. Beckers

      Karl H. Beckers - 2008-07-13

      This means you don't have the oss stuff for sox installed, so none of the sox based tests you did were testing the right stuff. You need a package that is called "libsox-fmt-oss" on Debian or Hardy, or just "libsox-fmt-all". While you're at it, check you have "alsa-oss", too.

    • Nobody/Anonymous

      well sorry i was missing some sox library now i get audio that audio file but quality and is very bad , volume is very low

    • Nobody/Anonymous

      yep installed of course that stuff (libsox-fmt-all ) and now i have read your message alsa-oss too but the same result very noise recording and low volume

    • Karl H. Beckers

      Karl H. Beckers - 2008-07-13

      The current version works fine on my gutsy machine, see:
      Will try the microphone on my hardy laptop, later.

    • Nobody/Anonymous

      welll i am on kubuntu 8.04 (it doesn't use pulse or other stuff only alsa i think )
      what kind of mixer have you used ? Oss mixer ? :S never seen

      • Karl H. Beckers

        Karl H. Beckers - 2008-07-13

        dunno how to do this with kmix, but on gnome you just open the normal gnome-volume-control, select file->change device and pick the oss device from the list. If there is none there, your alsa oss emulation is not set up correctly (but then I suppose you wouldn't be hearing anything).

    • Nobody/Anonymous

      on my hardy laptop, recording from the mic works:
      recording from audio playback is very low volume:

      For me, I very much assume this is to do with the way alsa treats my intel hda (no recording tab in oss, no pcm recording channel). I'll research this some more.


    • Nobody/Anonymous

      well today i lost my data partition -.-'' and i have , yeah i have used every damned recover software without luck, re-installed kubuntu 8.04

      (intel alc861-vd with alsadriver )

      so this is what i have discovered:

      -first i have instelled audacity and i have recorded something lol (set every things to max and I\O alsa default)

      amazing recording is very low...

      -so i have installed sox and libsox-fmt-all 

      tried another time and :

      Now volume is very nice

      i have google another bit (boring a lot)

      and i have discoverd kmix has some silly bug (i am not pretty sure anyway )



      so my situation is very complicated

      i have a way... but it's pretty boring

      when i record my video i re-encode with     mencoder and this option .... -af volume=30

      really sick..

      !!bye and THANK YOU  so much for your support!!

    • Nobody/Anonymous

      well you can select your oss device on your gnome-mix pretty nice but in kmix there is nothing , i will search for something by terminal right now

    • Nobody/Anonymous

      well i have solved. the problem i think is this . if you select oss like sound system as normal user there is some problem i don't know it seems it's working but it doesn't so i have made:

      type  in a terminal :

      kdesudo systemsettings

      then go on

      system sound

      select OSS (open sound system)

      then change in kmix volume's controlls (boost and microphone)

      after that it should save oss settings and you can gon another time on

      systemssetting (with kdesudo ) and set autodetect

      so now i have nive volume with xvid too


    • Nobody/Anonymous

      and rememeber to go on kmix setting and set unchecked "Restore Volumes on log in"

      or you have to do that every time you log in

      thank you Karl !!

  • Rumplestiltskin

    Rumplestiltskin - 2014-12-22

    I would like to add to this troubleshooting. I downloaded xvidcap to take a snippet of a video and the audio isn't working. I do have dev/dsp and dev/audio on the drive. Tried them along with hwC0D0, hwC0D1.
    There is no audio (buzzing etc) and no error msg. Just silence.
    I'm running Debian 7.0 if that helps.
    If anyone knows the file that I should link to under the audio settings, I sure would appreciate it.

    Last edit: Rumplestiltskin 2014-12-22

Log in to post a comment.