#62 ./configure - libXdamage

SVN
closed-fixed
2
2007-04-07
2007-02-03
No

Not a biggie: Just thought you would want to know that it appears that configure is not checking to see if libXDamage is installed.

-J

if gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPACKAGE_LOCALE_DIR=\""/usr/local/share/locale"\" -DPACKAGE_SRC_DIR=\""."\" -DPACKAGE_DATA_DIR=\""/usr/local/share"\" -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libglade-2.0 -I/usr/include/libxml2 -Wall -g -g -O2 -I /data/install/xvidcap-svn/xvidcap/trunk -I/data/install/xvidcap-svn/xvidcap/trunk/ffmpeg/libavcodec -I/data/install/xvidcap-svn/xvidcap/trunk/ffmpeg/libavformat -I/data/install/xvidcap-svn/xvidcap/trunk/ffmpeg/libavutil -I/data/install/xvidcap-svn/xvidcap/trunk/ffmpeg/libswscale -MT capture.o -MD -MP -MF ".deps/capture.Tpo" -c -o capture.o capture.c; \ then mv -f ".deps/capture.Tpo" ".deps/capture.Po"; else rm -f ".deps/capture.Tpo"; exit 1; fi
In file included from capture.c:79:
job.h:39:36: error: X11/extensions/Xdamage.h: No such file or directory
capture.c: In function ‘XGetZPixmap’:

Discussion

  • Jesse Litton

    Jesse Litton - 2007-02-03
    • priority: 5 --> 2
     
  • Karl H. Beckers

    Karl H. Beckers - 2007-02-06
    • assigned_to: nobody --> charly4711
    • status: open --> pending-fixed
     
  • Karl H. Beckers

    Karl H. Beckers - 2007-02-06

    Logged In: YES
    user_id=782084
    Originator: NO

    minor correction: configure does check, but job.h did not properly adhere to the results. That's fixed in SVN, though the whole xdamage stuff still needs more QA.

     
  • Jesse Litton

    Jesse Litton - 2007-02-09

    Logged In: YES
    user_id=210111
    Originator: YES

    Thanks for looking into that!

    Could the xdamage stuff be the cause of occasional segfaults I'm seeing?

    evil@pluto:~$ xvidcap --audio no
    Segmentation fault

    The segfaults only occur immediately after pressing the record button. Sometimes I can start/stop it a half dozen times with no fault, other times the fault occurs immediately. Changing the codecs etc. doesn't not seem to affect the symptoms.

    I first noticed this in SVN a few weeks back, but as I've only updated sporadically in the last few months, and had no time to troubleshoot it further, I haven't taken the time to write up a bug yet.

    Thanks for the cool program,
    J

     
  • Jesse Litton

    Jesse Litton - 2007-02-09
    • status: pending-fixed --> open-fixed
     
  • Karl H. Beckers

    Karl H. Beckers - 2007-02-10
    • status: open-fixed --> closed-fixed
     
  • Karl H. Beckers

    Karl H. Beckers - 2007-02-10

    Logged In: YES
    user_id=782084
    Originator: NO

    could well be. please file a new bug with description and attach a backtrace and possibly the core dump.
    To do that do this:
    - open a terminal
    - ulimit -c unlimited
    - start xvidcap from the command line
    - produce a crash
    - the terminal should say smth. like "segfault (core dumped)"
    - find the core file ("core" or "core.876868" or smth. like that)
    - gdb <path-to-xivdcap/xvidcap> <absolut-filename-for-core-file>
    - type bt and copy paste the output

    If you produce multiple and all backtraces look similar, one should be enough.
    If you compress the core file and it is of a remotely usable size, attach it to the bug report. multi-threading might render the simple backtrace not so useful.

    Thanks,
    Karl.

    btw. closing this one.

     
  • Jesse Litton

    Jesse Litton - 2007-03-21

    Logged In: YES
    user_id=210111
    Originator: YES

    When I recompiled SVN after upgrading Saturday, I noticed that the compile still fails if you don't have libXdamage-dev installed. The error didn't immediately indicate Xdamage, but installing it corrected the issue.

    -J

     
  • Karl H. Beckers

    Karl H. Beckers - 2007-03-21

    Logged In: YES
    user_id=782084
    Originator: NO

    will check again (artificially remove xdamage-dev)

     
  • Karl H. Beckers

    Karl H. Beckers - 2007-03-21
    • status: closed-fixed --> open-fixed
     
  • Karl H. Beckers

    Karl H. Beckers - 2007-03-23

    Logged In: YES
    user_id=782084
    Originator: NO

    should be fixed in svn, now

     
  • Karl H. Beckers

    Karl H. Beckers - 2007-03-23
    • status: open-fixed --> pending-fixed
     
  • SourceForge Robot

    • status: pending-fixed --> closed-fixed
     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks