xslt-process install/usage problem

Help
sean oc
2001-05-03
2001-05-10
  • sean oc

    sean oc - 2001-05-03

    Hello,
    I am a poor xemacs newbie, trying to read through the steps for using xslt-process. I have probably done several silly things, I feel I am close.

    My immediate problem is the following error message when I try to load an xml file:
    File mode specification error: (file-error "Cannot open load file" "gud" )

    So, I am assuming gud is in the Elib package, which I believe is installed. In my troubleshooting, I uninstalled the xemacs (21.1?) rpm which came with Redhat 7.1 and tried to install 21.4.x). I succeded in getting the package tools to work, so I can get a list of packages, resolve their dependancies, and install the needed files. I did this with xslt-process, getting many addition (and expected) packages for the dependancies, and did the install.

    I think there were some hitches along the way, but I'm 80% confident xslt-process installed fine. I can see the menu options for sgml modify move dtd, and they seem to work ok. Of course that is probably just the sgml mode in place, not actually the xslt mode. When I try C-c C-x C-v I get C-c C-x not defined.

    Can anyone point me in the right direction for what to look for next? I do have another install of Redhat 7.1 with the original XEmacs 21.2 install to test against if that helps. I also have the sumo package, with everything, but I missed something about how to install that, as untarring it in the /usr/local/lib/xemacs/xemacs-packages dir did not help.
    TIA

    Sean

     
    • Ovidiu Predescu

      Ovidiu Predescu - 2001-05-03

      You need to follow the instructions described in the XSLT-process manual, section 3.2, "Setting up PSGML with XSLT-process".

      Also make sure you're using not using the XEmacs package xslt-process-1.01.tar.gz as it's not complete. You can get the 1.03 version of it from the pre-releases area (in XEmacs go to Options -> Manage packages -> Add Download Site -> Pre-Releases). You can also install the 1.2.2 version from SourceForge as described in the manual.

      Please let me know if this worked for you.

      Ovidiu

       
      • sean oc

        sean oc - 2001-05-07

        As I suspected, I missed something(s) basic. I thought I had the debug package loaded, but in fact, I did not. The gud error message went away once I installed the xemacs debug package. Still working through the classpath issues for the XSLT processor.

        I have cocoon set to work with apache and tomcat 3.2.1. When I try C-c C-x C-v I get the error:
        'Could not process file, most probably Xalan1 could not be found!'

        I'm not sure why I've had trouble (apart from the obvious, being an XEmacs newbie :-) ). I've finally gotten the transformation to work. I tried setting the XSLT group customizations, but that did not work so well. Even with the explicit path to either cocoon1.8 or xalan, I got failure messages regarding the processor not being found.

        In the end, I took the easy way out, and just put them both in $JAVA_HOME/jre/lib/ext/. It seems to work now with a default processor of xalan. If anyone else has information or tips, I'd love to see them. I did see someone mention the following snippet (via bean shell):
        http://www.mail-archive.com/jde%40sunsite.auc.dk/msg04228.html
        whichClass("xslt.Xalan1")

        which I thought was quite enlightening (for a newbie like me).

        Anyway, I think I am now ready to start being productive. This project looks good, thanks for the time and effort.

         
        • Ovidiu Predescu

          Ovidiu Predescu - 2001-05-10

          You may want to check the reply I gave on a similar topic on the xslt-process-users mailing list:

          http://www.geocrawler.com/lists/3/SourceForge/10811/0/5715204/

          Thanks for your comments on the project. I hope the next release, on which I'm currently still working, will be even more useful. It includes an XSLT debugger and a completely reworked implementation. It is no longer based on BSH, so hopefully things will be a lot easier to setup.

          Regards,
          Ovidiu

           
    • Mykola Nikishov

      Mykola Nikishov - 2001-05-08

      > So, I am assuming gud is in the Elib package,
      no, gud.el is in debug package

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks