application crash when click on download ... fatal error has been detected by the Java Runtime Environment:

  • Anonymous - 2014-03-06

    (EDIT: by gnosygnu to add formatting)

    Crash happening in java version 1.7 as well as in 1.8 in ubuntu 13.10 64 bit release official ubuntu kernel version 3.11.0-18-generic.
    Cannot attached crash dump file because there is not possible to attached it unfortunately.

    version:; build date: 2014-03-02 21:14
      **** NONE ****
      use --help to show help
    cache_mgr.init:fatal error: err=exec nonQuery failed -- sql='INSERT INTO xowa_cfg (cfg_grp, cfg_key, cfg_val) VALUES ('fsdb.cache', 'next_id', '1')' err='class java.sql.SQLException columns cfg_grp, cfg_key are not unique [java.sql.SQLException]' []
    /usr/share/themes/Loma/gtk-2.0/gtkrc:47: Murrine configuration option "hilight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
    /usr/share/themes/Loma/gtk-2.0/gtkrc:49: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
    /usr/share/themes/Loma/gtk-2.0/gtkrc:50: Murrine configuration option "gradients" is no longer supported and will be ignored.
    # A fatal error has been detected by the Java Runtime Environment:
    #  SIGSEGV (0xb) at pc=0x00007fe108f7ac0a, pid=16384, tid=140604496742144
    SIGSEGV (0xb) at pc=0x00007fe108f7ac0a, pid=16384, tid=140604496742144
    # JRE version: Java(TM) SE Runtime Environment (7.0_51-b13) (build 1.7.0_51-b13)
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (24.51-b03 mixed mode linux-amd64 compressed oops)
    # Problematic frame:
    # C  []  _dl_rtld_di_serinfo+0x293a
    # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
    # An error report file with more information is saved as:
    # /media/u1/USB2Text4/_ajbos/developer/doc/xowa/hs_err_pid16384.log
    # If you would like to submit a bug report, please visit:
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
    Aborted (core dumped)
    Last edit: gnosygnu 2014-03-07
  • Anselm D

    Anselm D - 2014-03-06

    Just a question/statement before gnosygnu is able to have a look at it.


    Your are using Java 1.7
    JRE version: Java(TM) SE Runtime Environment (7.0_51-b13) (build 1.7.0_51-b13)

    but the path is set to: Java 8

    Environment Variables:

    Last edit: Anselm D 2014-03-06
  • gnosygnu

    gnosygnu - 2014-03-07

    @Anselm: Thanks for pointing it out.

    @martin: Thanks for the report and the numerous logs. Can you try changing your path as Anselm suggested?

    Also, I don't have a spare machine to set up Ubuntu 13.10. My main Linux box is Kubuntu 13.04, and I can't install anything on it at the moment.

    I did download a Ubuntu Live 13.10 version:

    This has a slightly older kernel (3.11.0-12-generic), but I can't see the kernel version making a difference.

    I was able to run XOWA on both openjdk-7 and oracle-8 with the Live image: sh

    RSI=0x00007fded976e3d0: <offset 0x3d0=""> in /media/u1/USB2Text4/_ajbos/developer/doc/xowa/bin/linux_64/xulrunner/ at 0x00007fded976e000

    The logs indicate a failure at xulrunner and

    XOWA packages the 64-bit xulrunner from Mozilla, so I doubt there are any problems with the binary.

    Can you try running it in HTTP Server mode?

    • Run "java -jar xowa_linux_64.jar --app_mode http_server --http_server_port 8080" or in your case, "/usr/lib/jvm/java-8-oracle/bin/java
      -jar /media/u1/USB2Text4/_ajbos/developer/doc/xowa/xowa/xowa_linux_64.jar --app_mode http_server --http_server_port 8080"
    • Open up a web browser and navigate to localhost:8080
    • You should get the Main_Page of the home_wiki.

    If that works, then it's definitely a XUL Runner issue. I honestly don't know what to recommend, as XUL Runner is a lower level, and I don't have much flexibility there.

    At that point, could you try it with a Live Image on your side? If it still fails, then we can investigate from there.


  • Anonymous - 2014-03-07


    I am using ubuntu 13.10 wihout any difficulties with xowa v1.3.1.1..
    But i do not really work with it, i did only the import of the german wiki and did some clicks in a few articles.
    Is there anythin i can test to reproduce it? You are running Xowa from an usb2 device? NTFS?

    My system:

    $uname -a
    Linux xyx 3.11.0-17-generic #31-Ubuntu SMP Mon Feb 3 21:52:43 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

    $ java -version
    java version "1.7.0_51"
    Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
    Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

    Java Installed with:
    sudo add-apt-repository ppa:webupd8team/java
    sudo apt-get update
    sudo apt-get install oracle-java7-installer

    $ whereis java
    java: /usr/bin/java /usr/bin/X11/java /usr/share/java /usr/share/man/man1/java.1.gz

    No $JAVA_HOME is set

    $ $ echo $PATH
    /usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/ binaryr/local/games

    Cheksum of binary

    $ cksum bin/linux_64/xulrunner/
    1981509456 426448 bin/linux_64/xulrunner/

    Is there anyhing i can try to compare our systems?


  • gnosygnu

    gnosygnu - 2014-03-08

    Thanks Anselm

    @martin: My checksum is also the same

    1981509456 426448

    Also, my md5sum is 2d75be7a9559b3c2cd0c214859b46e36

    Based on your stack trace, I think you'd run these commands on your machine:

    cksum /media/u1/USB2Text4/_ajbos/developer/doc/xowa/bin/linux_64/xulrunner/
    md5sum /media/u1/USB2Text4/_ajbos/developer/doc/xowa/bin/linux_64/xulrunner/
  • werfoxx

    werfoxx - 2015-03-22


    even if my problem is of a bit different nature, it's the only thread I've found containing the phrase " Problematic frame:".

    Here the error message:

    Problematic frame:
    C  []

    In my case the problem is:
    I can run Xowa (version:; build date: 2015-03-09 00:48) only successful in HTTP server mode.

    After I could not import any wiki using the script mode with an existing file, I was able to download a wiki (dewiki) from wthin Xowa, the import started, then Xowa crashed. I tried the command line way of importing (I edited the "xowa_build.gfs" file) which worked well (I downloaded and decompressed the dump manually before), but Xowa still crashes when started by running the .jar or the wrapper shell script and I click on the link to the imported wiki in the navigation on the left side.

    As mentiond before, in the HTTP server mode everything works well.
    I attach a crash log.

    I also checked the checksums of the xulrunner lib as recommended above: they are equal.

    Don't hesitate to ask if anything is not clear.

    Best regards

    ---------------  S Y S T E M  ---------------
    OS:Ubuntu 14.04 (trusty)
    uname:Linux 3.16.0-31-generic #43~14.04.1-Ubuntu SMP Tue Mar 10 20:13:38 UTC 2015 x86_64
    JRE version: OpenJDK Runtime Environment (7.0_75-b13) (build 1.7.0_75-b13)
    Java VM: OpenJDK 64-Bit Server VM (24.75-b04 mixed mode linux-amd64 compressed oops)
    Derivative: IcedTea 2.5.4
    Distribution: Ubuntu 14.04 LTS, package 7u75-2.5.4-1~trusty1
    Last edit: werfoxx 2015-03-22
  • gnosygnu

    gnosygnu - 2015-03-23

    Hi! Thanks for the crash log. In short, I'd guess something's wrong with your OpenJDK. I'd try reinstalling OpenJDK 7, or upgrading to OpenJDK 8.

    I list more details below. Hope this helps

    • The problem should not be related to xulrunner. The crash is happening in download file (DownloadFil), which xulrunner does not handle.
    • The same also applies to http server mode. It doesn't call DownloadFil, so it would work fine.
    • I've looked at the code, and it's fairly basic. It just calls openConnection. See snippet below
      src_url = new;
      src_conn = (HttpURLConnection)src_url.openConnection();
    • According to the crash log, it fails in openConnection()
    j  gplx.ios.IoEngine_system.DownloadFil(Lgplx/ios/IoEngine_xrg_downloadFil;)Z+171
    • I can't think of a reason why it would fail. I've run the same code on openSUSE and Mint. I've also done Ubuntu / Kubuntu 14.4 as well.
  • werfoxx

    werfoxx - 2015-03-23


    Thank you for your suggestion to reinstall Java/OpenJDK, after I've done this Xowa runs again.

    Best regardsmdwork

  • gnosygnu

    gnosygnu - 2015-03-23

    Cool! Thanks for confirming!

  • werfoxx

    werfoxx - 2015-03-25

    Sadly, this did not last for long: after I closed the program and started it again later, it crashed with the same error code :-(

    As I don't have any programming skills and do not really understand your description which function call causes the crash, I'd like to ask if I shall report the bug to as recommended?
    I tried to find there something similar, but without success.

    Wouldn't it be more effective if you report the bug there?

    Best regards

  • gnosygnu

    gnosygnu - 2015-03-25

    Sorry to hear that. I don't think it's a bug so much as a system issue. The URL and Connection classes are pretty low-level classes.

    Try the following jar. This literally isolates it to the failing lines. I list the source code below. If it still fails, we can see if the stack trace is any different. If it doesn't, it may be something else.



    C:\>java -jar C:\Url_connection_test.jar
    Response message: OK


    public class Url_connection_test {
        public static void main(String[] args) {
            try {
                if (args.length == 0) {
                    System.out.print("please enter a url. for example:");
                String url_string = args[0];
                System.out.print("calling " + url_string + "\n");
       url = new;
       conn = (;
                System.out.print("Response message: " + conn.getResponseMessage());
            catch (Exception e) {
                System.out.print(e.getMessage() + e.getStackTrace());
    Last edit: gnosygnu 2015-03-25
  • werfoxx

    werfoxx - 2015-03-26


    I tested the jar:

    Response message: OK

    Now I removed OpenJDK 7 and installed Version 8 instead: xowa runs stable now.

    Best regards

  • gnosygnu

    gnosygnu - 2015-03-26

    Strange. I expected the jar to fail as XOWA was failing at the same spot. Hopefully OpenJDK 8 works better. Thanks.



Cancel  Add attachments

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks