I have xoops installed locally but not access

2008-11-28
2012-09-25
  • Karthikeyan D

    Karthikeyan D - 2008-11-28

    hi,
    I have xoops installed locally but cannot access able.

    Steps:

    1. After installed xoops, Login page displayed
    2. Enter admin user name and password
    3. Click user login button

    Result : again login page displayed ( Redirect to login page)

    Please give me solution...

    Thanks in advance
    D.Karthikeyan

     
    • Defkon1

      Defkon1 - 2008-11-28

      Hi

      try to check if cookies are enabled, and if you have an antivirus or a firewall try to disable it.

      don't forget that xoops project can count on a thick network of local support communities ( http://www.xoops.org/modules/xoopspartners/ ) to help users experiencing any problem with our platform. Please refer to your local support group for further info.

      have a nice a day and happy xoopsing!

       
    • Karthikeyan D

      Karthikeyan D - 2008-11-28

      Hi,
      Thank you for replay.

      I'm in india, India have not local support communities team.

      My system also Cookies enabled and no firewall but not working.

      Thanks,
      D.karthikeyan

       
    • Julian Egelstaff

      Hello, more detail in your description could help, for example:

      After you click the login button, do you get a message at the top of the screen that says something about an invalid username or password? Or does the login page just reappear immediately?

      Are you being redirected back to the front page of the site? Or the page where you can login and also request a new password?

      If you are being redirected to the page where you can request a new password, that strongly suggests that you are using the wrong username or password (maybe you mistyped it when you installed XOOPS?). You can use an MD5 generator on the web (do a search for one) and create the MD5 hash for a password, and then go into the database and in the users table, you can replace the value in the password field with the new hash you got from the generator. Then you will be certain of the password for the admin user.

      If you are being redirected to the main front page, then it is probably another problem. Are you using Internet Explorer? I have seen that kind of error happen in IE before. If you haven't tried this in Firefox, try it in Firefox. It might work. If it still doesn't work in Firefox....it is probably a cookie problem, the cookie is not being set, or at least, your session cannot be verified on the subsequent pageload.

      You said you installed this locally...if you have another web application installed locally, and it uses cookies for authentication, then those cookies could be interferring with the XOOPS cookies. Try removing all cookies for the local domain, and then logging in. That might work. Then you know it's a cookie name conflict. In that case, after you have logged in to XOOPS, got to System Admin->Preferences->General settings and turn on the option to use a custom session, and then a custom cookie name will be used. That should prevent any cookie name conflicts with other apps that you might have installed locally.

      Does this help?

      --Julian

       
    • Karthikeyan D

      Karthikeyan D - 2008-11-28

      Hi,

      Thanks for your detailed replay...

        Yes after clicking "user login" button, I got following message   "Thank you for logging in, + my user name" .
        Then redirect to login window.
      

      I given user name and password is correct.

      I'm already installed one local web application but working fine.

      This problem occur same as IE7.0 and Firefox 2.0.13

       
      • Julian Egelstaff

        Did you try deleting all the cookies in your web browser and then logging in again?

        --Julian

         
        • Karthikeyan D

          Karthikeyan D - 2008-11-28

          Hi,
          Thanks for your quick replay...
          Now I have deleted Firefox's cookies and data base field "user_mailok" =1 and "user_mailok" "tinyint(1) unsigned" drop down change to MD5

          Thanks,
          D.Karthikeyan

           
    • Julian Egelstaff

      I'm not sure what you mean by "data base field "user_mailok" =1 and "user_mailok" "tinyint(1) unsigned" drop down change to MD5" .... I don't think you need to do anything with the user_mailok field.

      Could you login after deleing the cookies in Firefox?

      --Julian

       
    • Karthikeyan D

      Karthikeyan D - 2008-11-28

      Hi,

        No, Deleting cookies and close Firefox then open our xoops login page.
        "User_mailok" field functions I have changed manually 0 to 1 from phpmyadmin side.
           Now, again changed old setting to phpmyadmin side then tried but same page redirected.
      

      Thanks,
      D.Karthikeyan

       
      • Julian Egelstaff

        If deleting the cookies isn't working, then there's not a lot I can suggest. You could try it on a real web host, it could be something about your local setup that is causing the problem.

        Sorry I can't be of more help.

        --Julian

         
    • Karthikeyan D

      Karthikeyan D - 2008-11-28

      Hi,
      Now, i'm uploading web, any problem. I will contact you

      Thanks,
      D.Karthikeyan

       
    • Karthikeyan D

      Karthikeyan D - 2008-11-28

      hi.
      Same problem as online, Can you doubt please check my testing hosted domain http://shopping.coimbatoremap.com/xoops/htdocs/

      Awaiting for your replay

       
      • Mark Boyden

        Mark Boyden - 2008-12-02

        Nowhere in this thread does it say what version you are using. So, what version of XOOPS are you using? Version 2.3.2 does what you describe. Versions 2.3.0, 2.3.1, and 2.3.2a don't have this login loop. It had something to do with the auto-login code that had a bug introduced in 2.3.2 and was fixed in the 2.3.2a release. I've done clean installs of all four and only 2.3.2 does what you describe. It even did it after cleaning sessions, browser caches, and the likes.

        Hope that helps, and if not, do turn on debugging messages and see what you can find out from there.

         
        • Karthikeyan D

          Karthikeyan D - 2008-12-03

          hi,
          Thank you for replay... My version is 2.3.2

           
          • Mark Boyden

            Mark Boyden - 2008-12-03

            alright, then, so let's try 2.3.2a and see if you experience the same problems. --m

             
      • Julian Egelstaff

        Hello, very curious. I made a user called test, pw is 12345, and sure enough, I can't get in. Login page reloads every time.

        The fact you get the "thanks for logging in" message, suggests that the system does accept the username and password. But it is then unable to retrieve your session on the subsequent pageload.

        This could be due to the database user you are using not having permission to read the session table, maybe. Or the database user you are using does not have write permission to the session table. That would be very unusual...normally the database user that is defined in the mainfile.php has global rights within the database.

        Otherwise, the only reason the session would not be retrieved is if the cookie was not correct...but the cookie is clearly being set, I can see it in the cookies for this site.

        So I'm not sure what else to say. Someone with more experience with the XOOPS authentication system might be able to help.

        The only other thing is to break our your PHP skills and start digging in the code and seeing what exactly is failing when it tries to create the session on the subsequent page load. The file where this happens is include/common.php.

        If you can identify what is failing, then that will be a strong hint for what needs fixing.

        --Julian

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks