Newby Problem: starting X11

  • Ralph Pelletier

    Ralph Pelletier - 2003-01-01

    I recently installed Fink on Mac OS X 2.3. I then did a fink install xfree86-base, then a fink install xfree86-rootless. I then did a fink install gnome, and then a fink install enlightenment.

    So I run XDarwin in the applications folder and choose Rootless. It then quits on me and the Terminal spews this out:

    XFree86 Version / X Window System
    (protocol Version 11, revision 0, vendor release 6600)
    Release Date: 18 October 2002
            If the server is older than 6-12 months, or if your hardware is
            newer than the above date, look for a newer version before
            reporting problems.  (See http://www.XFree86.Org/FAQ\)
    Operating System: Darwin
    Using keymapping provided in /System/Library/Keyboards/USA.keymapping.
    _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
    _XSERVTransMakeAllCOTSServerListeners: server already running

    Fatal server error:
    Cannot establish any listening sockets - Make sure an X server isn't already running
    Quitting XDarwin...
    giving up.
    xinit:  Connection refused (errno 61):  unable to connect to X server
    xinit:  No such process (errno 3):  Server error.
    [Lizzy:~] chino%

    Does anyone know what I can do to make this work? I am new.

    • Patrik Montgomery

      Something is listening on port 6000. If you know you have something there, quit it and try again. If you don't know anything like that, try

      sudo lsof -i

      The column on the left is the process, in the one on the right you can find the port number. See if you can find anything listening on port 6000.

    • Nobody/Anonymous


      I recently got this problem also. I once had XDarwin running fine on my machine, updated to 10.2.3 in the meantime and yesterday I tried to start X for the first time after that update to 10.2.3 - which failed. I was confused and reinstalled X - which didn't help.

      I get the same output as synapticrecords does, with no process listening on port 6000.

      Maybe it's a problem with 10.2.3?


      • Nobody/Anonymous

        ...well, installing 10.2.3 did not fail but starting X. Sorry for that twisted sentence... 

    • Nobody/Anonymous

      as a point of information.

      I have a new 10.2.3 machine will latest apple updates and ADC toolkit.

      I installed X11 from fink stable.

      All works fine.

      • Nobody/Anonymous

        I removed the fink X packages and reinstalled them - still no luck. Confusingly enough, when I compiled the sources downloaded from and running make install did the job: X runs as expected. Bet, the problem was sitting in front of the iBook =o/



Log in to post a comment.