not listing all packages in fink

  • dornier328

    dornier328 - 2004-09-14

    Brand new, please bear with me...

    sudo apt-get install scribus

    (No package found.) Later realized that only 95 packages were listed. Read the FAQs, changed the config file to include unstable trees- still 95 packages. Updated Fink. No change. Uninstalled, re-installed twice. After the re-install, only 41 packages listed,  xfree86  was not one of them. Yet    sudo apt-get install xfree86-rootless    was successful and now 51 packages are listed. Am I missing something obvious?

    Any ideas? I'm not very up to speed with all this, yet. I tried searching the docs and archives. I ran out of things to try.

    Any ideas, thanks.

    Package manager version: 0.18.4
    Distribution version: 0.6.3
    MacOSX: 10.2.8
    Darwin Kernel: 6.8
    Mac Dec2002DevTools: installed

    • Martin Costabel

      Martin Costabel - 2004-09-14

      You don't say whether you ever ran "apt-get update".
      Please try the commands

         fink scanpackages
         sudo apt-get update
         sudo apt-get dist-upgrade

      If you really want to compile things from source and include also the unstable tree, run also

        fink selfupdate

      and choose "rsync" when the question is asked.

      From the binary distribution for OSX 10.2, you will only get scribus-1.0.1-15 which is now considered pretty old. If you install from source, you get scribus-1.2-1.


      • dornier328

        dornier328 - 2004-09-14

        Yes I ran the updates.

        I only ran selfupdate by point release earlier. I wasn't sure what this stuff meant. I just now ran selfupdate-rsync and update-all. Got a bunch more packages listed, now 2100 +/- up from 51.

        It does now list scribus, but only 1.1.1-1. I'll scanpackages again after it's done update-all. I didn't realize how long it would take to update dlcompat package.

        Ultimately, I want to install scribus [among other things] from source. But I'm new to all this and wanted to understand what I did wrong with Fink and what I thought was going to be easy binary packages, rather than memorize keystrokes.

        I'll post with the results after I scanpackages again.

        Thanks for your patience!

        • dornier328

          dornier328 - 2004-09-14

          Long story short...

          Removed Fink
          Installed gcc3.3 from Apple
          Fresh installation of Fink 0.6.3 from disk image
          -- 1239 packages

          Modified /sw/etc/fink.conf to include unstable trees
          -- 2994 packages

          fink selfupdate-cvs
          Package manager version: 0.22.2
          Distribution version: 0.6.3.cvs
          -- 3329 packages

          This still doesn't add up to the 4160+ packages in the database. I can only guess that certain packages are only available for Fink 0.7.0 (MacOSX 10.3), and those packages will not even be listed in Fink 0.6.3

          Does that sound right?


Log in to post a comment.