Can't stay in X Windows

Help
2002-12-12
2002-12-17
  • Greg Weinstein

    Greg Weinstein - 2002-12-12

    I d/l'd XDarwin 4.2.0 today, and it installed correctly. But when I started it, I answered "Full Screen" and saw the gray background and Xcursor. I saw twm come up with a clock, and then X exited.

    I checked here in the forums, and tried several things. I don't seem to have an .xinitrc, although X ran for a short time. I thought maybe an extra "&" might be to blame, but no.

    I upgraded to 4.2.0.1 and then 4.2.1.1. I still get kicked out of X immediately after seeing the gray background.

    What could I be doing wrong. FWIW, I have an iMac 266, 96 MB, Jaguar. Would the 96 MB be an issue (that X might not have enough memory?).

    I have 256 MB I'm installing tonight, hopefully, if that's the problem.

     
    • Greg Weinstein

      Greg Weinstein - 2002-12-12

      If this is any help:

      When I try to use startx from root, it says it can't find xinit.

      By typing XDarwinStartup -quartz, I get to the main X screen, with the X cursor, but can't do anything.

      If I try that under my account, I get the full screen or rootless question, then kicked out with the following error:

      2002-12-12 15:37:16.098 XDarwin[446]
      XDarwin 1.1.1.1
      Running in parallel with Mac OS X Quartz window server.

      Fatal server error:
      Could not create server lock file: /tmp/.X0-lock

         OsVendorFatalError
         AbortDDX
      Quitting XDarwin...

       
    • Anonymous - 2002-12-17

      For what it's worth, I am having the exact same problem.  I have tried XFree86 4.2.0 (Darwin ppc-5.x) on two different machines, both running Mac OS X 10.2.2.  I had seen this problem before with the developer pre-release version of Jaguar (can't recall which version of XFree86), so I figured it might have been a temporary incompatibility between Mac OS X and XFree86 , but apparently it's still there.

       
    • Nobody/Anonymous

      I finally got XDarwin running, by removing the & in /etc/X11/xinit/xinitrc

      But all I can get to work is twm, which I don't like too much. I want to use blackbox, so I downloaded it and tried to compile it. I thought it worked, but when I replaced twm in thw above file with blackbox, everything went to hell.

      When I tried making an .xinitrc in ~ I couldn't get XDarwin to run at all. So right now I'm stuck in twm, I am planning to try OroborosX, but I like blackbox and wanted to try it in XDarwin.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks