X font server won't start

Help
2002-12-05
2002-12-21
  • Nobody/Anonymous

    I'm getting an error attempting to start xfs on my OS X 10.2.2 machine, as follows.  Any ideas?

    TIA, Bill

    root# xfs
    xfs notice: listening on port 7100
    xfs notice: ignoring font path element /usr/X11R6/lib/X11/fonts/misc:unscaled (bad font path descriptor)
    xfs notice: ignoring font path element usr/X11R6/lib/X11/fonts/misc:unscaled/usr/X11R (bad font path descriptor)
    xfs notice: ignoring font path element sr/X11R6/lib/X11/fonts/misc:unscaled/usr/X11R6/lib/X11/fonts/Speedo/usr/X11R6/lib/X11/fonts/Type1/usr/X11R6/lib/X1 (bad font path descriptor)
    xfs notice: ignoring font path element r/X11R6/lib/X11/fonts/misc:unscaled/usr/X11R6/lib/X11/fonts/Speedo/usr/X11R6/lib/X11/fonts/Type1/usr/X11R6/lib/X (bad font path descriptor)
    xfs notice: ignoring font path element /X11R6/lib/X11/fonts/misc:unscaled/usr/X11R6/lib/X11/fonts/Speedo/usr/X11R6/lib/X11/fonts/Type1/usr/X11R6/lib/X (bad font path descriptor)
    xfs notice: ignoring font path element X11R6/lib/X11/fonts/misc:unscaled/usr/X11R6/li (bad font path descriptor)
    xfs notice: ignoring font path element 11R6/lib/X11/fonts/misc:unscaled/usr/X11R6/lib/X11/fonts/Speedo/usr/X11R6/lib/X11/font (bad font path descriptor)
    *** malloc[7143]: Deallocation of a pointer not malloced: 0x228fd0; This could be a double free(), or free() called with the middle of an allocated block; Try setting environment variable MallocHelp to see tools to help debug
    xfs error: Element #0 (starting at 0) of font path is bad or has a bad font:
    "/usr/X11R6/lib/X11/fonts/misc:unscaled,/usr/X11R6/lib/X11/fonts/Speedo,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/CID,/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X11/fonts/100dpi:unscaled,/usr/X11R6/lib/X11/fonts/TTF"
    Abort
    root#

     
    • Torrey T. Lyons

      Torrey T. Lyons - 2002-12-21

      This is a know bug that is in our bug database. You can check there to track the progress on resolving it.

       

Log in to post a comment.